VPN slows startup for just a couple of apps

I’m seeing some very strange VPN behavior. When connected to the VPN, everything works except for just two apps, which take a very long time to start up – about two minutes – after which they run normally. One is the file manager thunar, and one is a (somewhat obscure) wine application AceMoney. Everything else starts normally, including other wine applications, LibreOffice apps, Firefox, Chromium, Vivaldi, etc. The internet connection through the browsers is fine, both with and without VPN connected. AceMoney is a quite old Windows app from the 2000’s that I’ve been running for years, and is very unlikely to “phone home” or do anything else that requires an internet connection. Neither should a file manager like thunar. Disconnecting from the VPN restores normal behavior for all apps.

I an using ProtonVPN (paid version). I have used their v. 4 from the AUR (proton-vpn-gtk-app), and also tried connecting directly with wireguard. Both connect without problem, but show the same issue. Kernel is 6.6.26-1-MANJARO x86_64 fwiw.

Does anyone have any thoughts on a cause, or maybe some steps to diagnose? I used nethogs to look for strange network activity and saw nothing unusual. I also tried installing a different file manager PCmanFM and it does have the same delayed startup behavior.

Thanks for any suggestions!

Do you have something like external drives mounted or network shares ?

I do have a usb external HDD attached to my router, which I network-mount automatically via fstab. I also have dropbox running, which I am suspicious might be the issue (though I’m not sure how). I will try disconnecting those and report back.
Thanks for responding.

That’s the culprit. It will try to mount your network disk but because you’re not on the same network anymore, it will timeout.


That was it, thanks! Kind of kills my use of the VPN though, because I was using that drive for backup via a cron job. Guess I’ll look into putting the VPN on the router.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.