VPN service stopped unexpectedly

Trying to connect to VPNBOOK.

Have imported config files from VPNBOOK site and installed them as follows:

  1. Download the openvpn profiles
  2. Left-click on network icon in desktop panel and choose VPN Conections followed by Configure VPN, to open the Network Connections dialog.
  3. Select VPN and click the + button to see the Choose a Connection Type dialog.
  4. Choose Import a saved VPN configuration… under VPN and select the Create button to see a dialog allowing selection of an downloaded ovpn configuration.
  5. Choose an Import a saved configuration and select the Open button to display the Editing connection dialog.
  6. Specify the password published on the VPNBOOK site
  7. Choose Save to save the new VPN connection.

Now left-click on the network icon on the desktop panel and select VPN Connections… to see a list of available VPN connections.

After making a selection, see the following dialog stating “VPN connection failed”:
VPN service stopped unexpectedly

Have openvpn and networkmanager-openvpn installed.
User profile is a member of nm-openconnect and nm-openvpn

Had this working before for a long time…

I just had the same problem.
My solution was to close, in my case, the Wi-Fi connection and reset it.
Why it failed, I have no idea but resetting the connection fixed it.

Using cable mot using wi-fi.
Selecting Disconnect followed by ‘Wired Connection 1’ makes no difference.

Following instructions for how to setup openvpn at vpnbook, get:

# openvpn --config vpnbook-pl226-tcp80.ovpn
2022-11-23 12:39:38 WARNING: Compression for receiving enabled. Compression has been used in the past to break encryption. Sent packets are not compressed unless "allow-compression yes" is also set.
2022-11-23 12:39:38 DEPRECATED OPTION: --cipher set to 'AES-128-CBC' but missing in --data-ciphers (AES-256-GCM:AES-128-GCM). Future OpenVPN version will ignore --cipher for cipher negotiations. Add 'AES-128-CBC' to --data-ciphers or change --cipher 'AES-128-CBC' to --data-ciphers-fallback 'AES-128-CBC' to silence this warning.
2022-11-23 12:39:38 OpenVPN 2.5.8 [git:makepkg/0357ceb877687faa+] x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Nov  1 2022
2022-11-23 12:39:38 library versions: OpenSSL 3.0.7 1 Nov 2022, LZO 2.10
Enter Auth Username: vpnbook
🔐 Enter Auth Password: *******                 
2022-11-23 12:40:16 WARNING: No server certificate verification method has been enabled.  See http://openvpn.net/howto.html#mitm for more info.
2022-11-23 12:40:16 NOTE: --fast-io is disabled since we are not using UDP
2022-11-23 12:40:16 OpenSSL: error:0A00018E:SSL routines::ca md too weak
2022-11-23 12:40:16 Cannot load inline certificate file
2022-11-23 12:40:16 Exiting due to fatal error

For OpenVPN version:

# openvpn --version
OpenVPN 2.5.8 [git:makepkg/0357ceb877687faa+] x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Nov  1 2022
library versions: OpenSSL 3.0.7 1 Nov 2022, LZO 2.10
Originally developed by James Yonan
Copyright (C) 2002-2022 OpenVPN Inc <sales@openvpn.net>
Compile time defines: 

As per url for WARNING for cmd:
#openvpn --config vpnbook-pl226-tcp80.ovpn,

Then: RSA Key Management

and then 2x HowTo:

and then OpenVPN Quickstart:

Need to experiment to get working.

You’ll have to contact your provider for an updated ca cert on their end. See here for more info: [Stable Update] 2022-11-14 - Kernels, GNOME 43.1, Plasma 5.26.3, Systemd 251.8, Firefox 106.0.5, Thunderbird, LXQt - #152 by annoying_daniel