VPN no longer automatically connecting

Hello,

Since 1 month, my VPN stop to autoconnect at boot. I used GNOME manjaro. I tried this (old forum) but it’s not working:

Start with

nmcli connection

You should see a list with all connections available. Pick the Ethernet or Wifi connection which will be the underlying connection for the VPN.

nmcli connection edit MyEthernet 

or

nmcli connection edit d55555c5-5555-7777-7777-a555555f777a

now you are in the nmcli interactive mode. Then use

set connection.secondaries d44444c5-44444-8888-8888-a444445f666a

The Tab Key should work as in every normal Terminal and can help you. On the set command, don’t use a vpn name, use the uuid number of your VPN connection.

At the end you need to save the change and quit the interactive mode, just type in

save
quit

After that restart your connections or do a reboot.

Any ideas ? Thanks !

:+1: Welcome to Manjaro! :+1:

Please read this:


and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

An inxi --admin --verbosity=7 --filter --no-host would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command) and in your specific case, what is the Ethernet or WiFi connection name you want to use and what is the UUID of your VPN connection?

:innocent:

P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU you have, …

1 Like

Thanks for welcoming me (back) to Manjaro :slightly_smiling_face:

Here more informations:

  • Name of my Ethernet connection: Internet
  • Name of my Ethernet connection: VPN (UUID : cabea9e2-922f-4381-a0cc-4ad95ea9e5ca)

Here the result of inxi --admin --verbosity=7 --filter --no-host:

System:
  Kernel: 5.4.62-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=95f19348-1ddf-485c-b971-d9bf6f2e88e6 rw quiet 
  Desktop: GNOME 3.36.5 tk: GTK 3.24.23 wm: gnome-shell dm: GDM 3.36.3 
  Distro: Manjaro Linux 
Machine:
  Type: Desktop System: MEDIONPC product: MS-7658 v: 1.0 serial: <filter> 
  Chassis: type: 3 serial: <filter> 
  Mobo: MEDIONPC model: MS-7658 v: 1.0 serial: <filter> 
  BIOS: American Megatrends v: A7658MLN.103 date: 06/10/2010 
Battery:
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard PID:0055 
  serial: N/A charge: 70% (should be ignored) rechargeable: yes 
  status: Discharging 
  Device-2: hidpp_battery_1 model: Logitech Wireless Mouse PID:003f 
  serial: N/A charge: 55% (should be ignored) rechargeable: yes 
  status: Discharging 
Memory:
  RAM: total: 3.77 GiB used: 1.86 GiB (49.2%) 
  RAM Report: 
  permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Topology: Dual Core model: Intel Core i5 650 bits: 64 type: MT MCP 
  arch: Nehalem family: 6 model-id: 25 (37) stepping: 5 microcode: 7 
  L2 cache: 4096 KiB bogomips: 25549 
  Speed: 1203 MHz min/max: 1200/3201 MHz boost: enabled Core speeds (MHz): 
  1: 1239 2: 1200 3: 1279 4: 1279 
  Flags: acpi aes aperfmperf apic arat arch_perfmon bts clflush cmov 
  constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts ept est 
  flexpriority flush_l1d fpu fxsr ht ibpb ibrs ida lahf_lm lm mca mce mmx 
  monitor msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pebs 
  pge pni popcnt pse pse36 pti rdtscp rep_good sep smx ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc vme vmx vnmi vpid 
  xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode; 
  SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: AMD Redwood XT [Radeon HD 5670/5690/5730] vendor: Elite Systems 
  driver: radeon v: kernel bus ID: 01:00.0 chip ID: 1002:68d8 
  Display: x11 server: X.org 1.20.8 compositor: gnome-shell 
  driver: ati,radeon unloaded: modesetting alternate: fbdev,vesa 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: AMD REDWOOD (DRM 2.50.0 / 5.4.62-1-MANJARO LLVM 10.0.1) 
  v: 3.3 Mesa 20.1.7 compat-v: 3.1 direct render: Yes 
Audio:
  Device-1: Intel 5 Series/3400 Series High Definition Audio 
  vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:3b56 
  Device-2: AMD Redwood HDMI Audio [Radeon HD 5000 Series] 
  vendor: Elite Systems driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  chip ID: 1002:aa60 
  Device-3: Creative Labs CA0110 [Sound Blaster X-Fi Xtreme Audio] 
  driver: snd_hda_intel v: kernel bus ID: 04:00.0 chip ID: 1102:0009 
  Sound Server: ALSA v: k5.4.62-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Micro-Star MSI driver: r8169 v: kernel port: e800 bus ID: 02:00.0 
  chip ID: 10ec:8168 
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
  IP v4: <filter> type: noprefixroute scope: global broadcast: <filter> 
  IP v6: <filter> virtual: stable-privacy scope: link 
  WAN IP: <filter> 
Drives:
  Local Storage: total: 1.14 TiB used: 27.72 GiB (2.4%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB 
  block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  serial: <filter> rev: 2B6Q scheme: MBR 
  ID-2: /dev/sdb vendor: Seagate model: ST31000528AS size: 931.51 GiB 
  block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: CC44 scheme: MBR 
  ID-3: /dev/sdc type: USB model: Multiple Card Reader size: 7.46 GiB 
  block size: physical: 512 B logical: 512 B serial: <filter> rev: 1.00 
  scheme: MBR 
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVDRAM GH22NS50 rev: TN02 
  dev-links: cdrom 
  Features: speed: 48 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
RAID:
  Message: No RAID data was found. 
Partition:
  ID-1: / raw size: 107.42 GiB size: 105.48 GiB (98.20%) 
  used: 27.01 GiB (25.6%) fs: ext4 dev: /dev/sda4 label: N/A 
  uuid: 95f19348-1ddf-485c-b971-d9bf6f2e88e6 
  ID-2: /run/media/tifriis/B81A-F9E0 raw size: 7.46 GiB 
  size: 7.44 GiB (99.79%) used: 721.3 MiB (9.5%) fs: vfat dev: /dev/sdc1 
  label: N/A uuid: B81A-F9E0 
Swap:
  Alert: No Swap data was found. 
Unmounted:
  ID-1: /dev/sda1 size: 100.0 MiB fs: ntfs 
  label: R\xc3\xa9serv\xc3\xa9 au syst\xc3\xa8me uuid: 6EB01F94B01F61BF 
  ID-2: /dev/sda2 size: 112.53 GiB fs: ntfs label: N/A 
  uuid: 4C1020E71020D9AA 
  ID-3: /dev/sda3 size: 530.0 MiB fs: ntfs label: N/A uuid: 3CCC0F57CC0F0B3A 
  ID-4: /dev/sdb1 size: 931.51 GiB fs: ntfs label: N/A 
  uuid: 4E316F0F22954018 
USB:
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Hub: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip ID: 8087:0020 
  Device-1: 1-1.3:3 info: Logitech LX710 Cordless Desktop Laser 
  type: Keyboard,Mouse driver: logitech-djreceiver,usbhid interfaces: 2 
  rev: 1.1 speed: 1.5 Mb/s chip ID: 046d:c517 
  Device-2: 1-1.4:4 info: Sunplus Innovation Optical Mouse type: Mouse 
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s 
  chip ID: 1bcf:0005 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Hub: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0 
  speed: 480 Mb/s chip ID: 8087:0020 
  Device-1: 2-1.3:3 info: Alcor Micro Multi Flash Reader type: Mass Storage 
  driver: usb-storage interfaces: 1 rev: 2.0 speed: 480 Mb/s 
  chip ID: 058f:6366 serial: <filter> 
Sensors:
  System Temperatures: cpu: 23.0 C mobo: N/A gpu: radeon temp: 54 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 223 Uptime: 11m Init: systemd v: 246 Compilers: gcc: 10.2.0 
  Packages: pacman: 1172 lib: 319 flatpak: 0 Shell: Bash v: 5.0.18 
  running in: gnome-terminal inxi: 3.1.05

Thanks !

:grin:

Luckily I asked for the inxi as well as your Ethernet connection name is enp2s0 and that’s probably where you got stuck (Have a look at the network section of your own inxi as the ÌF means “InterFace” and that is network speak for “name”. :wink: )

so simply doing:

nmcli connection edit enp2s0 

and then:

set connection.secondaries cabea9e2-922f-4381-a0cc-4ad95ea9e5ca
save
quit

should do the trick.

:innocent:

1 Like

Thanks for your help but I’m not sure it’s correct. Here what I got with $ nmcli connection

NAME      UUID                                  TYPE      DEVICE 
VPN       cabea9e2-922f-4381-a0cc-4ad95ea9e5ca  vpn       enp2s0 
Internet  752d809c-a153-46d1-9a34-de12c37a64d7  ethernet  enp2s0 

enp2s0 isn’t the name but the device.

I tried to use UUID instead of name and it seems to be a little bit better but when i restart my computeur, my wired connexion is shutdown and I have to active it manually. But when i activate it, the VPN auto start. Any ideas ? And sorry for my english, it’s not my native tongue.

Moi non plus… :stuck_out_tongue_winking_eye:

Urgh… Yes, that’s the devicename.

Try:

nmcli connection modify Internet connection.autoconnect yes 

and if that doesn’t work, please provide the output of:

nmcli connection show Internet

:innocent:

Bien vu :joy:

I tried:

nmcli connection modify Internet connection.autoconnect yes 

but my wired still shutdown when I start my computer.

Here the long result of:

nmcli connection show Internet
connection.id:                          Internet
connection.uuid:                        752d809c-a153-46d1-9a34-de12c37a64d7
connection.stable-id:                   --
connection.type:                        802-3-ethernet
connection.interface-name:              --
connection.autoconnect:                 oui
connection.autoconnect-priority:        0
connection.autoconnect-retries:         -1 (default)
connection.multi-connect:               0 (default)
connection.auth-retries:                -1
connection.timestamp:                   1599813049
connection.read-only:                   non
connection.permissions:                 --
connection.zone:                        --
connection.master:                      --
connection.slave-type:                  --
connection.autoconnect-slaves:          -1 (default)
connection.secondaries:                 cabea9e2-922f-4381-a0cc-4ad95ea9e5ca
connection.gateway-ping-timeout:        0
connection.metered:                     inconnu
connection.lldp:                        default
connection.mdns:                        -1 (default)
connection.llmnr:                       -1 (default)
connection.wait-device-timeout:         -1
802-3-ethernet.port:                    --
802-3-ethernet.speed:                   0
802-3-ethernet.duplex:                  --
802-3-ethernet.auto-negotiate:          non
802-3-ethernet.mac-address:             --
802-3-ethernet.cloned-mac-address:      --
802-3-ethernet.generate-mac-address-mask:--
802-3-ethernet.mac-address-blacklist:   --
802-3-ethernet.mtu:                     auto
802-3-ethernet.s390-subchannels:        --
802-3-ethernet.s390-nettype:            --
802-3-ethernet.s390-options:            --
802-3-ethernet.wake-on-lan:             default
802-3-ethernet.wake-on-lan-password:    --
ipv4.method:                            auto
ipv4.dns:                               --
ipv4.dns-search:                        --
ipv4.dns-options:                       --
ipv4.dns-priority:                      0
ipv4.addresses:                         --
ipv4.gateway:                           --
ipv4.routes:                            --
ipv4.route-metric:                      -1
ipv4.route-table:                       0 (unspec)
ipv4.routing-rules:                     --
ipv4.ignore-auto-routes:                non
ipv4.ignore-auto-dns:                   non
ipv4.dhcp-client-id:                    --
ipv4.dhcp-iaid:                         --
ipv4.dhcp-timeout:                      0 (default)
ipv4.dhcp-send-hostname:                oui
ipv4.dhcp-hostname:                     --
ipv4.dhcp-fqdn:                         --
ipv4.dhcp-hostname-flags:               0x0 (none)
ipv4.never-default:                     non
ipv4.may-fail:                          oui
ipv4.dad-timeout:                       -1 (default)
ipv6.method:                            auto
ipv6.dns:                               --
ipv6.dns-search:                        --
ipv6.dns-options:                       --
ipv6.dns-priority:                      0
ipv6.addresses:                         --
ipv6.gateway:                           --
ipv6.routes:                            --
ipv6.route-metric:                      -1
ipv6.route-table:                       0 (unspec)
ipv6.routing-rules:                     --
ipv6.ignore-auto-routes:                non
ipv6.ignore-auto-dns:                   non
ipv6.never-default:                     non
ipv6.may-fail:                          oui
ipv6.ip6-privacy:                       -1 (unknown)
ipv6.addr-gen-mode:                     stable-privacy
ipv6.ra-timeout:                        0 (default)
ipv6.dhcp-duid:                         --
ipv6.dhcp-iaid:                         --
ipv6.dhcp-timeout:                      0 (default)
ipv6.dhcp-send-hostname:                oui
ipv6.dhcp-hostname:                     --
ipv6.dhcp-hostname-flags:               0x0 (none)
ipv6.token:                             --
proxy.method:                           none
proxy.browser-only:                     non
proxy.pac-url:                          --
proxy.pac-script:                       --
GENERAL.NAME:                           Internet
GENERAL.UUID:                           752d809c-a153-46d1-9a34-de12c37a64d7
GENERAL.DEVICES:                        enp2s0
GENERAL.IP-IFACE:                       enp2s0
GENERAL.STATE:                          activé
GENERAL.DEFAULT:                        non
GENERAL.DEFAULT6:                       non
GENERAL.SPEC-OBJECT:                    --
GENERAL.VPN:                            non
GENERAL.DBUS-PATH:                      /org/freedesktop/NetworkManager/ActiveConnection/9
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/Settings/2
GENERAL.ZONE:                           --
GENERAL.MASTER-PATH:                    --
IP4.ADDRESS[1]:                         192.168.1.58/24
IP4.GATEWAY:                            192.168.1.1
IP4.ROUTE[1]:                           dst = 0.0.0.0/0, nh = 192.168.1.1, mt = 100
IP4.ROUTE[2]:                           dst = 212.83.148.123/32, nh = 192.168.1.1, mt = 100
IP4.ROUTE[3]:                           dst = 192.168.1.1/32, nh = 0.0.0.0, mt = 100
IP4.ROUTE[4]:                           dst = 192.168.1.0/24, nh = 0.0.0.0, mt = 100
IP4.DNS[1]:                             192.168.1.1
DHCP4.OPTION[1]:                        dhcp_lease_time = 86400
DHCP4.OPTION[2]:                        domain_name_servers = 192.168.1.1
DHCP4.OPTION[3]:                        expiry = 1599896468
DHCP4.OPTION[4]:                        host_name = tifriis-pc
DHCP4.OPTION[5]:                        ip_address = 192.168.1.58
DHCP4.OPTION[6]:                        next_server = 192.168.1.1
DHCP4.OPTION[7]:                        ntp_servers = 192.168.1.1
DHCP4.OPTION[8]:                        requested_broadcast_address = 1
DHCP4.OPTION[9]:                        requested_domain_name = 1
DHCP4.OPTION[10]:                       requested_domain_name_servers = 1
DHCP4.OPTION[11]:                       requested_domain_search = 1
DHCP4.OPTION[12]:                       requested_host_name = 1
DHCP4.OPTION[13]:                       requested_interface_mtu = 1
DHCP4.OPTION[14]:                       requested_ms_classless_static_routes = 1
DHCP4.OPTION[15]:                       requested_nis_domain = 1
DHCP4.OPTION[16]:                       requested_nis_servers = 1
DHCP4.OPTION[17]:                       requested_ntp_servers = 1
DHCP4.OPTION[18]:                       requested_rfc3442_classless_static_routes = 1
DHCP4.OPTION[19]:                       requested_root_path = 1
DHCP4.OPTION[20]:                       requested_routers = 1
DHCP4.OPTION[21]:                       requested_static_routes = 1
DHCP4.OPTION[22]:                       requested_subnet_mask = 1
DHCP4.OPTION[23]:                       requested_time_offset = 1
DHCP4.OPTION[24]:                       requested_wpad = 1
DHCP4.OPTION[25]:                       routers = 192.168.1.1
DHCP4.OPTION[26]:                       subnet_mask = 255.255.255.0
IP6.ADDRESS[1]:                         fe80::ec04:678:3d9c:c180/64
IP6.GATEWAY:                            --
IP6.ROUTE[1]:                           dst = fe80::/64, nh = ::, mt = 100
IP6.ROUTE[2]:                           dst = ff00::/8, nh = ::, mt = 256, table=255

Merci!

That’s not normal:

That should be enp2s0 as per your inxi!

:open_mouth:

Did you do anything else like enable airplane mode?

If not, provide just the Network: section of inxi --system --verbosity=7 --filter --no-host --admin just after boot and after activating the NIC, please?

Also in the meantime do a:

nmcli connection modify Internet connection.autoconnect-priority -999

(that’s the only thing I can see that might do something while awaiting your output)

No (I I don’t use laptop).

Here the result of inxi --system --verbosity=7 --filter --no-host --admin

Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Micro-Star MSI driver: r8169 v: kernel port: e800 bus ID: 02:00.0 
  chip ID: 10ec:8168 
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
  IP v4: <filter> type: noprefixroute scope: global broadcast: <filter> 
  IP v6: <filter> virtual: stable-privacy scope: link 
  WAN IP: <filter> 

Thanks :slight_smile:

Grasping at straws now:

Disable IPV6?

If that doesn’t help: all out of ideas, unfortunately! @megavolt You any bright ideas why an Ethernet card that has a VPN attached to it needs activating?

If @megavolt doesn’t have any ideas, I can give @tifriis a script that auto-activates it at log on… Would that help?

:sob:

P.S. tifriis est labbréviation de quoi exactement? :thinking:

@Fabby @tifriis Ok let me test it… i have a vpn connection, but never automated it. That will be fun :smiley:

ok got it working.

nmcli c modify id <id-of-ethernet> +connection.secondaries <id-of-vpn>

that set the vpn to autoconnect with ethernet.

But what i don’t understand… Why is your vpn a device? Even if i set it for autostart with ethernet, it keeps to be “–”.

Did you put interface-name=enp2s0 into the conf file? Please check it:

sudo ls /etc/NetworkManager/system-connections/

Thank you :wink:

Update

I restarted the PC and it worked fine. Because of the vpn there is a higher delay until i get a connection.

1 Like

Hello everyone, sorry for the delay !

@megavolt, here what I got with:

sudo ls /etc/NetworkManager/system-connections/
fr510.nordvpn.com.tcp.nmconnection  Internet.nmconnection

I tried:
sudo nmcli c modify id Internet +connection.secondaries cabea9e2-922f-4381-a0cc-4ad95ea9e5ca
But still dosen’t work :cry:

@Fabby I also tried to desactivated IPV6 >> no change
@Fabby tifriis est un surnom ^^

Thanks!

1 Like

I’m officially all out of bright ideas then…

:sob:

This config file: fr510.nordvpn.com.tcp.nmconnection must be this:

VPN       cabea9e2-922f-4381-a0cc-4ad95ea9e5ca  vpn       enp2s0 

But it is not a device enp2s0! This config file is wrong!

Even I’m confused what OP’s corrective action should be…

:thinking: :wink:

thanks for your help, I appreciated ! Maybe next manjaro version will solve my issue ^^ (gnome 3.38)