VPN connection auto reconnects after wake from sleep

Since a few weeks ago, when I suspend my computer while connected to a VPN (this is a Network Manager VPN connection I use), after waking up, the connection automatically resumes. This is something I don’t like, so I would like to disable it. I looked into setting of the particular VPN connection I use, but I don’t see anything regarding automatic connections.
Can anyone help me out with disabling this feature? I use this VPN only for work purposes, so I don’t want to be connected to it all the time.

in network manager, i see the checkbox for that on the settings for the ethernet connection, not the settings for the vpn.

Is automatically connect to VPN unchecked in Wired Connection/Ethernet-General

@steanne @jrichard326 unfortunately no, this is not enabled either. I would upload a screenshot, but I get an error about embedding media in a post.
I suspect this is related to some systemd configuration or something else, since it changed a few weeks ago after an update.

Have a look at man systemd-suspend.service. The relevant extract:

       Immediately before entering system suspend and/or hibernation
       systemd-suspend.service (and the other mentioned units,
       respectively) will run all executables in
       /usr/lib/systemd/system-sleep/ and pass two arguments to them.
       The first argument will be "pre", the second either "suspend",
       "hibernate", "hybrid-sleep", or "suspend-then-hibernate"
       depending on the chosen action. 

So you’d create an executable file in /usr/lib/systemd/system-sleep/ with something like this:

if [ "${1}" == "pre" ]; then
  #command to turn off VPN before suspend
elif [ "${1}" == "post" ]; then
  # Do the thing you want after resume here

Taken from Running scripts before and after suspend with systemd – Just another Linux geek