Vorta requires downgrade of pyqt5 but im confused about future updates

Vorta had an update yesterday, I updated and it fails to load. I posted on its git and was told by the dev to use the previous version of pyqt5

$ pip uninstall PyQt5-Qt5 PyQt5-Qt PyQt5
$ pip install 'pyqt5<=5.15.3'

Vorta now works, but i don’t know how to proceed from here.

Iv now got pyqt5 showing as version 5.15.3 via pip

❰greg❙~/bash❱✔≻ pip show pyqt5
Name: PyQt5
Version: 5.15.3

Iv got pyqt5 version 5.15.4-1 via yay

❰greg❙~/bash❱✔≻ yay -Qi python-pyqt5
Name            : python-pyqt5
Version         : 5.15.4-1

Iv got vorta that says it is out of date by both pip and yay but if i try to update it via yay it says

1  aur/vorta  0.7.6-1 -> 0.7.6-2
-> Could not find all required packages:
        python-pyqt5<=5.15.3 (Wanted by: vorta)

So I put vorta into “ignore” in pacman.conf, just for now, until it works again with the updated pyqt5.

I dont know if pip will update vorta or i should keep trying to update manually via pip or if im supposed to keep checking yay -S vorta? Am i supposed to update pyqt5 via pip at some point?

You could downgrade Vorta like I did. I wouldn´t downgrade system packages.

Here is the altered PKGBUILD file for 0.7.5:

Download, open terminal and run

makepkg -si

it says

❰greg❙~/Downloads❱✔≻ makepkg -si
==> Making package: vorta 0.7.5-2 (Wed 09 Jun 2021 11:37:01 BST)
==> Checking runtime dependencies...
==> Installing missing dependencies...
[sudo] password for greg: 
error: target not found: python-pyqt5<=5.15.3
==> ERROR: 'pacman' failed to install missing dependencies.
==> Missing dependencies:
  -> python-pyqt5<=5.15.3
==> Checking buildtime dependencies...
==> ERROR: Could not resolve all dependencies.

maybe im supposed to pip install pyqt5 I just dare not tinker with pip as iv never used it before.

O my mistake, python-pyqt5 is the pacman package, it wants python-pyqt5 version <=5.15.3 I just dont know what im doing.

I just don’t understand why installed pip packages are different versions than installed pacman packages on the same machine, I don’t understand if pip is supposed to check for updates to these packages or not, meh loads i don’t understand now.

Like @angrytux I didn’t want to downgrade system packages so I downgraded Vorta to version 0.7.5. I went to the AUR site and used the PKGBUILD there for the previous version PKGBUILD - aur.git - AUR Package Repositories

Hopefully the developers of Vorta will sort this issue out for the next release.

Ok, so iv downgraded vorta, its still working atm

aur/vorta 0.7.6-2 (+31 2.54) (Installed: 0.7.5-1)

❰greg❙~/Downloads❱✔≻ vorta --version
Vorta 0.7.5

but should i update pyqt5 with pip to what it was originally ? Im confused that pip says i have pyqt5 ver 5.15.3 but pacman say its ver 5.15.4-1

Should i do this?
pip install -U pyqt5

No, never update packages with pip.

Pip is the python package manager which and it’s separate from pacman. If you update packages with pip, pacman doesn’t know that you updated the package.

For these special cases, you should create a python virtual environment in which you can go crazy with pip.

I was only doing as instructed Can't run v0.7.6 with latest PyQt5 version · Issue #1011 · borgbase/vorta · GitHub as far as i can remember.

Its all working now via pacman now so i assume i got there in the end.

❰greg❙/run/media/greg❱✔≻ yay -Qi vorta
Name            : vorta
Version         : 0.7.7-1