Volume adjuster is too loud and imprecise

When I am using my headphones, 10% is already too loud. But the panel “PulseAudio” plugin only works in decrements of 5% (or I have to open the menu up and drag around bars half of which don’t seem to affect anything). Because my headphones are so amplified I lose a lot of granularity. I’m using the audio jack directly, no USB thingamabobs are involved.

Is there a way I can tell my computer “listen, when I say 75% system volume, really output 5% to the audio jack”?

In addition, the pulseaudio equalizer is introducing audible overdrive (+4db on bass, -2db on mid). Isn’t audio handled as fp32 in linux or something?

:+1: Welcome back to the Manjaro forums! :+1:

  1. Please read this:
    How to provide good information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)

  3. A pacmd dump would be helpful as well

  4. You do that per application in pavucontrol, including the system sounds.


P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU or Kernel you have, …

I suggest you reduce audio level for headphone output in ALSA to increase the useable range of PulseAudio controls

Use alsamixer in terminal to adjust audio hardware settings
Use F6 to find audio card for analog audio
Then find control for headphone output and turn it down to around 20-30%

And use this command to save new ALSA settings

sudo alsactl store

pulseaudio equalizer is introducing audible overdrive (+4db on bass, -2db on mid)

If equalizer is boosting bass by +4dB, audio level before the equalizer must be reduced by -4dB to maintain a level below distortion threshold

Audio controls in PulseAudio can have a maximum level of 150% and any level over 100% can cause distortion on some systems

PulseAudio default is usually CD quality (16bit 44.1kHz) for backward-compatibility with older systems

see this post for how to reconfigure PulseAudio
How to change audio bitrate? - #3 by nikgnomic


Using a mousewheel, audio jumps by 5%. Using the slider I can adjust it by 1% increments.

Also, I wouldn’t use equalizers for anything except for attenuating a signal.

odB is the maximum volume. You should only exceed that when the input signal is too low.
So instead of pushing bass 4dB over maximum volume, bring all other levels down to -4dB.