Vmware-workstation15 stopped working

vmware-workstation15 (as installed via AUR) stopped working with this stable update. Worked fine before updates. Reinstalled/rebuilt and tried several kernels. Give the following error

"Unable to change virtual machine power state: Transport (VMDB) error -14: Pipe connection has been broken."

Any other vmware-workstation15 user also experiencing this after this stable update?

In the meantime I’ve reverted back to before this stable update to get a working vmware workstation setup again. Happy for any ideas and/or to test those ideas/suggestions.


VMware is unsupported - rebuild your custom package.

it works for me.

ha… that’s actually quite helpful (knowing that it’s working for another user after this update) - I’m about to start digging into and seeing if I can isolate the issue.

@linub , what kernel are you running?

Many thanks.

1 Like

try following this guide:

There’s this post on vmware forums about tpm

no joy - same result/error.

Are you running vmware-workstation v15 or v16?

Thanks all - got it resolved.

Turns out it was a video issue - when I run in intel model (on my nvidia optimus2 razer blade 15). Had to disable video acceleration and things worked fine after that.

Interestingly, vid acceleration worked fine when running intel only prior to this update.

Thanks again all.