Vmware Player and new kernel version

I recently updated to kernel 6.1.12-1 from 5.15.94-1. Everything seemed to work ok, except vmware-player, which won’t launch at all. I uninstalled it, then re-installed, but the issue remains with the error message Cannot open /dev/vmmon: No such file or directory. Please make sure that the kernel module `vmmon’ is loaded. Sure enough, there is no /dev/vmmon when I checked, although this file is supposed to be made during the building process. Another error in the journal shows: FATAL: Module vmnet not found in directory /lib/modules/6.1.12-1-MANJARO process created.. So it does seem that the new kernel is failing to provide the necessarry files in compiling vmware.

Vmware has worked fine for a couple of years now, with previous kernels, although I remember I once had this issue before, and a few others, but can’t remember what I did to solve them, but do remember it took me many weeks.

Any ideas on how to solve this, or do I need to roll back to previous kernel?

There is this post on the forum about vmware that could be helpful or at least explain what to check en why.

It’s likely the kernel modules didn’t get built for the mew kernel.


Daft question but did you reboot? Had same error before with vmware, had to rebuild it and then reboot after switching kernels

Yes. Definitely rebooted. So clearly this seems like a kernel issue. Even tried command sudo modprobe -a vmw_vmci vmmon, which I seem to recall fixed the issue last time it occurred nearly 2 years ago, but it didn’t work this time around.

Now moved back to previous kernel, and all is well again.

Happy to report that the new updated kernel version Linux 6.1.19-1-MANJARO is now working with Vmware 17.0.1 Player, whereas v. 6.1.12-1 did not. No more problems, hopefully.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.