VMware - Login into Sway live environment fails

I’m trying to login into the live environment of the daily sway distribution, but when I apply the credentials I just get back to the login. I’m using VMware on a Windows 11 host.

username: manjaro
password: manjaro

In boot menu I tried to boot with source and proprietary drivers. I also tried this:

The default passwords are

  • root:manjaro
  • manjaro:manjaro
    Sway is based on the Wayland so the first that comes to mind is some kind of issue with the graphics.
    One option you could try is to edit the kernel arguments and for the kernel add the digit 3 to boot the console only. Then login and run startx.
    Another option you could try is a tip I read for vmware products editing the boot arguments for the display driver used - replacing driver=free with driver=mesa.

But not sure about the part with the kernel and digit 3.

The image file I’m using: manjaro-sway-21.1.0-minimal-220130-linux516.iso

Any ideas?


Thanks, works. It took some time to check how to read the lines. My boot line looks differently. But how can I now start the desktop environment or start the installation respectively? startx is an unknown command.

I’m on the command line and successfully logged in but I would like to discover the desktop or start the installation

startx would usually start the WM, if it is saying command not found then there may be an issue with the ISO.