VLC/MakeMKV Bluray play problem "initializing overlay"

Hello community,
I could not fix the problem on the laptop from my brother. He has an external bluray player and he has installed an activated MakeMKV and tried to play different Blurays with the same result. It always stops by the process of initializing the overlay. I could not figure out the problem, because the same program MakeMKV with VLC do work with the same BluRays on my Laptop pretty well. I do not understand what I am missing here.

The installed libbluray vs. is libbluray-awt-j2se-1.2.1.jar / libbluray.so.2.3.0.

The terminal output during the play trial of the bluray was:
libbluray demux: First play: 1, Top menu: 1
HDMV Titles: 17, BD-J Titles: 0, Other: 0
mobj_parse.c:89 MovieObject.bdmv: empty object
uint DBusMenuExporterDBus::GetLayout(int, int, const QStringList&, DBusMenuLayoutItem&): Condition failed menu
libbluraydemux: Initializing overlay

The last part repeats for eternity

The Laptop from my brother is a Asus G712LV - H7007T I7-10750H/16GB/2060 RTX
He is using the bumblebee drivers

I was having the same problem but I’m on Arch not Manjaro.

After painstakingly testing the reason why the git version of VLC(4.0) works with makemkv and not the repo version, I figured out that I was missing an optional dependency which was stopping VLC from playing blu-ray disks. Try installing aribb24.


My brother will test this today. Thanks for the answer. We will see if it works and solves the problem.

Thanks a lot. This was the solution! We have to fix a little sound problem otherwise and unfortunately I cannot travel back to my brother to have a closer look at his laptop, but I will online guid him further.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.