VLC Error - Unable To Play VIdeos Over Network (VLC is unable to open MRL file)

Hey Guys,

I currently have a home server (MacOS) that hosts a lot of videos, movies, pictures, etc. that I have used for a few years now. I was running Ubuntu previously on my laptop, and had no issues connecting to my server (over SMB) and watching movies on my Linux laptop (Ubuntu). My wife’s macbook, our phones, and other devices can connect to the server and play movies without any problems.

The Problem:
I reinstalled Manjaro (Manjaro Gnome, previously was using Manjaro KDE), and when I try to watch a movie from the server, it fails with the following error:

Strange;y enough testing playing the video on my wife’s MacBook, our phones, etc. can still play all movies / videos from the server without any problems (not a permissions issue). I also tried to copy the video from my home server to the actual Manjaro installation locally, and playing the video once it was copied over worked perfectly.

Debug Information:
Opening up the Debug “Messages” as I tried playing the video gave the following error:

filesystem error: read error: Input/output error
cache_read error: cannot pre fill buffer
main warning: cannot insert stream filter prefetch,cache_read
mjpeg warning: no more data
mjpeg error: cannot peek
avformat warning: cannot peek 

I’ve done some googling and found a few pages talking about the issue, but it seems that nothing is working for me so far:

Anyone see this issue before? In addition, is this the ‘right’ sub-forum to post this question? I wasn’t sure if this qualifies as a Network (SMB) issue or not.

Any help that anyone could provide would be greatly appreciated. Thanks in advance to everyone for your time and help!

Anyone? Thanks again!

Putting the error and linux in a search engine gives me this as the first hit, read it, try to fix it?

Not running a windows file server so can’t test it.

Hello guys I have tried to solve it.

steps :

  1. Create mount point
  2. Mount Your Shared file Location.

I have made a dedicated video on this topic may it help

Yt : Ktechs
Video Title : Video is unable to open the MRL || #Manjaro #Linux #arch || Dolphin file manager .

You can watch it.