VLC does not show stream from streamlink, but time progresses in the player


I want to watch a twitch stream using streamlink and VLC. I do that for years now. I type in the streamlink command into my terminal

$ streamlink twitch.tv/nl_kripp best

… seems to work, like always … the VLC player automatically opens and the video time, down left, starts ticking, but no video or audio.

When i look at the codec informations within VLC, it seems to be fine, as if a stream is being shown.

Stream 0
     Codec: H264 - MPEG-4 AVC (part10) (h264)
     Typ: Video
Stream 1
     Codec: MPEG Audio layer 1/2 (mpga)
     Typ: Audio 

Even the statistics of the stream in the media information of VLC show decoded blocks and images and a bitrate of over 5K to 8K kb/s and demuxed data and so on.

(i have screenshots, but i am not allowed to post media apparently)

Info about my installation:

$ uname -a
Linux workstation 5.13.19-2-MANJARO #1 SMP PREEMPT Sun Sep 19 21:31:53 UTC 2021 x86_64 GNU/Linux

$ pacman -Q --info streamlink
Name : streamlink
Version : 2.4.0-1

$ pacman -Q --info vlc
Name : vlc
Version : 3.0.16-3

One interesting twist, which is the main reason i am asking for help in the manjaro forums:

I made a fresh install of manjaro, but the only USB stick with manjaro on it was a a very old one with linux kernel 5.6 (i don’t know the manjaro version).
After that install, everything worked, even the playing of streams with streamlink and vlc.

But i was not happy, because, why not use the most recent stable kernel, right ? So installed kernel 5.14 using pamac from the official manjaro repos. Something broke, i don’t know. I could not reboot.

I used the same USB stick to download the newest manjaro image and used a second USB stick to put it on there. I installed manjaro using the new stick. Now i have kernel 5.13. I don’t dare to install 5.14 again. But now i have the streamlink / VLC issue described above. I don’t remember the VLC and streamlink versions of the previous installation with the older manjaro image, but it must have been the same, because i did install all the new versions using pamac. I did not do a full system upgrade though. Well i am on the newest manjaro image now.

Normal video playback with VLC works just fine !
Video Output is set to OpenGL. I tested every video output option, without success.
Hardware Acceleration is on Auto. I tested the other Acceleration option as well. Didn’t help.

So why did it work with the old manjaro image ?
And no it does not anymore.
Does anyone else have that issue ?

I am glad for every hint anyone can give me. Thank you.

You should always install from the latest ISO available. Installing from a VERY old ISO is highly discouraged as simply updating would not be possible in many cases. Kernel 5.6 reached end of life more than a year ago.

Always do a full system upgrade, partial update is not supported.

On your new installation of Manjaro, try the LTS kernel 5.10 or 5.4.

I tried to use streamlink for twitch and indeed it doesn’t work for me either.

//EDIT: Players - Streamlink 2.4.0 documentation

It might simply be a bug in VLC, I tried by forcing another player and it works.

streamlink --player mpv https://www.twitch.tv/yourStreamerNameHere best

//EDIT2: you can create a configuration file for settings to be applied automatically, create ~/.config/streamlink/config and put your custom settings

# Player options

Hi omano,

thank you for your fast response. Because of it, i installed my system again. I downloaded the ISO from the manjaro front page.

After the installation i checked which kernel i have and it showed me 5.13.

The only thing i did was
$ pamac -S streamlink
and then i tested it
$ streamlink twitch.tv/streamername best
i got the the same issue as i describe before with vlc.

Forcing another player like mpv works on the new install (i needed to install mpv of course).
But that worked on the older installation as well. I tested it before i made the new system.

You hinted, that i should try the LTS kernel 5.10.
I couldn’t find a way to choose a specific kernel while installing the ISO image.
But after the installation and the first streamlink tests i downgraded from 5.13 to 510 using pamac.
But i got the exact same issue with VLC. I went back to 5.13 for now.

Because of your hint, that it might be a bug in vlc, i tried to install vlc-git from AUR using pamac. Unfortunately the build failed. I can’t fix that.

Do you think, i should write a bug report to the VLC issue tracker or into their forums ?

Thank you.

I didn’t tell you to install your system again I even edited my post to point to the issue. I even told you I had the same issue. I linked to you the known issues of streamlink it is an issue with VLC apparently.
You would ne the 32bits version of VLC to verify that as it seems to be working with it (but Manjaro only ship 64bits I think).

Also you should use the Manjaro tools to manage your kernels Manjaro Kernels - Manjaro

You do as you wish regarding this issue. I would first search for it because it probably already is reported, if it is listed in the known issues with streamlink, in which case reporting it again wouldn’t be relevant.

Thank you omano,

sorry that I am quite stupid, but i try my best. I did what I thought would be the right thing.

That said, I finally read your link.

I tried
streamlink --player-passthrough hls twitch.tv/zackrawrr best
as suggested there, one time

didnt work

I tried to play a standard mkv video from my drive and I couldn’t see the video there either.
That was new.

Then I looked at the “Hardware Acceleration” setttings of VLC. I changed it to “deactivated”.

After that, videos from my drive and the twitch stream suddenly worked. Even without the “–player passthrough” thing.

Sorry, for not being able to accurately do what you wrote to me. I am just a human with a lot of errors. I try. Does that not count ?

Anyways, thank you a lot for your help and time.

Of course, what i did is random enough, that we could not say what the solution actually was.
Or am i wrong here, too ?