Vivaldi browser not able to open magnet links

Vivaldi browser not able to proper load torrent download from magnetic links after Stable update. XDG portal open but it doesn’t launch qBittorrent to download the file.

Tested also on Firefox and ungoogled-chromium, both are working correctly, looks like Vivaldi issue.

Note: Before the release 2023-09-18 it was working properly.

This looks like an issue for the Vivaldi support.
Manjaro updates don’t change your user’s configuration files. What happens if you click such a link?

The settings should have a search function for magnet or link behavior.

It open the dialog as expected, but when you click on button Open qBittorrent nothing happen, while previously if opens the qBittorrent in order to accept and ad the torrent link for download.

While this pop-up screen is not working anymore for Vivaldi, it still work for Firefox and Ungoogled-chromium.

Probably it’s an issue from Vivaldi, but once Manjaro may change something may not and put this app on the official repo, as ordinary user I can’t evaluate where is the issue but I’m trying to provide feedback at stable update.

If I remember well this software also come installed by default with Manjaro KDE Stable.


Does not compute. Please run that by us again… :thinking:

Notice I moved your post to a new thread. Vivaldi was updated a week ago in all branches, so it’s technically not related to the stable update. You should check for updates more often to make sure you have the latest security updates. :wink:

Cinnamon. :wink:

I carefully select the world “may” “may not” once if indicates doubt, so it’s a possibility not a fact. For instance, Fedora and OpenSUSE does not have Vivaldi offered in the official repo while Manjaro does and I like it, So i think if Vivaldi is available in the official repo is because the Manjaro team added it there, right? But as user I can’t say if changes were introduced or not and I can just report what I faced after update.

Sure, OK.

I do often updates as long they are available, but sometimes things break and we need to take a decision as user, there is a reason for Manjaro Stable to hold package from testing, that holds from Unstable that holds from Arch, and there is reason for user to hold packages even from Manjaro stable.

I was holding updates because Diablo 4 was broken from previous updates.

Issue happen sometimes, It’s just about notify and wait for fixes somewhere in time to be released. Thanks for having Timeshift well integrated with BTRFS/GRUB.

Thank you for explaining, I understand.

Yes. See this article for example in the Previous News section of Stable Updates topics:

Yes, that’s fine. :+1:


Nice article and nice to know that Philip was following windows road until windows 7, like me, so I jumped into Linux road as well.

I vote to make Vivaldi default browser also for KDE plasma edition :slight_smile:

Before Vivaldi, I was a big fan of Opera for a long time, until some issues and devs departure to create Vivaldi.

I don’t like Firefox, outdated look, I always had issues on windows like trojans, virus and others using it, the same using internet explorer, while with Opera it was much safer for me and never had issue, for sure I had more experience while using it.

I like Firefox – it arguably keeps the Chromium-based world honest.

Clicking a magnet link in Firefox launches the ‘Open xdg-open’ dialog which allows you to choose the default application, and proceed to open the link – qBittorrent, in your case. Chromium-based browsers typically don’t offer this (Vivaldi is Chromium-based); instead, the default application is launched directly.

It’s possible that the default association for magnet links was reset – an artefact of the update, perhaps; or something else, entirely.

I found this article which details a method to change the default application for magnet links to qBittorrent. The procedure is used in a Debian-based system but it seems like it should also work as expected in Arch-based systems; possibly with minor variations to syntax. Cheers.


I just tested cause Vivaldi is my default browser and qBittorrent is my default torrent client and no issue whatsoever.

A thought. Launch Vivaldi, go to it menu, under file select private window, now try a magnet link.

I use Vivaldi as my primary browser, and I cannot reproduce your problem. When I click on a magnet link I get a popup asking to open qBittorrent.

Have you tried using a fresh profile in Vivaldi, maybe you have an extension that’s interfering?

This is working for me too, what was broken is if I click on the button inside pop up screen the qBittorrent don’t open.

Didn’t tried once I didn’t installed any extension.