Visual studio extenstion not working

I recently installed visual studio code but it’s extensions don’t work, i reinstalled but that still show the message “we cannot connect to the Extensions Marketplace at this time, please try again later”,
i don’t know what to do to solve this problem

1 Like

I’m not sure, but this version of VS Code is not the Official Microsoft Version, That is Code, an Open Source Release of VS Code. It is very similar but some of these versions reference different Extension Libraries. You can check in your extension settings by following the guide on VS Codium’s github README:

Or you can install the official VS Code from the AUR using the following commands in your terminal:

git clone https://aur.archlinux.org/visual-studio-code-bin.git
cd visual-studio-code-bin
makepkg -si

Regular Microsoft Visual Studio Code should be installed at this point with the standard Extensions Library built into VS Code. I’d encourage you take a look at the AUR documentation on VS code though, as there are other options that might interest you (like VS Codium which has the telemetry stripped from it).

https://wiki.archlinux.org/title/Visual_Studio_Code

Welcome to the Manjaro Forums btw! :slightly_smiling_face:

2 Likes

in .vscode-oss/.argv.json
add the line in the dictionary:
"enable-browser-code-loading": false,
This worked for me.
Add the line before crash reporter id line

2 Likes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.