Visual Issues/Glitches After Latest Big Update

Hello! After this previous update I have been facing some weird glitches, since i cant put pictures nor links to show them I have to explain it (would’ve been easier with pictures). Basically, when for example I play Minecraft I see black boxes with dots, and in the Application Launcher at the bottom there’s Favorites, Applications, Computer,… These have green at their top, this green is having some blacks inside it and it’s moving sometimes becoming bigger/smaller, and also on the Panel when I have for example Discord opened and I hover my mouse on the Discord logo since it again has that green thing that is still going black. So as in the volume place when i increase/decrease with the buttons, that is a bit glitched out too with black lines.

Please any help would be appreciated!

Some specs:
Kernel Version: 5.10.15-1
Processors: 2 × Intel® Celeron® CPU 1037U @ 1.80GHz
Memory: 3.7 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 2500
KDE Plasma Version: 5.20.5
spi video-linux | version: 2018.05.04 | freedriver: true |

Let me know! Thank you.

1 Like

I am having the same issue on my system since the last major update. It happened in minecraft and in mount and blade.
I think it is due to some thing in the mesa driver. Maybe downgrading the package could be a temporary solution but still not advised.

Here are my specs too:
Operating System: Manjaro Linux
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2
Kernel Version: 5.10.15-1-MANJARO
OS Type: 64-bit
Processors: 4 × Intel® Celeron® CPU N2940 @ 1.83GHz
Memory: 3.7 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics

I am having same issue. I also created a post at:
forum.manjaro[DOT] org/t/one-more-broken-system-with-intel-and-amd-vga-cards/53274
PS: In above link, replace [DOT] with .

Owh, hopefully there’s a solution!

We all have Intel graphics card common among us. It seems to me that the problem may lies in Intel driver.

Hello! I found a solution, mine was because of the kernel! It upgraded to 5.10.15 mine and now I downgraded to 5.9.16 (or do it to any that u had installed before) and now it’s fixed! Here steps:

  1. Shut down pc.
  2. Boot and then click ESC.
  3. It will open a page, go to Advanced options and then choose a kernel version lower than your current one and reboot! If it didn’t work try the recommended version 5.4.95 and do the same steps.

If it didn’t fixed it then I dont know sorry, this fixed mine. It’s a kernel issue so Manjaro devs please look into it!


I’m having the same issue as well, with Intel graphics. Switching back to the 5.9 kernel fixes it, but I was previously able to use 5.10 without issues until 2 updates ago.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.