Virtualbox, unable to browse or mount install disk

Manjaro host.

When creating a new guest and clicking ‘add’ on the virtual optical drive dialogue nothing happens.

When virtualbox is run as root I am able to click add and select a img.

I think this is a user groups issue but can’t figure out what to do.


This should cover most of your questions

Let us know if the issue persists.

It doesn’t seem to help. I’ve read through that article. The issue is that for some reason virtualbox doesn’t have permission to browse the file system unless I run as root. I’ve added my current user to the vboxusers group. It seems like the vboxusers group itself does not have permission to read files

Did you log out and back in or reboot the system. Oppening GUI applications as root is not a good approach.
Open it from terminal and share the errors you get there.

I don’t get any errors. I think maybe I need to add vboxusers to the storage group?

Only your user needs to be in the vboxusers group. A group can’t be added to another group. In principle this are the groups you should be in

sys network power vboxusers lp wheel

thanks! I’ll make sure I’m inn all of those

no dice. I’m already in all of those groups. Its a strange issue I’ve never had to deal with on deb systems, I’m new to manjaro / arch.

What DE is this? Is polkit running?

Gnome, stable release. I installed polkit as it was not installed, rebooted, verified it was running with ps aux | grep “polkit” attempted to open virtualbox from the terminal and load installation media and nothing happened when I clicked add

was able to load through adding a new virtual optical disc drive. Problem solved. Thanks for all of your advice!

There is something you are leaving out - a Gnome installation contain all necessary applications - including polkit

Unless you are performing system maintenance never run apps using sudo as this will create issues for your user locally.

VirtualBox does not require special permissions to run - and it does not require superuser to browse for and load an ISO.

Please rethink what you have changed because the behavior is not a default installation but a heavily modified one.

1 Like

Not that i want to antagonize … but first of all, polkit is installed by default on all Manjaro releases.

When creating a new Virtual macine, the virtual optical disk is always there … so i wonder how did you installed Manjaro, Gnome and how you handle the VM creation part. But since you solve it, good for you.

I know i might be late but i had the same problem. I solved it by moving the windows iso to the home/virtualbox vms . Then i opened virtual box i pressed chose a disk file and typed the name in the promt