VirtualBox shell colors

I have Ubuntu Server installed in a VirtualBox VM. Note, this distro doesn’t have a DE.

VB boots the VM fine, but the terminal I am presented with is white text on a black background. Considering the text editor I use, in fullscreen, is also white text on black; It’s very difficult to see the terminal window. At least it causes unwanted eye strain.

Is there any way I can change the background color of VB’s terminal or at least add a border to the window (in KDE)?

Window borders are part of the window decoration… :arrow_down:

System Settings → Appearance → Application Style → Window Decorations

At the bottom, you should see a checkbox for using the theme’s own window border, and a selector for the size of the border.

As for the colors inside the terminal, there are two separate things to look at. The first is the configuration of the shell itself, and the second is the configuration of the editor.

Now, I don’t know what editor you’re using ─ you didn’t say ─ but for nano you can enable syntax coloring in /etc/nanorc.

For the use of colors in the shell, take a look at the page below… :arrow_down:

After rewording my google search phrases, I came across this:

I added the escapes to the end of .bashrc inside the VM. The white on black continues until the user logs in. It’s a workaround for now. I was hoping to change the background color of the kernel boot lines (can’t remeber what it’s called) and the login prompt itself.

I could be wrong, but I don’t think that’s possible. :man_shrugging:

You’re probably right, but with it running inside a VB window I was hoping there might be a way to configure it. TBH though, I’m only testing server setup scripts locally before deploying them on a real VPS. So the bashrc workaround is enough.

1 Like