Virtualbox nightmare

Hi! installing any kind of Virtualbox (main bin + correct modules) ends up with the useless and uninformative error :
Fallo al abrir una sesión para la máquina virtual DSL-4.4.10.

The virtual machine ‘DSL-4.4.10’ has terminated unexpectedly during startup with exit code 1 (0x1).

Código resultado: NS_ERROR_FAILURE (0x80004005)
Componente: MachineWrap
Interfaz: IMachine {85632c68-b5bb-4316-a900-5eb28d3413df}

Installed different kernels from 5.10 to 5.15 all same error. It doesnt matter guest os, all vms refuses to run (same identical error). Dkms modules makes same result. I came from sabayon (discontinued now) and there Vbox works flawlesly.
00:00:00.000601 main OS Release: 5.15.2-2-MANJARO
00:00:00.000602 main OS Version: #1 SMP PREEMPT Sat Nov 13 19:25:38 UTC 2021
00:00:00.000658 main DMI Product Name: R430/R480/R440
00:00:00.000678 main DMI Product Version: Not Applicable
00:00:00.000699 main Firmware type: BIOS
00:00:00.000797 main Host RAM: 7747MB (7.5GB) total, 4359MB (4.2GB) available
00:00:00.000806 main Executable: /opt/VirtualBox/VBoxSVC
00:00:00.000807 main Process ID: 28423
00:00:00.000807 main Package type: LINUX_64BITS_GENERIC
00:00:00.004224 main IPC socket path: /tmp/.vbox-vibrion-ipc/ipcd
00:00:00.112648 nspr-2 VirtualBox: object creation starts
00:00:00.112812 nspr-2 Home directory: ‘/home/vibrion/.config/VirtualBox’
00:00:00.113070 nspr-2 Loading settings file “/home/vibrion/.config/VirtualBox/VirtualBox.xml” with version “1.12-linux”
00:00:00.115511 nspr-2 Successfully initialised host USB using sysfs
00:00:00.127000 nspr-2 NetIfAdpCtlOut: VBoxNetAdpCtl: Error while retrieving link speed for wlp2s0b1: VBoxNetAdpCtl: ioctl failed: Operation not supported
00:00:00.128078 nspr-2 HostDnsMonitor: initializing
00:00:00.128422 nspr-2 NAT: resolv.conf: nameserver -----
00:00:00.128456 nspr-2 HostDnsMonitor: updating information
00:00:00.128477 nspr-2 HostDnsMonitor: old information
00:00:00.128483 nspr-2 no server entries
00:00:00.128489 nspr-2 no domain set
00:00:00.128493 nspr-2 no search string entries
00:00:00.128497 nspr-2 HostDnsMonitor: new information
00:00:00.128500 nspr-2 server 1: ------
00:00:00.128504 nspr-2 domain:
00:00:00.128508 nspr-2 search string 1:
00:00:00.132279 nspr-2 VD: VDInit finished with VINF_SUCCESS
00:00:00.137702 nspr-2 Loading settings file “/home/vibrion/VirtualBox VMs/DSL-4.4.10/DSL-4.4.10.vbox” with version “1.15-linux”
00:00:00.140220 nspr-2 VirtualBox: object created
00:00:04.244721 nspr-2 Launched VM: 3087013968 pid: 28446 (0x6f1e) frontend: GUI/Qt name: DSL-4.4.10
00:00:04.745506 Watcher ERROR [COM]: aRC=NS_ERROR_FAILURE (0x80004005) aIID={85632c68-b5bb-4316-a900-5eb28d3413df} aComponent={MachineWrap} aText={The virtual machine ‘DSL-4.4.10’ has terminated unexpectedly during startup with exit code 1 (0x1)}, preserve=false aResultDetail=0
Of course, Im in a hurry cause I need some previous VMs to run.

modinfo output:
modinfo vboxdrv  INT ✘  8m 25s 
filename: /lib/modules/5.15.2-2-MANJARO/misc/vboxdrv.ko.xz
version: 6.1.30 r148432 (0x00320000)
license: GPL
description: Oracle VM VirtualBox Support Driver
author: Oracle Corporation
srcversion: F9FA1A81FC138C0AB4CA5BE
retpoline: Y
name: vboxdrv
vermagic: 5.15.2-2-MANJARO SMP preempt mod_unload
parm: force_async_tsc:force the asynchronous TSC mode (int)

Tip: When pasting terminal output on Discourse forums, one can either…

  • Use the Preformatted text </> toolbar button–NOT the Quote " button.

  • Add three backticks ` above and below the text (Markdown):

    type or paste code here

  • Use HTML:

    type or paste code here

Please edit your post accordingly.

Your host user must be a member of the group vboxusers:
sudo gpasswd -a $USER vboxusers

(Change $USER to the correct user name if not for yourself)*

Upgrade the VirtualBox extension pack to the latest version

Take a look at these:

Maybe a stupid question… but where is the edit button??? :thinking: :grinning: :grinning:

Have you tried gnome-boxes instead VBox?
Much more lighter stable and success

Thanks to your response! After hitting my head on the wall (several hours) I’ve decided giving a try to KVM/QEMU (with virtio W10 drivers) and it works pretty fine!

Your issue is strange and annoying - but it is local to your system and next to impossible to troubleshoot.

I am using VirtualBox every day - running several virtual windows systems (my systems uses unstable branch) and there is years between issues except for the selfinflicted ones :grin:.

I suspect you are having a mismatch between the oracle extension package and the installed version of VirtualBox.

This mismatch is caused by the gap between Manjaro stable branch and Manjaro unstable/Arch stable.

The AUR script for the extension package follows upstream VirtualBox release closely - so from time to time this issue comes up due to the difference in available VirtualBox packages.

Thanks! It seems resolved by now!. Trying to reinstall following steps from Virtualbox forum found some strange permissions in my /usr folder (they were set to my personal user instead of root) so changing it resolve the problem (and arise new ones with sudo, but thats a different story)
Do i need to change the post to SOLVED?

1 Like

You should, so people that the nightmare is over :grin:

1 Like