Virtualbox funktioniert erneut nicht

Hallo liebes Forum,

hatte dieses Problem vorher schon einmal. Nach einer Lösung von gosia, hatte Virtualbox erst einwandfrei funktioniert.

Hallo Hesko,

ich im Moment leider nicht, sondern habe nur eine Nachfrage: Mit

meinst Du genau diese Anleitung aus dem Manjaro-Wiki
https://wiki.manjaro.org/index.php?title=Virtualbox
Sorry, aber es gibt viele Anleitungen im Netz und manche sind für Manjaro nicht unbedingt passend und mit
sudo pacman -Syu virtualbox linuxXY-virtualbox-host-modules
habe ich eigentlich noch nie Probleme gehabt.

viele Grüße gosia

Hesko

12d

Hallo Gosia,

ich habe es nach der Anleitung von wiki.manjaro.org probiert. Gestern ohne Erfolg, nach mehrmaligem installieren und deinstallieren. Habe gerade nochmal deine zeile eingegeben:

sudo pacman -Syu virtualbox linux57-virtualbox-host-modules

Nur mit meiner Kernelversion und es funktioniert jetzt. Keine Ahnung was ich gestern anders gemacht habe.

Vielen dank für deine Antwort

Hesko

Ich hatte auch ein Debian Linux virtuell installiert. Heute wollte ich Virtualbox wieder starten und habe wieder die gleiche Fehlermeldung:

Das COM-Objekt für VirtualBox konnte nicht erzeugt werden.

Die Anwendung wird nun beendet.

Document is empty.

Location: **'/home/hesko/.config/VirtualBox/VirtualBox.xml'** , line 1 (0), column 1.

/build/virtualbox/src/VirtualBox-6.1.14/src/VBox/Main/src-server/VirtualBoxImpl.cpp[740] (nsresult VirtualBox::init()).

|Fehlercode:|NS_ERROR_FAILURE (0x80004005)|
| --- | --- |
|Komponente:|VirtualBoxWrap|
|Interface:|IVirtualBox {d0a0163f-e254-4e5b-a1f2-011cf991c38d}|
|Callee:|IVirtualBoxClient {d2937a8e-cb8d-4382-90ba-b7da78a74573}|

Keine Ahnung, woran es liegt. Wenn jemand etwas dazu weiß, ich bin über jede Antwort dankbar.

Viele Grüße

Hesko

Diese Datei ist leer. Deswegen startet es nicht.

Schau einmal nach ob Du eine
~/.config/VirtualBox/VirtualBox.xml-prev
hast.
Wenn ja kopier diese nach VirtualBox.xml
Ist möglicherweise nicht exakt die selbe, aber VBox startet zumindest wieder.

Beachte das der Kernel linux57 5.7.19 [EOL] Status hat und damit auch alle Module für diesen kernel.

Hallo gefri,

wunderbar, das hat funktioniert.

Vielen dank

Hesko

Hallo StiritOfTux,

ich habe den Kernel linux54 und den linux57. Das hatte ich mit

mhwd-kernel -li

herausgefunden. Kernel linux57 ist aktiv. Wie kann ich diese Abhängigkeiten lösen?

(ich weiß nicht ob ich mich richtig ausdrücke!)

Saludos

Hesko

Einfach den 5.7er Kernel deinstallieren.
Und ggf. den 5.8er als aktuellen 2. Kernel dazu.
Am Einfachsten (xfce) unter Einstellungsverwaltung - Manjaro Einstellungen - Kernel
Um die Abhängigkeiten kümmert sich die Installationsroutine.

uname -a zeigt Dir mit welchem Kernel gebootet wurde
ggf. beim nächsten reboot den anderen auswählen

Öffne die Konsole

sudo nano /etc/default/grub

Dann passte die Parameter an wie hier z.Bsp,

GRUB_TIMEOUT=5
GRUB_TIMEOUT_STYLE=menu
GRUB_DISTRIBUTOR=‘Manjaro’

Hier nach muß noch ein

sudo update-grub
erfolgen, nach einem REBOOT wird Dir dann BootMenü angezeigt.

Hallo SpiritOfTux,

ich werde mal ein bischen rumprobieren.
Aber im moment läuft VirtualBox.

Danke für die Info

Hesko

Hallo gefri,

auch vielen Dank an dich. Werde mit den Kerneln ein bisschen rumprobieren.

Lieben Gruß

Hesko