Virtualbox-ext-oracle 6.1.26 not listed when doing pamac search


I installed Virtualbox using the instructions from the Manjar VirtualBox link. I successfully installed the virtualbox 6.1.26, however when I got to the part to install the extension pack, I’m running into an issue.

It says to run “pamac search virtualbox-ext-oracle” to get a list of extension packs to choose from. When I do this, it shows several, including 6.1.28-1, but no option for 6.1.26 which is the version of virtualbox it installed.

Previously I have used this link to correctly install Virtualbox and the corresponding extension pack without issue but for some reason, the extension pack 6.1.26 is not there. Anyone else having this issue and/or know whats going on and how to proceed? Thanks.

This is not a Manjaro package. It’s an AUR package. If you want VirtualBox to be compatible with that, then you need to replace the Manjaro version and install the AUR version, which is at 6.1.28. :arrow_down:

pamac remove virtualbox
pamac build virtualbox-bin virtualbox-ext-oracle

Hi Aragorn and thanks for the reply. I see what your saying and tried doing as you suggested. Virtuablox installed and so did the extension pack. However when I tried to start one of my vm’s it gives me the error Kernel drive not installed (rc=1908). /sigh What else am I missing. It shouldn’t be this difficult on manjaro.

You probably don’t have the host modules installed for your running kernel. The host modules are named linuxNNN-virtualbox-hostmodules, whereby “NNN” should be replaced by your kernel version. So for instance, for kernel 5.14, it would be the package linux514-virtualbox-hostmodules, and you would install it with… :arrow_down:

pamac install linux514-virtualbox-hostmodules

… or… :arrow_down:

sudo pacman -S linux514-virtualbox-hostmodules

Adapt this to the kernel you’re actually using, and don’t forget to reboot after installing the package.

This is what I have done a few times with no problem. It installs the 6.1.26 version of Virtualbox. Not a problem but the instructions say to install the extension package from the AUR, but 6.1.26 isn’t listed any longer. That’s the real problem here.

1 Like

OK, that is pretty much what I figured my options were. Thank you very much for confirming and your help!!

You can install an older version of an AUR package by doing the following:

The commit you need can be obtained by clicking View Changes under Package Actions on the AUR page, click the commit message you want, then copy the commit hash.

Tip: In the future, never update virtualbox-ext-oracle until the matching VirtualBox packages come along.

Or you can just download the specific version version of extensionpack from the website of VirtualBox (Go to the older builds section and choose the matching version) [It is not a convenient way, but better than nothing]:
Download Old Builds - Oracle VM Virtualbox

Get extensionpack from VirtualBox - Manjaro Wiki

1 Like

Why isn’t extensionpack in the repos while virtualbox is? Most people who install virtualbox also install extensionpack. I think keeping extensionpack as the same version of VB in the repos as an optional dependency of VB would be great. Please consider it @Yochanan :slightly_smiling_face:

The license does not allow it to be redistributed. If it did, it would have been in the Arch repos long ago.

1 Like

I thought everything related to virtualbox is open source and redistributable [Error 404 :face_with_hand_over_mouth:].