VirtualBox error in the last update

I’m glad I found this thread. I thought I was going crazy with constant app crashes in a Windows VM in Virtualbox. I am on 5.15.46 ( though I just updated to 5.15.48 but have yet to reboot. I was reading this as I updated :stuck_out_tongue: ) I have not tried 5.18 though I don’t really plan to. I prefer sticking with LTS. I also have 5.10 installed but had not thought to boot into that. Not 5.4 though

Just received updates for LTS kernels: 5.10.123-1 and 5.15.48-1. My W10 VM seems to be running just fine now (VBox 6.1.34 r150636) — at least here at home. Even under heavy duty conditions.

More interesting will be the productive W10 and W11 VMs in my office though. I’m going to test them in about 2 hours. :crossed_fingers:

Thanks a lot, team Manjaro! :ok_hand:

1 Like

i should have checked the forum before deleting a vm because of app crashes and strange artifacts on the screen.

Thanks too for your hints
I only can confirm that upgrading to 5.18.5-1-MANJARO also works smoothly with VB 6.1.34r150636 (HOST)
und windows 10 X64(GUEST)

After trying downgrading 6.1.34 to 6.1.32 with LTS kernel linux515 (OS reboots at random, blue screen) and other possibilties,I tried, as mentionned, also 5.18.5-1-MANJARO (linux518) and did a fresh install
Windows 10 Professionnel
Version 21H2
Processeur Intel(R) Core™ i7-5600U CPU @ 2.60GHz 2.59 GHz
VB RAM allocated 5,98 Go
Its frustrating because it seams that LTS isn’t compatible with VB 6.1.34.

Yes, you’re right - @linux-aarhus: Many thanks for testing. So still just to sum up:

working as vmware hosts (date: 2022-06-17):

((Tested these Manjaro Currently supported) Kernels + “related” virtualbox-host-modules)

  • 5.4.199-1
  • 5.18.5-1
  • 5.10.123-1 (@djentling : confirmed?)

(Tested &) NOT working as vmware hosts (date: 2022-06-17) … inconclusive (does NOT work for me):

  • 5.15.48-1

… all other Kernels that are available via the Manjaro settings manager (… or installable via [pacman] (Pacman - Manjaro) / pamac ) have not (yet) been tested.

Yesterday Kernel 5.15.48-1 did not work for me - same install status as mentioned in my last post. Does it work for you? if yes, could you please show how your result for this shell command looks like?

pamac search virtualbox | grep -i install

looks like … example: for me this looks like:

pamac search virtualbox |grep -i install                                                                                                                                                   
linux518-virtualbox-host-modules [Installiert] 6.1.34-8                extra 
linux515-virtualbox-host-modules [Installiert] 6.1.34-17               extra 
virtualbox-guest-iso            [Installiert] 6.1.34-1                community 
virtualbox-ext-oracle           [Installiert] 6.1.34-1                AUR 
virtualbox                      [Installiert] 6.1.34-4                community

vmware is an unsupported 3rd party custom package

… after summarizing, just retested with both kernels 5.18 and 5.15 again

Status unchanged for me, only kernel 5.18 + virtualbox host modules as mentioned in the last posts are working for me. Will keep on testing…

1 Like

I tried running sudo pacman -Syu linux518 linux518-headers virtualbox-host-dkms and ended up with a blinking cursor on boot.

I installed the manjaro updates a couple of days ago and my Virtualbox has been unusable with processes crashing constant inside the VMs.

Can I expect a fix to be rolled out in the following days or would I have to resolve this issue myself? (I’m new on Manjaro)

…installing kernels manually without including other kernel modules you probably need. Always use Manjaro Settings Manager / mhwd.


No, you should never expect anything in life. You will always be sorely disappointed.

A fix for what? Something that only happened on your computer?

Thanks, I’ll look into mhwd.

I was of the impression this wasn’t only happening on my computer, since the bug is mentioned on VirtualBox’s forum and I didn’t create this thread. It’s my first time using a distro with rolling updates, I’m not used to stuff breaking when running on a stable branch.

Please link to the post. I was not aware of any upstream issues as I’m able to use VirtualBox just fine. I track Arch bug reports daily and I do not recall anything reported recently.

No worries. A rolling release distro does take some getting used to. Once you do, you’ll never want to use a point release distro again. :wink:

1 Like

The 3rd. post in this thread mentions it with some different links.

I already appreciate it, but I’m using Virtualbox most of the day, so this one hit hard.

It seems like the issue has been resolved using mhwd to upgrade the kernel to 5.18, thanks for the wiki link.

Aha! Sorry, had been following this thread (among many others) and lost track.

Haven’t had time to read all of this thread,
just posting what I’ve gleaned from the vbox forum.

  • There are some recent major changes in the kernel that virtualbox hasn’t caught up with.
  • The changes have been backported to LTS kernels (5.10, 5.15) so the problems happen with those too.
  • It seems to happen only with certain CPUs, not all.
    (I have Xeon E5-2665 and kernel 5.15, and I have the problem,)
  • Recently people have been trying a new virtualbox 6.1.35 test build with success.
    Hope we can get that in Arch/Manjaro soon.
    VirtualBox test builds 6.1.35r151573 (and newer) …”

EDIT: the vbox testbuids page has a .run file : ‘
Is there a way to use that (temporarily) on Manjaro, safely?
If so, how?

Maybe this is a fix for it? Will try it.
EDIT: It’s better than before, but maybe not completely fixed.

$ checkupdates
linux515 5.15.46-1 -> 5.15.48-1
linux515-headers 5.15.46-1 -> 5.15.48-1
linux515-virtualbox-host-modules 6.1.34-14 -> 6.1.34-17


I have had problems with VBox for the last year. The new versions are somehow unstable.

I also have Virt-Manager (Qemu/KVM) now… Just works. The switch is a pain, the interface of VBox is very good. The shared folder of VBox for Windows guests I still miss now. For Linux guests Virtiofs works really well.

I was able to convert the VMs easily. :slight_smile:

Yes it is.
Have been running Win11 in VBox for half an hour – nice and smooth.

Maybe not; I’ve had some unexpected restarts that I don’t think were Windows’ fault.
Looks like we have to wait for vbox 6.1.35; it’s in testing, and some fedora users report that it works, in this forum.

Still no joy for me with these versions.

I still get these various errors with manjaro guest, so going back to kernel 5.4:

On manjaro upgrade:

  • openssl_read error ssl3_get_record:decryption failed or bad record mac

  • error: failed to decompress: /usr/lib32/ (Zstd decompression failed: Restored data doesn’t match checksum)

random segfaults with calamres during install

fsck.ext4: error whil eloadning shared libraries: cannot open shared object file: No such fil eor directory
ERROR: Bailing out. Run ´fsck /dev/sda1´ manually

sh: can’t access tty: job control turned off

Same here

1 Like

Some contributions:

  1. The VM files don´t get corrupted by anyway (even though running it through those mentioned kernels in those mentioned VirtualBox’s version become VERY unstable regarding memory issues);

  2. Downgrading to virtualBox 6.1.32 or even 6.1.30 didn’t make it for me;

  3. Upgrading my kernel to the 5.15 LTS didn´t make it for me (I was originally on 5.10 LTS);

  4. Upgrading my kernel to the non-LTS 5.18 brought everything back to normal (so far).