VirtualBox error in the last update

Well, my story isn’t quite over…

Today I updated the 4 machines affected by the issue. (2) Dell desktops, (1) ASUS desktop, (1) Lenovo desktop. The Lenovo and the ASUS have aftermarket graphics cards but nothing spectacular, just enough for dual monitors.

TEST 1: Kernel 5.18.3

  • VirtualBox Windows 7 Guests seem to run fine at first (they did not crash in the first minute or less, like previously).
  • Windows 7 Guest on the Lenovo crashed after about 30 minutes.
  • Windows 7 Guest on the ASUS seemed a bit sluggish compared to before this mess. One piece of software wouldn’t run. Chrome seemed to run fine but I kept seeing the “busy” icon appear next to my mouse.
  • I didn’t see an issue on the Dell machines but I didn’t play with them for more than 20 minutes.

TEST 2: Kernel 5.4 (yes all the way back to 5.4 because 5.10 didn’t work either)

  • I decided to go back to 5.4 because I tried it with one of the machines on Monday and left it running overnight. This morning it was still running fine with dozens of tabs open in both Chrome and Firefox, plus a couple of other programs running.
  • As of 8pm, all 4 computers are running fine with 5.4, none are sluggish, and none have crashed after several hours of testing.

I see Kernel 5.4 is LTS so guess its fine for now. Maybe its the lack of sleep over the past 48 hours, but I just find this whole thing super frustrating.

1 Like

Well, I guess you know it, but it is worth mentioning that there are pretty good alternatives to virtualbox.

  1. gnome-boxes
  2. virt-manager

I myself love the simple and easy to use interface of Gnome Boxes. Some features are missing, but it works faster and rock stable for me. I guess you just need to convert the VDI-Image to qcow2 and then create a virtual machine with it. All you need is this setup for Windows:

1 Like

"sudo pacman -S linux-headers " all you need

You are correct - but converting a 128G vdi is not a simple process and virt-manager can be quite intimidating in setting up a VM - it has a steeper learning curve than VirtualBox.

Gnome Boxes is virt-manager without the intimidating stuff - you still need to convert the VDI

That is partly correct - you still need to know your kernel as a selection will be presented and the default is not always the right one.

1 Like

Thank you very much for your contributions, apparently the most stable kernel is 5.4, for the moment I have no problems in 5.18, the VM I am using is a Debian, I have not tested it in Windows.

GnomeBoxes sure is a great VM but there are options that do have VirtualBox that is missing GnomeBoxes, in my case I am obliged to use VirtualBox.

1 Like

@linux-aarhus yes, I’ve played with several including qemu and vmware. As we have a dozen or so workstations all running Manjaro with VirtualBox and Windows 7 guests, I really need to keep them all the same.

Today I’m waiting to hear if there are any complaints from people using the kernel 5.4 machines, and if all looks good, then I will be installing updates and reverting the other machines from 5.15 to 5.4. The machines currently using 5.15 are working fine with VirtualBox because they’re still using the previous linux515 headers.

I’d love to hear this is fixed soon. I’m one of those people who is always telling people they can switch to Manjaro as a desktop, and I still believe this is true! The support in this forum is always great.

from a sysadmin pov - that is reasonable.

linux515 is preferable but if not achievable and lts is - supposedly better in the long run - maintenance wise.

I just didn’t connect my problems to the kernel in use and in hindsight I see now why - my windows began abruptly closing - my visual studio 2022 stopped working - I admit I blamed Windows for the instability.

So I did a test yesterday on a clean install - and there is definately something off with linux515 and virtualbox - on kernel 5.18 no issues but if I reboot into 5.15 - windows works but visualstudio do not.

Perhaps it is caused by may habit of using dkms for host modules - instead of using the prebuilt modules :person_shrugging:

Disclaimer: My testing is subjective and inconclusive - but they point in direction of the previous assesment that 5.10 and 5.15 are flaky. Systematic reboot over the course of approx. 60 minutes - using prebuilt modules instead of dkms.


  • Windows 10 2016ltsb
  • Runing a debug session on a API hosted on IIS Express.
  • Posting requests against the API using postman running on the host
$ uname -rsv
Linux 5.18.4-1-MANJARO #1 SMP PREEMPT_DYNAMIC Wed Jun 15 07:05:22 UTC 2022

5.18 - appears stable

$ uname -rsv
Linux 5.15.47-1-MANJARO #1 SMP PREEMPT Wed Jun 15 07:06:46 UTC 2022

5:15 - flaky - may work and after reboot it does not

$ uname -rsv
Linux 5.10.122-1-MANJARO #1 SMP PREEMPT Wed Jun 15 07:06:00 UTC 2022

5.10 - worked for about 10-15 min. then visual studio crashed.

$ uname -rsv
Linux 5.4.198-1-MANJARO #1 SMP PREEMPT Tue Jun 14 16:52:20 UTC 2022

5.4 - compared to 5.10 - 5.4 is stable

1 Like

Thanks for the checks. I can also confirm that kernel 5.15 with current updates (date: 2022-06-16) is causing havoc. Testing with manjaro VM in manjaro virtual box Host system. Same issue as others here reported - vm becomes unusable after some minutes, sometimes even on boot

Switching forward to kernel 5.18 in the host system solved the issue for now.
… waiting for a 5.15 fix and will keep on testing as well in the next days.

P.S.: Manjaro VM (KDE, Kernel 5.15, booting via btrfs on a luks encrypted VMdrive) works flawless, I retested installation procedure multiple times. Each Install roundtrip took ~5 minutes. Tested different installer options regarding SWAP, btrfs and encryption during installation.
… this works (tested ~6 combinations) as designed every time … when virtualbox is working correctly

looks like today (2022-06-17) virtualbox-host-modules 6.1.34-17 is available
pamac is just installing it for both of my kernels…
linux515-virtualbox-host-modules (6.1.34-14 → 6.1.34-17)…

… testing …

Test 1: Host (kernel 5.18) rebooted, VM (kernel 5.15) started, updated, rebooted (kernel 5.15 has a new release also…)
Result: working as expected, all fine
… rebooting host to kernel 5.15 to see if this is now fixed …

Virtualbox host rebooted (kernel 5.15.48-1-MANJARO, linux515-virtualbox-host-modules 6.1.34-17), VM started.
Result: No good, KDE in the VM / VirtualBox still breaks down pretty much directly after login.

… Back to Kernel 5.18 for now …


I’m glad I found this thread. I thought I was going crazy with constant app crashes in a Windows VM in Virtualbox. I am on 5.15.46 ( though I just updated to 5.15.48 but have yet to reboot. I was reading this as I updated :stuck_out_tongue: ) I have not tried 5.18 though I don’t really plan to. I prefer sticking with LTS. I also have 5.10 installed but had not thought to boot into that. Not 5.4 though

Just received updates for LTS kernels: 5.10.123-1 and 5.15.48-1. My W10 VM seems to be running just fine now (VBox 6.1.34 r150636) — at least here at home. Even under heavy duty conditions.

More interesting will be the productive W10 and W11 VMs in my office though. I’m going to test them in about 2 hours. :crossed_fingers:

Thanks a lot, team Manjaro! :ok_hand:

1 Like

i should have checked the forum before deleting a vm because of app crashes and strange artifacts on the screen.

Thanks too for your hints
I only can confirm that upgrading to 5.18.5-1-MANJARO also works smoothly with VB 6.1.34r150636 (HOST)
und windows 10 X64(GUEST)

After trying downgrading 6.1.34 to 6.1.32 with LTS kernel linux515 (OS reboots at random, blue screen) and other possibilties,I tried, as mentionned, also 5.18.5-1-MANJARO (linux518) and did a fresh install
Windows 10 Professionnel
Version 21H2
Processeur Intel(R) Core™ i7-5600U CPU @ 2.60GHz 2.59 GHz
VB RAM allocated 5,98 Go
Its frustrating because it seams that LTS isn’t compatible with VB 6.1.34.

Yes, you’re right - @linux-aarhus: Many thanks for testing. So still just to sum up:

working as vmware hosts (date: 2022-06-17):

((Tested these Manjaro Currently supported) Kernels + “related” virtualbox-host-modules)

  • 5.4.199-1
  • 5.18.5-1
  • 5.10.123-1 (@djentling : confirmed?)

(Tested &) NOT working as vmware hosts (date: 2022-06-17) … inconclusive (does NOT work for me):

  • 5.15.48-1

… all other Kernels that are available via the Manjaro settings manager (… or installable via [pacman] (Pacman - Manjaro) / pamac ) have not (yet) been tested.

Yesterday Kernel 5.15.48-1 did not work for me - same install status as mentioned in my last post. Does it work for you? if yes, could you please show how your result for this shell command looks like?

pamac search virtualbox | grep -i install

looks like … example: for me this looks like:

pamac search virtualbox |grep -i install                                                                                                                                                   
linux518-virtualbox-host-modules [Installiert] 6.1.34-8                extra 
linux515-virtualbox-host-modules [Installiert] 6.1.34-17               extra 
virtualbox-guest-iso            [Installiert] 6.1.34-1                community 
virtualbox-ext-oracle           [Installiert] 6.1.34-1                AUR 
virtualbox                      [Installiert] 6.1.34-4                community

vmware is an unsupported 3rd party custom package

… after summarizing, just retested with both kernels 5.18 and 5.15 again

Status unchanged for me, only kernel 5.18 + virtualbox host modules as mentioned in the last posts are working for me. Will keep on testing…

1 Like

I tried running sudo pacman -Syu linux518 linux518-headers virtualbox-host-dkms and ended up with a blinking cursor on boot.

I installed the manjaro updates a couple of days ago and my Virtualbox has been unusable with processes crashing constant inside the VMs.

Can I expect a fix to be rolled out in the following days or would I have to resolve this issue myself? (I’m new on Manjaro)

…installing kernels manually without including other kernel modules you probably need. Always use Manjaro Settings Manager / mhwd.


No, you should never expect anything in life. You will always be sorely disappointed.

A fix for what? Something that only happened on your computer?

Thanks, I’ll look into mhwd.

I was of the impression this wasn’t only happening on my computer, since the bug is mentioned on VirtualBox’s forum and I didn’t create this thread. It’s my first time using a distro with rolling updates, I’m not used to stuff breaking when running on a stable branch.

Please link to the post. I was not aware of any upstream issues as I’m able to use VirtualBox just fine. I track Arch bug reports daily and I do not recall anything reported recently.

No worries. A rolling release distro does take some getting used to. Once you do, you’ll never want to use a point release distro again. :wink:

1 Like