Virtualbox 6.1 not starting Virtualbox 7.0.6 starts but software in the Windows Guest crashes

Dear Community,

In my Virtualbox 6.1 I was running a Windows 10 Guest, everything worked flawlessly until lately my system upgraded. Somehow every time my systems makes a bigger upgrade, Virtualbox has issues starting, but I always managed to fix them by downgrading the Virtualbox software or the kernel. Until this time.

If I try to start Virtualbox 6.1 I get an error message “Failed to ceate the VirtualBoxClient Com object.” I removed and reinstalled several versions (6.1-versions) always with the same result. I tried different kernels 5.10, 5.4, 5.18 but never can get the Virtualbox software to start.

If I update my Virtualbox to 7.0, (Kernel 5.10) everything seems to be working normal, except, the software I use inside the Windows 10 Guest keeps crashing before it even starts. I reinstalled this software in the guest, even setted up a new Virtual machine with Windows 11, the software keeps crashing. Other programs I tried inside the Virtual machine seem to be working properly, just the one I need most for my work (KukaSim) won’t start and keeps crashing before it even opens.

I’m really desperate looking for a solution, could someone please help me out? Please let me know what information or command line outputs you need in order to help me. Since I tried several versions of Vitualbox and kernels I’m not sure what to provide.

Thanks a lot in advance.

Any software inside a VM runs indepently of the host.

But the host will need the complentary guest software matching the host VBox version.

The same is even more applicable for the extension pack if you use that.

Is there any suspicious log entry?

You could try reinstalling just so we’re on the same page about the actual software you have running:

pamac reinstall linux61 linux61-headers linux61-virtualbox-host-modules virtualbox

(After this, you have to reboot, did you initially?)

Verify in GRUB that you actually boot into kernel version 6.1, and check with uname -r that it prints 6.1.25-1-MANJARO.

How are you switching between the different VirtualBox versions? You mention 6.1 and 7.0, however, only 7.0 is available from the official repos.

did you create a new windows.vdi with virtualbox7 or do you use the vdi that’s created with 6.1 ? seems that vb7 isn’t that compatible to use windows.vdi files that had been created with previous versions.

Thanks for your reply.

I’m using the vdi that was created with 6.1, which runs but with issues. I noticed that also in some other software the dialog windows are looking weird, kind of messed up. But at least the software is not crashing.
Besides I created a new vdi (Windows 11 Guest) but I face the same problem ie my software is crashing.
Maybe an interesting side note: I already had some trouble with my Virtualbox before. A few months ago, my Virtualbox was updated to 7.0, after which my Windows Guest kept crashing, I was not able to boot anymore at all (I guess that had something to do with Hyper-V virtualisation) I didn’t manage to fix the problem so downgraded my Virtualbox again to 6.1 and prevented it from upgrading. Until now, that worked fine, just now the Virtualbox software doesn’t even start anymore as mentioned in my initial message.

it sounds a little bit off-topic but have you ever tried qemu/kvm ? i really suggest that you check it out. it is more powerful than the “free” virtualbox, more stable and much more flexible. please take some time to check out the tutorials of this guide, he made a lot and very good ones that gives you an impression:

it’s worth to switch to kvm/qemu

1 Like

I tried to install linux61, but did not succeed… As always when an upgrade is performed, I’m not only facing issues with my Virtualbox but also with my nvidia-drivers. I once downloaded a script file from somewhere that fixes the problem (pc stops booting after selecting the version to boot) after an upgrade… I do not really have any idea of what I’m exactly doing, but it used to work :see_no_evil:. Not this time with Linux61 however.

Switching between 6.1 and 7.0 by the command sudo DOWNGRADE_FROM_ALA=1 downgrade virtualbox OR I also downloaded a package virtualbox-6.1.36-1-x86_64.pkg.tar.zst and the accompanying virtualbox-host-dkms-6.1.36-1-x86_64.pkg.tar.zst these I then install manually

maybe it’s time that you can give us some infos of your system first.
may you post the output of

inxi --admin --verbosity=7 --filter --width

please use the option of preformatted text (the three ticks) and paste it inside

  Kernel: 5.10.178-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
    root=UUID=e6463198-1f4d-4692-ac48-203dbb8eab66 rw quiet apparmor=1
    security=apparmor resume=UUID=e4ab34e4-4bbc-4c58-a23f-d306cef4898d
  Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: Precision 7530 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0425K7 v: A00 serial: <superuser required> UEFI: Dell
    v: 1.21.0 date: 03/24/2022
  ID-1: BAT0 charge: 38.8 Wh (100.0%) condition: 38.8/97.0 Wh (40.0%)
    volts: 11.8 min: 11.4 model: SMP DELL 0WMRC77 type: Li-poly serial: <filter>
    status: full
  Device-1: hidpp_battery_0 model: Logitech M720 Triathlon Multi-Device Mouse
    serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: discharging
  Device-2: hidpp_battery_1 model: Logitech K850 Performance Wireless
    Keyboard serial: <filter> charge: 50% (should be ignored) rechargeable: yes
    status: N/A
  RAM: total: 15.39 GiB used: 3.4 GiB (22.1%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i7-8850H bits: 64 type: MT MCP arch: Coffee Lake
    gen: core 8 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF0
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 9 MiB desc: 1x9 MiB
  Speed (MHz): avg: 4151 high: 4201 min/max: 800/4300 scaling:
    driver: intel_pstate governor: powersave cores: 1: 4142 2: 4200 3: 4199
    4: 4125 5: 4201 6: 4193 7: 4198 8: 3912 9: 4096 10: 4198 11: 4201 12: 4156
    bogomips: 62431
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr hle ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida
    intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
    movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp
    rep_good rtm sdbg sep smap smep smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3
    stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx
    vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Dell driver: i915
    v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
    active: eDP-1 empty: DP-1, DP-2, DP-3, HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:3e9b class-ID: 0300
  Device-2: NVIDIA GP107GLM [Quadro P2000 Mobile] vendor: Dell driver: nvidia
    v: 470.74 alternate: nouveau,nvidia_drm non-free: 530.xx+
    status: current (as of 2023-03) arch: Pascal code: GP10x process: TSMC 16nm
    built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 16 ports: active: none
    off: HDMI-A-2 empty: DP-4,DP-5,DP-6 bus-ID: 01:00.0 chip-ID: 10de:1cba
    class-ID: 0300
  Device-3: Realtek Integrated Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-11:4 chip-ID: 0bda:5650 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 compositor: kwin_x11 driver: X:
    loaded: intel,nvidia dri: i965 gpu: i915,nvidia,nvidia-nvswitch
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 4480x1440 s-dpi: 108 s-size: 1054x342mm (41.50x13.46")
    s-diag: 1108mm (43.63")
  Monitor-1: HDMI-A-2 mapped: HDMI-0 note: disabled pos: right
    model: Dell U2721DE serial: <filter> built: 2020 res: 2560x1440 hz: 60
    dpi: 109 gamma: 1.2 size: 597x336mm (23.5x13.23") diag: 685mm (27")
    ratio: 16:9 modes: max: 2560x1440 min: 640x480
  Monitor-2: eDP-1 mapped: eDP1 pos: primary,left model: LG Display 0x0540
    built: 2017 res: 1920x1080 hz: 60 dpi: 143 gamma: 1.2
    size: 340x190mm (13.39x7.48") diag: 395mm (15.5") ratio: 16:9
    modes: 1920x1080
  API: OpenGL v: 4.6.0 NVIDIA 470.74 renderer: Quadro P2000/PCIe/SSE2
    direct-render: Yes
  Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_sof_pci bus-ID: 00:1f.3
    chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA GP107GL High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:0fb9 class-ID: 0403
  API: ALSA v: k5.10.178-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.70 status: off with: pipewire-media-session
    status: active tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-jack
    type: module tools: pacat,pactl
  Device-1: Intel Ethernet I219-LM vendor: Dell driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15bb class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: noprefixroute scope: global broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Intel Wireless-AC 9260 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 70:00.0 chip-ID: 8086:2526 class-ID: 0280
  IF: wlp112s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  IF-ID-1: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter>
  Message: Output throttled. IPs: 2; Limit: 10; Override: --limit [1-x;-1
  IF-ID-2: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter>
  Message: Output throttled. IPs: 2; Limit: 10; Override: --limit [1-x;-1
  WAN IP: <filter>
  Device-1: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb
    v: 0.8 bus-ID: 1-14:5 chip-ID: 8087:0025 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 1.04 TiB used: 715.94 GiB (67.4%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: PM981 NVMe 512GB
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: EXA74D1Q temp: 26.9 C scheme: MBR
  ID-2: /dev/nvme1n1 maj-min: 259:4 vendor: Samsung model: SSD 970 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 2B2QEXE7 temp: 37.9 C scheme: GPT
  ID-3: /dev/nvme2n1 maj-min: 259:2 vendor: Samsung model: MZVLV128HCGR-000L2
    size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 5L0QBXV7 temp: 44.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 40 GiB size: 39.08 GiB (97.69%) used: 31.61 GiB (80.9%)
    fs: ext4 dev: /dev/nvme1n1p7 maj-min: 259:11 label: N/A
    uuid: e6463198-1f4d-4692-ac48-203dbb8eab66
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 332 KiB (0.1%) fs: vfat dev: /dev/nvme1n1p5 maj-min: 259:9 label: N/A
    uuid: 0C3D-97D3
  ID-3: /home raw-size: 227.95 GiB size: 223.31 GiB (97.97%)
    used: 208.78 GiB (93.5%) fs: ext4 dev: /dev/nvme1n1p8 maj-min: 259:12
    label: N/A uuid: 2fd7fe9b-78b6-4ab8-a138-80ba2d441f9a
  ID-4: /run/media/ras/Projects raw-size: 476.94 GiB
    size: 476.94 GiB (100.00%) used: 373.41 GiB (78.3%) fs: ntfs
    dev: /dev/nvme0n1p1 maj-min: 259:1 label: Projects uuid: 1BEEFB4560807E27
  ID-5: /run/media/ras/VirtualMachines raw-size: 122.27 GiB
    size: 122.27 GiB (100.00%) used: 101.81 GiB (83.3%) fs: ntfs
    dev: /dev/nvme1n1p9 maj-min: 259:13 label: VirtualMachines
    uuid: 4BB3982176B12B0A
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 2 GiB used: 342.2 MiB (16.7%)
    priority: -2 dev: /dev/nvme1n1p6 maj-min: 259:10 label: N/A
    uuid: e4ab34e4-4bbc-4c58-a23f-d306cef4898d
  ID-1: /dev/nvme1n1p1 maj-min: 259:5 size: 100 MiB fs: vfat label: N/A
    uuid: 0CE4-CABF
  ID-2: /dev/nvme1n1p2 maj-min: 259:6 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-3: /dev/nvme1n1p3 maj-min: 259:7 size: 72.43 GiB fs: ntfs label: N/A
    uuid: 8022FE5C22FE569E
  ID-4: /dev/nvme1n1p4 maj-min: 259:8 size: 505 MiB fs: ntfs label: N/A
    uuid: F050982E5097F994
  ID-5: /dev/nvme2n1p1 maj-min: 259:3 size: 119.24 GiB fs: ntfs label: N/A
    uuid: 0E1EA2297272B549
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-1:2 info: Logitech Unifying Receiver type: Keyboard,Mouse,HID
    driver: logitech-djreceiver,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s
    power: 98mA chip-ID: 046d:c52b class-ID: 0300
  Device-2: 1-10:3 info: Broadcom 5880 type: Smart Card driver: usbfs
    interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 100mA chip-ID: 0a5c:5832
    class-ID: 0b00 serial: <filter>
  Device-3: 1-11:4 info: Realtek Integrated Webcam_HD type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 0bda:5650 class-ID: 0e02 serial: <filter>
  Device-4: 1-14:5 info: Intel Wireless-AC 9260 Bluetooth Adapter
    type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 8087:0025 class-ID: e001
  Hub-2: 2-0:1 info: Super-speed hub ports: 10 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 67.0 C pch: 50.0 C mobo: N/A gpu: nvidia temp: 53 C
  Fan Speeds (RPM): cpu: 3893 fan-2: 3897
  Processes: 347 Uptime: 36m wakeups: 6 Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: 1731
  pm: pacman pkgs: 1726 libs: 441 tools: pamac,trizen,yay pm: flatpak pkgs: 0
  pm: snap pkgs: 5 Shell: Zsh v: 5.9 default: Bash v: 5.1.16
  running-in: yakuake inxi: 3.3.26

thanks, now please post the infos of this 2 commands


glxinfo | grep server

if glxinfo is not present you’ll need to install the “mesa-utils” package


glxinfo | grep server
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions:

well that looks good. X11 is a good base for virtual systems and the nvidia-driver works properly. this should not be the problem. i’m off for the next hours but i’ll look forward here. as i already mentioned the kvm/qemu system is a way more superior to virtualbox, maybe you give it a try.

Thanks a lot for your help. Tomorrow I’ll have a look at the kvm/qemu.

Well, quite some things happened over the last couple of days…
I tried to install the qemu system. I followed the guide from Pavol Elsig as you recommended, downloaded and executed his script, after which my PC didn’t boot again at all (stuck at manufacturer logo) I messed around a little with the graphics drivers and managed to boot my laptop again, surprisingly my Virtual Box was suddenly working again as it should! So now I’m on Linux61 with a working Virtualbox 7.0.6. running a Windows10 Guest, basically problem solved,


Somehow I messed up my Nvidia drivers. I guess it has to do with the installed virtualisation. I can not open the nvidia-settings menu anymore (well I can open it, but there is nothing to set up) also nvidia-smi gave an error message that it couldn’t communicate with the nvidia-driver. I have an external monitor that I would like to use as before, but I can’t get it to work. So I ended up in trying to remove all graphic drivers, trying to install just what I need properly, without succes until now.

I read a lot of forums, they all say the same, remove the drivers with mhwd -r pci name-of-the-driver and reinstall with the same command. I tried several times and drivers, but can’t get it to work. Is there any way to clean up all the graphic-drivers mess I created and properly install just what I need?

Please let me know what kind of outputs are needed in order to fix my issues. Thanks a lot.