Virtualbox 6.1.38 -> 7.0.2 | Windows not starting

I’ve been using virtualbox 6.1.38 to run Widnows 10 and it has been working as a charm.

I have just updated VirtualBox to 7.0.2 and cannot start Windows:

The system remains like this forever

Saved state may be the cause. Delete the saved state for your virtual machine.

@linux-aarhus Many thanks for your reply. I’m afraid I’m not able to find a “delete saved state” or similar option in the Settings menu in VirtualBox. Could you please tell me how to do that? Thanks again.

The virtual machine will have a Saved state in the list.

If your VM does not have this state - it is something else.

Rightclick the VM and select Discard Saved State …

Screenshot

@linux-aarhus Manu thanks again: I can see that menu, but “Discard Saved State” is in grey, so it cannot be clicked…

:man_shrugging:

Other possibilities

  • Ensure USB is set to USB1.1
  • Did you enable EFI when creating the VM?

If you did enable EFI it could be why your VM is failing. Check with SystemMotherboard

@linux-aarhus Many thanks for your reply

It is set to 1.1:

It is disabled:

@linux-aarhus Thanks. So I thought about downgrading to 6.1.38 and check if the problem persists.

$ sudo downgrade virtualbox

And downgrade to the most previous, i.e. 6.1.38

For the virtualbox-host-modules I first check I’m running on 5.10:

$ inxi -S
System:
  Host: david-pc Kernel: 5.10.151-1-MANJARO arch: x86_64 bits: 64
    Desktop: GNOME v: 42.5 Distro: Manjaro Linux

So then I do:

$ sudo downgrade  linux510-virtualbox-host-modules

I run virtualbox, Start the virtual machine but I get these errors:

I forgot to say that I did reboot the system

My fix was to create a new VM with the existing .vdi

1 Like

I know it’s not the solution but I’ve found virt manager /qemu to be much better for running Windows than virtual box or vmware. There are done windows packages I can only run in virt manager

Thank you very much all, but I’d like first to check if the problem still persists with the downgraded version of VirtualBox

@linux-aarhus do you know why I get this errors? Many thanks for all your help, truly

While you may be able to downgrade a package the result is unpredictable and both process and result is unsupported.

This was the only thing that worked here. Thank you!
Hopefully this will be corrected soon

1 Like

@linux-aarhus any news about that?
EDIT: When you create a “new” VM, but reuse an existing Virtual Disk, it work…
Boring doing, but at least it worked!

No there is no news. The good side of that is, that this issues is a lonely bird.

There is only very scarse issues and as such their cause is unknown but likely caused by rare circumstances and it is nothing which can be acted upon.

I use my primary workstation for contract development targeting the windows server platform and I have had no issues syncing the new versions of VirtualBox.

I tried to run my vm with EFI loader but it caused problems when moving to another system.

Major versioning is usually an indicator that backwards compatibility may be broken. So if you are in the habit of using EFI for your virtualbox vm there is slight possibliity of the EFI stub used by VirtualBox may cause it.

1 Like