Virtual webcam works, but i can't switch to it on ometv

i know this might be a silly problem but it was really annoying for me.
hi, i have switched from windows to manjaro three months ago, and this is the biggest problem i have ever faced since then :slightly_smiling_face:.
i use obs virtual camera, i tested it using webcamoid after i disabled my internal webcam in the bios and the virtual webcam works fine.
on windows i used to turn off the webcam and open obs virtual webcam and then turn the webcam on again, and that’s it.

however, when i use ome it give me these masseges:

Windows != LInux and functrionality is expected to be different.

1 Like

obs-studio has an optional dependency v4l2loopback-dkms for virtual camera support, that requires package dkms

To install both packages:

pamac install dkms v4l2loopback-dkms

i installed it and i installed linux headers, and without them, obs virtual webcam wouldn’t work at all.
actually, before i installed v4l2loopback, there was no “Start Virtual Camera” in obs.

If it’s still not working fully, you might also need:

akvcam-dkms  1.2.2-1                                 AUR
    Virtual camera for Linux
1 Like

i installed it, and now it works on telegram video call, but i get the same massage on ometv.
It seems that the problem has something to do with the internet browser or the website itself.