Virtual keyboard works with Manjaro Gnome but not with Phosh


I use the Phosh shell on Manjaro Gnome with the Radxa Zero single board computer.
On the normal Manjaro Gnome shell the virtual keyboard works fine. But when I install and activate Phosh it doesn’t works. Do I need to install something extra for it?

What virtual keyboard?

Phosh uses squeekboard as their OSK and that’s what we ship on our Phosh images.

I searched for the squeekboard in the store and it wasn’t installed. But after installing and restarting it still doesn’t works.
This are the steps I made to install and activate Phosh.

  1. Go to the Store and install Phosh.
  2. Execute "systemctl enable phosh“ and “systemctl start phosh” in the command line.

Maybe you still need:

Where do I need to save this file? I couldn’t find the exact path.

Should be in:


And make sure you make it executable.

Thanks it works like expected.

If someone got the same problem. To make the file executable execute the command.

sudo chmod +x /usr/bin/osk-wayland

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.