Virtual box not working showing errors instead on trying to start virtual environment

i am getting this error when i try to start a vm in virtualbox
what can i do now?

Has it ever worked before or is this the initial setup?
If the latter is the case then the installation is still incomplete. and the message tells you where to look.

VirtualBox - ArchWiki

Read the full topic [root tip] VirtualBox - Installation - USB - Shared Folder


Hey @KDE! Now I’m not going to say anything about “why it happend” or “what does this command do” but how to fix this problem. So, try these commands to fix the problem.

IMPOTANT:- You have to run these commands on separate reboots! After each reboot and commands try this VBoxManage --version (to ensure that virtualbox is fixed)

sudo /sbin/vboxconfig
If that doesn’t work:-
sudo /sbin/rcvboxdrv setup
sudo /usr/lib/virtualbox/ setup

Tell me if these didn’t work. :grin:

thanks it worked

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.