Virtual Box Kernel driver not installed (rc=1908)

I tried to make a VM with Virtualbox and followed the manjaro wiki steps and when I tried to load the VM with the windows ISO I got the Error mentioned on the tittle of this post, I’ve tried checking if I had installed the Linux515 and it shows up as installed, I’ve also tried doing sudo pacman -S virtualbox-host-dkms so I don’t know what’s wrong with my Kernel, if anyone can help me I appreciate the effort! I’ll try to respond ASAP and if you need anything from me just let me know!

Do you have the linux515-virtualbox-host-modules package installed?

I feel like you might have missed a step in the wiki. Did you reboot, did you add your user to the vboxusers group?

I Prolly missed this step, but when I went to the settings and I didn’t see the setting to put me in the vboxuser group, I’ll try to see if I can figure it out

still didn’t work, I didn’t had the boxes ticked but I tried it again and it didn’t work, now about the linux515 I Installed it with the following command “sudo pacman -Syu virtualbox-guest-utils linux54-virtualbox-guest-modules”, “sudo pacman -S virtualbox-host-dkms” and this “sudo pacman -S linux515-virtualbox-host-modules” I don’t know what step I’m missing rn

After installing virtualbox you must run this command in terminal (without it vbox won’t run and will cry about kernel):

sudo modprobe vboxdrv

This will add you to the vboxusers group
sudo gpasswd -a $USER vboxusers
You also need linux515-virtualbox-guest-modules not linux54-virtualbox-guest-modules.
Then reboot to load virtualbox

Got this error…
modprobe: FATAL: Module vboxdrv not found in directory /lib/modules/5.15.60-1-MANJARO

Install virtualbox-host-dkms and run the command again. Whenever I need virtualbox, I always install these two packages: virtualbox virtualbox-host-dkms and never had a problem running the command I gave you.