Virtual Box- Display Resolution and Configuration Question

Hoping somebody may be able to assist. I am running VirtualBox with Manjaro xfce as Host with Arch Linux and Windows 10 Pro as Guests. Laptop is a Dell 15R 5537, inxi copied below.
First Question (probably a dumb question) Do I need to enable Trim on this(Arch)install? Does it have any benefit?

Second Question: Display Resolution offered in Arch and the one that works best is 1366x768 @60 Hz. No issue with Arch.
On Windows 10 The best resolution that works is 1024x768 and the others offered are 800x600, 1152x864,1280x1024 and 1600x1200.
Is there anyway that I can get Windows to offer 1366x768 as that seems ideal. I don’t see any updated video drivers on Dell’s website and Windows searched but claims the native driver is fine. I only use Windows to do my taxes as the tax software is only offered in Win and Mac :frowning:

System:
  Kernel: 5.9.8-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=c63cf222-2a4b-4818-9b5a-c77ee7eb0bdf rw ipv6.disable=1 quiet 
  apparmor=1 security=apparmor nmi_watchdog=0 nowatchdog udev.log_priority=3 
  Desktop: Xfce 4.14.3 tk: Gtk 3.24.23 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Portable System: Dell product: Inspiron 5537 v: A12 serial: <filter> 
  Chassis: type: 8 v: A12 serial: <filter> 
  Mobo: Dell model: 0845MX v: A00 serial: <filter> UEFI [Legacy]: Dell v: A12 
  date: 05/27/2019 
Battery:
  ID-1: BAT1 charge: 43.6 Wh condition: 43.6/66.6 Wh (65%) volts: 12.8/11.1 
  model: LGC DELL 0MF6936I type: Li-ion serial: <filter> status: Full 
CPU:
  Info: Dual Core model: Intel Core i5-4200U bits: 64 type: MT MCP 
  arch: Haswell family: 6 model-id: 45 (69) stepping: 1 microcode: 26 
  L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 18366 
  Speed: 798 MHz min/max: 800/2600 MHz Core speeds (MHz): 1: 905 2: 1410 
  3: 1383 4: 1417 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Dell driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:0a16 
  Device-2: Microdia Dell Laptop Integrated Webcam HD type: USB 
  driver: uvcvideo bus ID: 1-1.8:6 chip ID: 0c45:64ad 
  Display: x11 server: X.org 1.20.9 driver: intel unloaded: modesetting 
  alternate: fbdev,vesa resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) 
  v: 4.5 Mesa 20.2.2 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Haswell-ULT HD Audio vendor: Dell driver: snd_hda_intel 
  v: kernel bus ID: 00:03.0 chip ID: 8086:0a0c 
  Device-2: Intel 8 Series HD Audio vendor: Dell driver: snd_hda_intel 
  v: kernel bus ID: 00:1b.0 chip ID: 8086:9c20 
  Sound Server: ALSA v: k5.9.8-2-MANJARO 
Network:
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell 
  driver: r8169 v: kernel port: 3000 bus ID: 01:00.0 chip ID: 10ec:8136 
  IF: enp1s0 state: down mac: <filter> 
  Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  vendor: Dell driver: ath9k v: kernel port: 3000 bus ID: 02:00.0 
  chip ID: 168c:0036 
  IF: wlp2s0 state: down mac: <filter> 
  Device-3: Qualcomm Atheros AR9462 Bluetooth type: USB driver: btusb 
  bus ID: 1-1.5:7 chip ID: 0cf3:0036 
  Device-4: ASIX AX88179 Gigabit Ethernet type: USB driver: ax88179_178a 
  bus ID: 3-2:2 chip ID: 0b95:1790 serial: <filter> 
  IF: enp0s20u2 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 465.76 GiB used: 70.27 GiB (15.1%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Western Digital model: WDBNCE5000PNC-WRSN 
  size: 465.76 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 10WD scheme: MBR 
Partition:
  ID-1: / raw size: 97.66 GiB size: 95.62 GiB (97.92%) used: 20.68 GiB (21.6%) 
  fs: ext4 dev: /dev/sda1 
Swap:
  Alert: No Swap data was found. 
Sensors:
  System Temperatures: cpu: 48.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 178 Uptime: 2h 21m Memory: 7.67 GiB used: 603.7 MiB (7.7%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1284 lib: 357 
  Shell: Zsh v: 5.8 running in: xfce4-terminal inxi: 3.1.08

I finally figured out how to get Guest Additions installed properly on the Windows Guest and it is working for the resolution. Bidirectional clipboard and Drag and Drop remains a mystery.