Virt-Manager QEMU Issue with Sidebuttons PS2 Mouse driver is not changeable to Microsoft PS2

Hi everyone,

i am currently trying out QEMU and have a Win11 VM. I already have my first Problem that the side buttons, for going backwards and forwards, are not working.

I have already done a bit of research on this and there should be a quick fix which is simply in Windows 11 i am to and i a quote a Redditor: “Launch Device Manager Open the Mice and other pointing devices section Right-click on PS/2 Compatible Mouse and select Update Driver Select Browse my computer for driver software Select the Let me pick from a list of available drivers on my computer option Untick the Show compatible hardware checkbox Select Microsoft (default) in the left pane, and then scroll until you find Microsoft PS/2 in the right pane”

I also checked out VirtualBox and checked the drivers there and it was “Microsoft PS/2”. In VirtualBox i was able to use my side buttons without any issue due to this driver. But in QEMU/Virtmanager i am unable to switch the drivers. Everytime i try to update the driver and reboot it would reboot to have the “PS/2 Compatible Mouse” driver installed. This feels like a simple XML change. On QEMU/Virtmanager the mouse XML is so i need to know what the bus name for “Microsoft PS/2” is.

Can anyone help me out with this issue?
i made a video:
Thank you

windows is a little bit weird but red-hat developed a driver for it:
there is a link how to use it and where to download

additional: make sure that you add “libvirt” and “kvm” to your groups-membership

was in the groups membership, already downloaded the virtio drivers. still the same issue.

okay, as far as i understand you’re using a real ps/2 mouse that needs complete acces to the tty. there might be some additional needed to passtrough serial signals.
add your user to the “uucp” group. this handles the serial access.
reboot to make all changes take effect and after rebooting retry installation and report please.

p.s.: how is this mouse physical connected ?

i have added the user to the “uucp” group and tried to change the mouse driver again, now it seems the vm is having trouble booting up at all. The mouse is connected wirelessly.
i have to see how i can boot up the vm again will report back. It boots into Windows 11 Automatic Repair.

seems when im booting up now it changes the firmware from UEFI to UEFI x86_64: /usr/share/OVMF/

seems the vm, after repairing, still doesnt want to change the mouse driver → after repairing i tried changing it against to microsoft ps/2 mouse but it went into automatic repair loop again.