Virt-Manager / Gnome-Boxes: No screen found


I’ve got the problem that every VM in virt-manager can’t find a screen and thus crashes. I am able to see the grub bootloader just fine. I can also see the BIOS logo, but afterwards, I’m getting the error that no screen could be found.

Windows shows the following error:

The problem occurs using gnome-boxes as well! Installing virtualbox and using that, works, thought.

Settings in virt-manager:

  • Hypervisor: KVM
  • Architecture: x86_64
  • Emulator: /usr/bin/qemu-system-x86_64
  • Chipset: Q35
  • Firmware: UEFI x86_64: /usr/share/edk2-ovmf/x64/OVMF_CODE.secboot.fd (BIOS results in the same error)

Video Model is Virtio (3D acceleration disabled as that causes some OpenGL error).

I’m using Kernel 5.15.53-1-MANJARO and mesa gpu drivers for my AMD GPU.
Those errors occur directly when trying to install the operating system!

Hello, you did everything as described in Virt-Manager - ArchWiki ?

1 Like

I don’t have experience with virt-manager or gnome-boxes.

The no screen found-message makes me think you are using wayland - is that correct?

1 Like

Yes, I’m using Wayland.

I skipped the configuration step, as the conig file said, that is not necessary when using systemd which I assume I am using. I assume it, because it’s not listed in this guide which I followed.

Fair enough, yeah, the manjaro wiki in that regard provides more info, but yeah, the only thing to test is with x11 session instead of Wayland…

Ok, using doesn’t solve the problem. However, I noticed that before that error appears, another erorr pops up for a second.
This error pops up just before that error pops up:

I think we all meant that the VM to run X11 … i guess :slightly_smiling_face:

Well, I can’t change what the VM is using internally (at least not during the installation process). Based on the picture, the Linux VMs are using X11. The Windows VM obviously not.
On the host system I tried both Wayland here and X11 here.

Testing it with some ova files from REMnux (converting to qcow2), those just show a black screen instead of booting.

Any idea? It seems to work fine on Fedora on my laptop for some reason.

Heya, for reference I use virt manager and run gnome with wayland as a host. I can start manjaro en windows guests and do not experience the issues you describe.

I remember having to have to change the Video model setting to get the guest to use the screen output properly. Currently this is set to QXL for manjaro and windows. This might be a setting to try.

Ok. This seems to have fixed the issue for all my Linux VMs. Windows still doesn’t seem to work, but all linux vms now get past the initial boot screen.
Now the question is: Why does it fix it for Linux, but not for Windows guests.

For windows I use the bios as firmware, that is the only difference I can see with the info provided.

One thing I could find when searching for the windows error is the option to change the way the VM sees the CPU and if the CPU should be exposed (host-model) or something else. This might lead you to an answer.

Another thing to consider is the recent updates that split the qemu stack, you might miss something:

Other then that I’m out of ideas in this case. Hope you find a solution.

1 Like

I’ve got qemu-desktop installed.

Default virt-manager settings and BIOS firmware:

for reference the list of qemu packages installed on my system:

qemu-audio-alsa                          7.1.0-5                           extra      26,7 kB
qemu-audio-dbus                          7.1.0-5                           extra      30,9 kB
qemu-audio-jack                          7.1.0-5                           extra      22,6 kB
qemu-audio-oss                           7.1.0-5                           extra      18,5 kB
qemu-audio-pa                            7.1.0-5                           extra      22,6 kB
qemu-audio-sdl                           7.1.0-5                           extra      14,4 kB
qemu-audio-spice                         7.1.0-5                           extra      18,6 kB
qemu-block-curl                          7.1.0-5                           extra      38,6 kB
qemu-block-dmg                           7.1.0-5                           extra      14,1 kB
qemu-block-nfs                           7.1.0-5                           extra      27,6 kB
qemu-block-ssh                           7.1.0-5                           extra      44,1 kB
qemu-chardev-spice                       7.1.0-5                           extra      26,6 kB
qemu-common                              7.1.0-5                           extra      4,5 MB
qemu-desktop                             7.1.0-5                           extra      
qemu-hw-display-qxl                      7.1.0-5                           extra      101,0 kB
qemu-hw-display-virtio-gpu               7.1.0-5                           extra      66,3 kB
qemu-hw-display-virtio-gpu-gl            7.1.0-5                           extra      35,0 kB
qemu-hw-display-virtio-gpu-pci           7.1.0-5                           extra      14,3 kB
qemu-hw-display-virtio-gpu-pci-gl        7.1.0-5                           extra      14,1 kB
qemu-hw-display-virtio-vga               7.1.0-5                           extra      14,7 kB
qemu-hw-display-virtio-vga-gl            7.1.0-5                           extra      14,1 kB
qemu-hw-s390x-virtio-gpu-ccw             7.1.0-5                           extra      14,3 kB
qemu-hw-usb-host                         7.1.0-5                           extra      56,7 kB
qemu-hw-usb-redirect                     7.1.0-5                           extra      68,5 kB
qemu-hw-usb-smartcard                    7.1.0-5                           extra      32,2 kB
qemu-img                                 7.1.0-5                           extra      10,9 MB
qemu-pr-helper                           7.1.0-5                           extra      1,0 MB
qemu-system-x86                          7.1.0-5                           extra      37,4 MB
qemu-tools                               7.1.0-5                           extra      2,2 MB
qemu-ui-curses                           7.1.0-5                           extra      43,0 kB
qemu-ui-dbus                             7.1.0-5                           extra      256,0 kB
qemu-ui-egl-headless                     7.1.0-5                           extra      14,2 kB
qemu-ui-gtk                              7.1.0-5                           extra      79,8 kB
qemu-ui-opengl                           7.1.0-5                           extra      31,1 kB
qemu-ui-sdl                              7.1.0-5                           extra      43,0 kB
qemu-ui-spice-app                        7.1.0-5                           extra      14,2 kB
qemu-ui-spice-core                       7.1.0-5                           extra      69,0 kB
qemu-vhost-user-gpu                      7.1.0-5                           extra      772,2 kB
qemu-virtiofsd                           7.1.0-5                           extra      835,0 kB

Searching for the stop code and virtmanager/libvirt/qemu should provide some leads. sharing more info could help others help you further.

edit: I’m not sure windows likes a change from efi to bios on installed systems.

It’s not an installed system. Just the installer iso.

How can I get those details?

sharing more info could help others help you further:

ManjaroLinux 22.0.0 Sikaris
  Kernel: 5.15.65-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
Desktop: GNOME v: 42.4 tk: GTK v: 3.24.34 wm: gnome-shell dm: GDM v: 42.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASRock model: X399 Taichi serial: <superuser required>
    UEFI: American Megatrends v: P3.60 date: 02/19/2019
  Info: model: AMD Ryzen Threadripper 1950X bits: 64 type: MT MCP MCM
    arch: Zen level: v3 built: 2017-19 process: GF 14nm family: 0x17 (23)
    model-id: 1 stepping: 1 microcode: 0x8001137
  Flags: 3dnowprefetch abm adx aes amd_dcm aperfmperf apic arat avic avx
    avx2 bmi1 bmi2 bpext clflush clflushopt clzero cmov cmp_legacy
    constant_tsc cpb cpuid cr8_legacy cx16 cx8 de decodeassists extapic
    extd_apicid f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate
    ibpb irperf lahf_lm lbrv lm mca mce misalignsse mmx mmxext monitor movbe
    msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae
    pat pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rapl rdrand rdseed rdtscp rep_good
    sep sev sha_ni skinit smap smca sme smep ssbd sse sse2 sse4_1 sse4_2 sse4a
    ssse3 succor svm svm_lock syscall tce topoext tsc tsc_scale
    v_vmsave_vmload vgif vmcb_clean vme vmmcall wdt xgetbv1 xsave xsavec
    xsaveerptr xsaveopt xsaves
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] vendor: PC
    Partner / Sapphire driver: amdgpu v: kernel arch: GCN-4
    code: Arctic Islands process: GF 14nm built: 2016-20 pcie: gen: 3
    speed: 8 GT/s lanes: 16 ports: active: DP-1,DP-2
  Display: wayland server: v: with: Xwayland v: 22.1.3
    compositor: gnome-shell driver: X: loaded: amdgpu
    unloaded: modesetting,radeon alternate: fbdev,vesa gpu: amdgpu
    display-ID: 0

From journalctl, this is the only thing that seems relevant, maybe:

Sep 24 02:03:36 ShadowDragon gdm[1922]: Gdm: Failed to list cached users: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name :1.13 was not provided by any .service files
Sep 24 02:03:36 ShadowDragon systemd-coredump[173163]: Failed to connect to coredump service: Connection refused

And the application log:

$ sudo cat /var/log/libvirt/qemu/win10-2.log                       ✔ 
2022-09-25 00:19:01.931+0000: Starting external device: TPM Emulator
/usr/bin/swtpm socket --ctrl type=unixio,path=/run/libvirt/qemu/swtpm/4-win10-2-swtpm.sock,mode=0600 --tpmstate dir=/var/lib/libvirt/swtpm/7514c0e0-85b6-4a6d-8e29-ee0fe392e26a/tpm2,mode=0600 --log file=/var/log/swtpm/libvirt/qemu/win10-2-swtpm.log --terminate --tpm2
2022-09-25 00:19:01.949+0000: starting up libvirt version: 8.7.0, qemu version: 7.0.0, kernel: 5.15.65-1-MANJARO, hostname: ShadowDragon
PATH=/usr/local/sbin:/usr/local/bin:/usr/bin:/var/lib/snapd/snap/bin \
HOME=/var/lib/libvirt/qemu/domain-4-win10-2 \
XDG_DATA_HOME=/var/lib/libvirt/qemu/domain-4-win10-2/.local/share \
XDG_CACHE_HOME=/var/lib/libvirt/qemu/domain-4-win10-2/.cache \
XDG_CONFIG_HOME=/var/lib/libvirt/qemu/domain-4-win10-2/.config \
/usr/bin/qemu-system-x86_64 \
-name guest=win10-2,debug-threads=on \
-S \
-object '{"qom-type":"secret","id":"masterKey0","format":"raw","file":"/var/lib/libvirt/qemu/domain-4-win10-2/master-key.aes"}' \
-machine pc-q35-7.0,usb=off,vmport=off,dump-guest-core=off,memory-backend=pc.ram \
-accel kvm \
-cpu host,migratable=on,hv-time=on,hv-relaxed=on,hv-vapic=on,hv-spinlocks=0x1fff \
-m 4096 \
-object '{"qom-type":"memory-backend-ram","id":"pc.ram","size":4294967296}' \
-overcommit mem-lock=off \
-smp 2,sockets=2,cores=1,threads=1 \
-uuid 7514c0e0-85b6-4a6d-8e29-ee0fe392e26a \
-no-user-config \
-nodefaults \
-chardev socket,id=charmonitor,fd=33,server=on,wait=off \
-mon chardev=charmonitor,id=monitor,mode=control \
-rtc base=localtime,driftfix=slew \
-global kvm-pit.lost_tick_policy=delay \
-no-hpet \
-no-shutdown \
-global ICH9-LPC.disable_s3=1 \
-global ICH9-LPC.disable_s4=1 \
-boot strict=on \
-device '{"driver":"pcie-root-port","port":16,"chassis":1,"id":"pci.1","bus":"pcie.0","multifunction":true,"addr":"0x2"}' \
-device '{"driver":"pcie-root-port","port":17,"chassis":2,"id":"pci.2","bus":"pcie.0","addr":"0x2.0x1"}' \
-device '{"driver":"pcie-root-port","port":18,"chassis":3,"id":"pci.3","bus":"pcie.0","addr":"0x2.0x2"}' \
-device '{"driver":"pcie-root-port","port":19,"chassis":4,"id":"pci.4","bus":"pcie.0","addr":"0x2.0x3"}' \
-device '{"driver":"pcie-root-port","port":20,"chassis":5,"id":"pci.5","bus":"pcie.0","addr":"0x2.0x4"}' \
-device '{"driver":"pcie-root-port","port":21,"chassis":6,"id":"pci.6","bus":"pcie.0","addr":"0x2.0x5"}' \
-device '{"driver":"pcie-root-port","port":22,"chassis":7,"id":"pci.7","bus":"pcie.0","addr":"0x2.0x6"}' \
-device '{"driver":"pcie-root-port","port":23,"chassis":8,"id":"pci.8","bus":"pcie.0","addr":"0x2.0x7"}' \
-device '{"driver":"pcie-root-port","port":24,"chassis":9,"id":"pci.9","bus":"pcie.0","multifunction":true,"addr":"0x3"}' \
-device '{"driver":"pcie-root-port","port":25,"chassis":10,"id":"pci.10","bus":"pcie.0","addr":"0x3.0x1"}' \
-device '{"driver":"pcie-root-port","port":26,"chassis":11,"id":"pci.11","bus":"pcie.0","addr":"0x3.0x2"}' \
-device '{"driver":"pcie-root-port","port":27,"chassis":12,"id":"pci.12","bus":"pcie.0","addr":"0x3.0x3"}' \
-device '{"driver":"pcie-root-port","port":28,"chassis":13,"id":"pci.13","bus":"pcie.0","addr":"0x3.0x4"}' \
-device '{"driver":"pcie-root-port","port":29,"chassis":14,"id":"pci.14","bus":"pcie.0","addr":"0x3.0x5"}' \
-device '{"driver":"qemu-xhci","p2":15,"p3":15,"id":"usb","bus":"pci.2","addr":"0x0"}' \
-device '{"driver":"virtio-serial-pci","id":"virtio-serial0","bus":"pci.3","addr":"0x0"}' \
-blockdev '{"driver":"file","filename":"/var/lib/libvirt/images/win10-2.qcow2","node-name":"libvirt-2-storage","auto-read-only":true,"discard":"unmap"}' \
-blockdev '{"node-name":"libvirt-2-format","read-only":false,"discard":"unmap","driver":"qcow2","file":"libvirt-2-storage","backing":null}' \
-device '{"driver":"ide-hd","bus":"ide.0","drive":"libvirt-2-format","id":"sata0-0-0","bootindex":2}' \
-blockdev '{"driver":"file","filename":"/mnt/ee61cf61-af75-4930-9f5e-a51e1c67d259/VMs/Win10_21H2_EnglishInternational_x64.iso","node-name":"libvirt-1-storage","auto-read-only":true,"discard":"unmap"}' \
-blockdev '{"node-name":"libvirt-1-format","read-only":true,"driver":"raw","file":"libvirt-1-storage"}' \
-device '{"driver":"ide-cd","bus":"ide.1","drive":"libvirt-1-format","id":"sata0-0-1","bootindex":1}' \
-netdev tap,fd=34,id=hostnet0 \
-device '{"driver":"e1000e","netdev":"hostnet0","id":"net0","mac":"52:54:00:45:16:08","bus":"pci.1","addr":"0x0"}' \
-chardev pty,id=charserial0 \
-device '{"driver":"isa-serial","chardev":"charserial0","id":"serial0","index":0}' \
-chardev spicevmc,id=charchannel0,name=vdagent \
-device '{"driver":"virtserialport","bus":"virtio-serial0.0","nr":1,"chardev":"charchannel0","id":"channel0","name":"com.redhat.spice.0"}' \
-chardev socket,id=chrtpm,path=/run/libvirt/qemu/swtpm/4-win10-2-swtpm.sock \
-tpmdev emulator,id=tpm-tpm0,chardev=chrtpm \
-device '{"driver":"tpm-crb","tpmdev":"tpm-tpm0","id":"tpm0"}' \
-device '{"driver":"usb-tablet","id":"input0","bus":"usb.0","port":"1"}' \
-audiodev '{"id":"audio1","driver":"spice"}' \
-spice port=5900,addr=,disable-ticketing=on,image-compression=off,seamless-migration=on \
-device '{"driver":"qxl-vga","id":"video0","max_outputs":1,"ram_size":67108864,"vram_size":67108864,"vram64_size_mb":0,"vgamem_mb":16,"bus":"pcie.0","addr":"0x1"}' \
-device '{"driver":"ich9-intel-hda","id":"sound0","bus":"pcie.0","addr":"0x1b"}' \
-device '{"driver":"hda-duplex","id":"sound0-codec0","bus":"sound0.0","cad":0,"audiodev":"audio1"}' \
-chardev spicevmc,id=charredir0,name=usbredir \
-device '{"driver":"usb-redir","chardev":"charredir0","id":"redir0","bus":"usb.0","port":"2"}' \
-chardev spicevmc,id=charredir1,name=usbredir \
-device '{"driver":"usb-redir","chardev":"charredir1","id":"redir1","bus":"usb.0","port":"3"}' \
-device '{"driver":"virtio-balloon-pci","id":"balloon0","bus":"pci.4","addr":"0x0"}' \
-sandbox on,obsolete=deny,elevateprivileges=deny,spawn=deny,resourcecontrol=deny \
-msg timestamp=on
char device redirected to /dev/pts/1 (label charserial0)
qxl_send_events: spice-server bug: guest stopped, ignoring
2022-09-25T00:19:30.113695Z qemu-system-x86_64: terminating on signal 15 from pid 86739 (/usr/bin/libvirtd)
2022-09-25 00:19:30.314+0000: shutting down, reason=destroyed

Installed qemu packages:

$ sudo pacman -Q | awk '{print $1}' | grep "qemu"

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.