Virt-Manager errors

hi folks,

im creating a windows vm to game and in virt-manager i get the error:

Unable to connect to libvirt qemu:///system.

Verify that the ‘libvirtd’ daemon is running.

Libvirt URI is: qemu:///system

Traceback (most recent call last):
File “/usr/share/virt-manager/virtManager/”, line 922, in _do_open, data)
File “/usr/share/virt-manager/virtinst/”, line 153, in open
conn = libvirt.openAuth(self._open_uri,
File “/usr/lib/python3.9/site-packages/”, line 104, in openAuth
if ret is None:raise libvirtError(‘virConnectOpenAuth() failed’)
libvirt.libvirtError: Failed to connect socket to ‘/var/run/libvirt/libvirt-sock’: Connection refused

Try running

sudo systemctl enable --now libvirtd.service

then try again.

same error

1 Like

Weird,restart the computer just in case.

yea rebooted and same error

@XRaTiX post was meant to ensurelibvirtd.service is running. Check with:

$ systemctl status libvirtd.service

Has that socket been created?

ls -l /var/run/libvirt/libvirt-sock
Is your user a member of libvirt group?

1 Like

Thank you guys. This was very helpful for me.