VIM 2 - install 20.12 to emmc

Hi there!
Wonderful experience with latest build from sd card. Thumbs up!
Tried to install to emmc with manjaro-flash : which did its job and was apparently successful.
Alas, my VIM 2 is now bricked. Can’t boot anything, even Krescue.
Any ideas?
Thks in advance and a happy new year to all Manjaro teams and users!

Hello and welcome to the forum.

Yes I know why, coz amlogic bootloader keeps updating and keeps breaking the device that’s the reason most amlogic maintainers are dropping support for amlogic boards :frowning:

If you want to use Manjaro on emmc then best is to use mainline image for it.

It is impossible to not be able to boot in krescue just like it impossible to brick the device.
Enter into maskrom mode with krescue and flash vim2 emmc image but once you update it then it will break again coz krescue images are manipulated manually which I have adviced not to but I can’t keep explaining them that Rolling release distro are not the same as Other distro.

I will make a mainline image for sd and emmc soon as I am living the performance of vim1 and vim2 with the lima and panfrost support.

Thanks for informing.

UPDATE: I have prepared Mainline uboot sd and emmc image for vim2 as it can boot over bsp uboot on emmc using maskrom mode. I have KDE-Plasma sd and emmc image.

Please share which DE have you tried?

I have created images for KDE-Plasma and XFCE emmc installer as well as normal sd card image.

If you plan to install the OS on emmc then use the emmc-installer file and flash it on sd card and then boot into the sd card by press function key 2 times.

Vim2-02-01-2020-Images it is uploading now, give it sometime and match the md5sums before flashing, as I am off to sleep now.

Good Luck and Enjoy.

Thank you so much for your reply.
Twizers (maskrom) and then krescue to erase emmc.
Then tried your latest image.
To no avail : “no write permission” or something similar.
No luck …!
BTW, I used the KDE image. Quiet impressed! Everything was working (did not test eth : I used the wifi). An 1080p movie : flawless.
Although the mouse cursor was annoying : it blinked at high intervals.
So, I’m still eager to succeed that emmc installation!

Take care!

Yes that’s panfrost but.

Which latest image?
How did you flash it?

You can erase the emmc and then flash emmc-installer image on sd card and then boot vim2 with the same sd card it will start with emmc installer, i guess you’re trying to flash the image over sd card instead of emmc.

Please share more details of the steps you’re trying to flash it on emmc.

I’ve submitted the images for krescue team to use these images in future.

I used “…fkardame…/Linux/Images/Khadas/Vim2/” which you sent me with your answer. Burnt it to an SD card (remember my emmc is empty) via rufus or etcher.
Then I switched to Krescue and reinstalled an older version (cli only).
Alas, my vim2 behaves strangely now : bootloop (did not find device dmc3w@90000 … or whatever); finally boot (after numerous reboots). I’m afraid there’s some shortcircuit over there.
And it’s me blowing up the fuse and giving up.
Too much wasted time for too little fun.
Thanks anyway!!

It will be helpful if you can give the accurate name of the file you used.

I am confused, why you tried to use krescue?

The files I shared is to be used directly without krescue.
If you want to try os on sd card then use image which doesn’t haveemmc-installer in the name and if you want to flash os on emmc then flash image with emmc-installer in the image.

Using either is the file user can just flash it sd card and start booting it.

If you have hardware issue then it will be hard to know why it is not booting.

Anyways good luck.


For clarity’s sake : I burnt " Manjaro-ARM-kde-plasma-vim2-Mainline-02-01-2021-emmc-installer-21.01.img".
It booted (after many retries due to hardware issues I suppose).
This installer stopped with “no write permission” or something similar.
This message was sent wether the emmc was populated or not (after wiping partitions).
Reason why I reverted to Krescue and finally gave up due to bootloop issues.

Hope it might help.

Thanks for your interest!

No idea why you’re facing this. I always test the image before sharing it. I can also confirm that it works as I shared it with Hyphop who used the same image for krescue now.

I think you should post in khadas forum as they will be able to identify what is wrong.

Will give it a try next week end.
If I ever succeed through that ordeal, I promise I’ll keep you posted!
Anyway, thumbs up for your concern. I really appreciated!

1 Like

I said I would revert to you…
My board has indeed a short circuit : it will fail if not in a “special” position…

When it’s in such special position, I manage to boot from sdcard.
I then use manjaro-arm-flash to install on emmc.
Tried with Mate and Kde editions.
The flashing process now works all right. _Root and _Boot partitions are created and populated as expected.
But systemd fails to mount /boot.
For an unknown reason, I also fail on cli. Mount does not provide a precise clue.

All I know is that the emmc is also populated by 2 partitions, each 4M, emmcblk2boot? (0 or 1).
None of which is legible (unknown fs).

I tried to erase the emmc but still got these 2 partitions.

Any idea??