Viewnior - Set as Wallpaper doesn't work for XFCE *Solution = Ristretto*

“Even though I have set the desktop to XFCE in the preferences “Set as Wallpaper” doesn’t work.”

https://bugs.launchpad.net/viewnior/+bug/1661712

Can Manjaro XFCE solve this problem?

Last stable version here (Manjaro XFCE). This “error” was also in the older stable versions.

Rgds,
Miroslav

1 Like

Seems like there is a fix for that: https://github.com/hellosiyan/Viewnior/pull/18/files

The first step would be to check if the fix is actually working. Here is the PKGBUILD for it: https://git.archlinux.org/svntogit/community.git/plain/trunk/PKGBUILD?h=packages/viewnior One would need to add an sed line or a patch implementing the fix. If it works, post a positive review in the github pull request to get it merged faster.

It can be also fixed at packaging level, but it’s always easier to get it fixed upstream. :slight_smile:

Worst case scenario, you can still change your wallpaper from the Xfce Settings.

2 Likes

Solution = Ristretto.

I think that Ristretto should be installed by default in MJRO XFCE.

2 Likes

Good tip!

This bug was fixed in Viewnior 1.7 released May 13. viewnior-git 1.7.r2 is in the AUR. It will probably be in official arch repos soon enough.

Thunar has ‘set as wallpaper’ right-click menu option for images

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by