Viewing files on a network drive

Why are you using smb:// ?

You’re supposed to browse the location defined in the systemd mount unit. For example,


Assuming everything else is working / enabled.

You can check the status of these units:

systemctl status mnt-cifs-macmini.mount
systemctl status mnt-cifs-macmini.automount

I can’t type the address in the Files manager which I presume is Nautilius to take me there.

Just browse to /mnt/cifs/macmini

And better yet, add it to your Favorites for quick access from your Places and panel.

Did you check the status of the units?

Mar 12 10:23:03 manjaro systemd[1]: Mounting CIFS network mount for macmini…
Mar 12 10:23:03 manjaro mount[1583]: mount error(22): Invalid argument
Mar 12 10:23:03 manjaro mount[1583]: Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)
Mar 12 10:23:03 manjaro systemd[1]: mnt-cifs-macmini.mount: Mount process exited, code=exited, status=32/n/a
Mar 12 10:23:03 manjaro systemd[1]: mnt-cifs-macmini.mount: Failed with result ‘exit-code’.
Mar 12 10:23:03 manjaro systemd[1]: Failed to mount CIFS network mount for macmini.

When I type in >> systemctl status mnt-cifs-macmini.automount it shows up in files but still get the broken pipe message whenever I try to view a text file?

Ok. It seems I can’t open txt files but pictures and pdf seems okay?

When I get home I can help out better. Using my phone right now. Hard to type.

It sounds like you’re using GVFS (by using the file manager’s smb://). Remember, we’re trying to set up native kernel CIFS using systemd mounts. The error message means there’s something incorrect in your mount unit.

Do I need to setup anything on the server side?

No. Nothing required of the server. The issue is in your mount unit according to the error message.

I can be home in about two hours.

You can paste the contents of your unit files in the meantime.

I can always use just systemctl without sudo
For example:
systemctl restart bluetooth
I’ll get prompted for the password to perform the action.

1 Like

ok. I’ll check the mnt-cifs-macmini.mount file

Is this correct @winnie : WantedBy=multi-user.targetmacmini

or should there be a period between targetmacmini so its target.macmini

I’m the wrong person to ask - @winnie will know … :wink:

ookay. thanks

No. That part must be the same for all units. It basically means it’s a service/unit that is ready upon a standard booted up system.

“” is a very common “WantedBy” target.

It’s in my template.

@winnie I rebooted and macmini shows up .it seems I can open files on the server EXCEPT text documents. I even tried with thunar but no go?

Output of the status for both units?

stemctl status mnt-cifs-macmini.mount
○ mnt-cifs-macmini.mount - CIFS network mount for macmini
Loaded: loaded (/etc/systemd/system/mnt-cifs-macmini.mount; disabled; vendor preset: disabled)
Active: inactive (dead)
TriggeredBy: ● mnt-cifs-macmini.automount
Where: /mnt/cifs/macmini
What: //

systemctl status mnt-cifs-macmini.automount
● mnt-cifs-macmini.automount - Automount for CIFS macmini
Loaded: loaded (/etc/systemd/system/mnt-cifs-macmini.automount; enabled; vendor preset: disabled)
Active: active (waiting) since Sat 2022-03-12 11:10:38 AEST; 45min ago
Until: Sat 2022-03-12 11:10:38 AEST; 45min ago
Triggers: ● mnt-cifs-macmini.mount
Where: /mnt/cifs/macmini

Notice: journal has been rotated since unit was started, output may be incomplete.

I’ll be home soon. I noticed something in your output.