Video playback in all browsers not working

good morning everybody :slight_smile:

After the recent updates all the in browser videos stopped to work on vivaldi and on firefox, be it played back from youtube or vimeo etc… any idea what could have caused this ? as both browsers are affected, it could easily be a global video problem? the videos load and freeze on the first frame. any hint is appreciated. Thank you!

I m on a thinkpadx220 with xfcedesktop

Please post the output of inxi -Fayz

Run your browser from the terminal and post any errors here.

Same issue for me I hope someone could help. ( This is my first forum post )

When loading a video on Youtube or Vimeo it loads the first frame but video doesn’t play. If I hit different parts on the timeline frame changes but doesn’t play either. Videos running on VLC work well.

Inxi -Fayz Output:

  Kernel: 5.4.95-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=0159e70a-3cf6-4583-8a30-ce43a4ab9773 rw quiet apparmor=1 
  security=apparmor resume=UUID=5a7a5750-4139-46c7-aa22-766530c05d1c 
  Desktop: i3 4.19.1 info: i3bar dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Laptop System: Dell product: Vostro 7500 v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Dell model: 0K5HK9 v: A02 serial: <filter> UEFI: Dell v: 1.5.1 
  date: 12/04/2020 
  ID-1: BAT0 charge: 50.8 Wh condition: 94.1/97.0 Wh (97%) volts: 11.4/11.4 
  model: SMP DELL GPM0365 type: Li-ion serial: <filter> status: Discharging 
  Info: 6-Core model: Intel Core i7-10750H bits: 64 type: MT MCP 
  arch: Comet Lake family: 6 model-id: A5 (165) stepping: 2 microcode: E2 
  L2 cache: 12 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 62431 
  Speed: 900 MHz min/max: 800/5000 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 
  4: 900 5: 900 6: 901 7: 901 8: 900 9: 900 10: 900 11: 900 12: 900 
  Vulnerabilities: Type: itlb_multihit status: KVM: Vulnerable 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:9bc4 class ID: 0300 
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: Dell 
  driver: nvidia v: 460.39 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
  chip ID: 10de:1f95 class ID: 0300 
  Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo 
  bus ID: 1-5:2 chip ID: 0bda:5538 class ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.10 driver: loaded: modesetting,nvidia 
  unloaded: intel,nouveau alternate: fbdev,nv,vesa display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") 
  diag: 395mm (15.5") 
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 20.3.4 
  direct render: Yes 
  Device-1: Intel Comet Lake PCH cAVS vendor: Dell driver: snd_hda_intel 
  v: kernel alternate: snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:06c8 
  class ID: 0401 
  Sound Server: ALSA v: k5.4.95-1-MANJARO 
  Device-1: Intel Wireless-AC 9462/9560 driver: iwlwifi v: kernel port: 4000 
  bus ID: 00:14.3 chip ID: 8086:06f0 class ID: 0280 
  IF: wlp0s20f3 state: up mac: <filter> 
  Device-1: Intel type: USB driver: btusb v: 0.8 bus ID: 1-14:4 
  chip ID: 8087:0026 class ID: e001 
  Message: Required tool hciconfig not installed. Check --recommends 
  Local Storage: total: 953.87 GiB used: 124.35 GiB (13.0%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: PC611 NVMe 1TB 
  size: 953.87 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 rotation: SSD serial: <filter> rev: 11002111 scheme: GPT 
  ID-1: / raw size: 100 GiB size: 97.93 GiB (97.93%) used: 26.6 GiB (27.2%) 
  fs: ext4 dev: /dev/nvme0n1p8 maj-min: 259:8 
  ID-2: /boot/efi raw size: 512 MiB size: 511 MiB (99.80%) 
  used: 324 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p6 maj-min: 259:6 
  ID-3: /home raw size: 153.77 GiB size: 150.36 GiB (97.78%) 
  used: 3.21 GiB (2.1%) fs: ext4 dev: /dev/nvme0n1p9 maj-min: 259:9 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 16 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p7 maj-min: 259:7 
  System Temperatures: cpu: 51.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 0 fan-2: 0 
  Processes: 285 Uptime: 40m wakeups: 5535 Memory: 15.41 GiB 
  used: 2.62 GiB (17.0%) Init: systemd v: 247 Compilers: gcc: 10.2.0 
  clang: 11.0.1 Packages: 1319 pacman: 1307 lib: 313 flatpak: 6 snap: 6 
  Shell: Bash v: 5.1.0 running in: urxvtd inxi: 3.3.01

I ran Firefox -P and got no error messages. Same with Brave.

SOLVED for me:

I have Cadence controling my audio.
Jack status was started but PulseAudio was not bridged to JACK

Now, everytime I restart I need to verify both Jack and PulseAudio are started and videos are playing properly.

It seems the audio issue was not allowing the web video player to work properly.

@kalimerox Is this solution working on your end?

1 Like


something very similar happened to me tonight. After successful upgrade of many packages I’ve noticed that my Xorg configuration was gone, so I had to restore it. Also there had to be some strange issue with my USB Audio card (Audioquest Dragonfly Red), because it was able to play music via Deadbeef as usual, but browsers could not play any video.

Simple re-plugging of my audio card helped and all is working again as usual.

1 Like