Viber not starting

Hello,

I’m using Manjaro KDE and since one of the last updates from like month or two ago my Viber application installed from AUR is not starting. When I click on it, it shows its icon on panel like it is loading, and nothing happens. Since it is not that urgent issue for me I waited two more updates hopping it will be fixed somehow (the way it was broken). But still nothing.

I really need it on desktop since all my friends are on it, and it is generally still widely used in my country.

I tried reinstalling and purging it, but nothing helps.

Try running viber in the terminal and post all the output it gives you.

1 Like
qt.webenginecontext: 

GLImplementation: desktop
Surface Type: OpenGL
Surface Profile: CompatibilityProfile
Surface Version: 4.6
Using Default SG Backend: yes
Using Software Dynamic GL: no
Using Angle: no

Init Parameters:
  *  allow-loopback-in-peer-connection  
  *  application-name ViberPC 
  *  autoplay-policy no-user-gesture-required 
  *  browser-subprocess-path /opt/viber/libexec/QtWebEngineProcess 
  *  create-default-gl-context  
  *  disable-features DnsOverHttpsUpgrade,ConsolidatedMovementXY,InstalledApp,BackgroundFetch,WebOTP,WebPayments,WebUSB,PictureInPicture,AudioServiceOutOfProcess 
  *  disable-setuid-sandbox  
  *  disable-speech-api  
  *  enable-features NetworkServiceInProcess,TracingServiceInProcess,NetworkServiceInProcess 
  *  enable-threaded-compositing  
  *  enable-usermedia-screen-capture  
  *  in-process-gpu  
  *  use-gl desktop 

xkbcommon: ERROR: Couldn't process include statement for 'us(latin)'
xkbcommon: ERROR: Abandoning symbols file "(unnamed)"
xkbcommon: ERROR: Failed to compile xkb_symbols
xkbcommon: ERROR: Failed to compile keymap
[1713:1742:0913/221558.609305:FATAL:xkb_keyboard_layout_engine.cc(640)] Keymap file failed to load: us-latin
zsh: trace trap (core dumped)  viber

Try switching your X11 keyboard layout to just us. Maybe the latin version is not supported anymore.

1 Like

LoL, it works on my Serbian Cyrillic xDDDDDD

1 Like

How do I change input language for English US?

1 Like

Strange. It works when English is third in list of those 3 that I use, and then select it. But when I move it up to first position and start the Viber, selecting the English, it is not working…

I know this is a Manjaro forum but I couldn’t find the topic anywhere else. I can confirm that this is happening on Debian GNOME as well. I have English (US) as a first language, Serbian (Latin) as a second, Spanish (ES) as a third and Serbian (Cyrillic) as a forth and all of them work except for English (US), the first one.

I guess it is something related to Viber or its Qt backend?

Setting English as a second language seems to be a workaround as they all work in that case, but it is a bug nevertheless.

1 Like

Ok, so the problem seems to be in the xkbcommon library which handles keyboard layout descriptions in Xorg based desktops. According to another thread I found, the output of setxkbmap -query should give something like:

rules: evdev
model: pc105
layout: us,rs,es,us
variant: ,latin,
options: lv3:ralt_switch,grp:alt_shift_toggle,terminate:ctrl_alt_bksp

The problem appears to be in the variant line, which xkbcommon is unable to parse correctly. It is possible to set it manually with setxkbmap -variant '" ,latin,,' (NOTE the leading space in the variant option) but it will be overwritten by GNOME as soon as any keyboard layout modification is performed. Furthermore, I have found that some layout orders work while others don’t, I guess it is the mapping issue.

2 Likes

Works on Serbo-Croatian US.:smiley:

This is a Viber bug, and it is present in Wayland as well, so until they fix it, the solution will always be to change the keyboard layout. Irrespective of DE and server.