VGA second screen doesn't work when plugged in a USB hub


I bought myself a USB hub to be able to transform my laptop into a workstation by plugging in a keyboard, a mouse, speakers and a second screen, which does not connect via HDMI but via VGA. The station itself plugs into the computer via USB C. My computer doesn’t have a VGA port so I can’t try to plug it in directly.

The keyboard, mouse and speakers work perfectly, but the screen is not recognized. I tried to restart the computer with the screen plugged in, without success. Something happens when I plug it in (if it’s on standby, the screen lights up and displays “no video input” before going back to standby), so the station is apparently working, thus I imagined that it was a driver problem.

However, when I typed lspci -k | grep -EA3 'VGA' in the terminal, and it says:

00:02.0 VGA compatible controller: Intel Corporation CometLake-U GT2 [UHD Graphics] (rev 02)
	Subsystem: CLEVO/KAPOK Computer CometLake-U GT2 [UHD Graphics]
	Kernel driver in use: i915
	Kernel modules: i915

If I understand correctly, there is in fact a working driver for VGA. Is the problem in the VGA to USB C conversion? What to do in this case ?

Thanks a lot for your help !

check your manufacturer manual first if your computer does support video through usb-c. a lot of laptops do not support it.

Thank you! I didn’t think to read the laptop’s manual… and it said I had to configure the BIOS to allow video transfer by USB, and now it works perfectly.

For future reference : if you have Thunderbolt 3 with DisplayPort, for example on a Tuxedo Infinitybook pro 15 v5 like mine, you shoud set DDI control to DDI to TBT in yout Thunderbolt BIOS configuration.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.