Very slow on old laptop, eats all RAM, freezes and crashes

Hi, new Manjaro user here.

Last month I installed Manjaro XFCE on an old laptop (thinkpad x201 from 2011 with 4GB RAM, underclocked down to 1Ghz to avoid overheating). I spent a week to configure it to my liking and was happy with it, although it was a bit slow, but still acceptable. I then saved the config to my dotfiles repo and installed Manjaro XFCE with the same config on an old Desktop from 2009 (3 Ghz dual core CPU, 4GB RAM).
Last week or so the laptop crashed during an update and wouldn’t boot after that. I read the relevant forum threads and used a live USB to restore the system, and that seems to have worked.
But now, it’s unbearably slow. Opening the dropdown terminal or a Thunar window takes several seconds. Using firefox with more than one tab freezes and eventually crashes the system.
When I only use the terminal, there’s no lag.

My suspicion is that there’s something wrong with RAM usage. Running “free -m” after a fresh boot shows:

total: 3722
used: 2969
free: 125
shared: 121
buff/cache: 627
available: 412

So, 3GB is used instantly after startup. I didn’t install any resource hungry desktop apps, I only added rofi and xfdashboard. Taskmanager tells me, that the following applications each use more than 200 MB: nm-applet, 4 different xfce panels (which were preinstalled), xfce4-clipman, xfce4-panelxfce-terminal, xfdesktap, xfwm4, pamac-tray, blueman-applet

On the desktop with the same configuration (which continues to work fine), only 1 of 4 GB is occupied after a fresh boot, and taskmanager shows that the same applications use 30-50% as much RAM.

Is the installation on my laptop broken? Or is the RAM usage not a problem? (linuxatemyram indicates it might not be.) Or is this old laptop just not fit to run Manjaro XFCE any more? (I used i3/arch on it before, and it worked ok.)

no swap?

1 Like

Running ‘swapon’ gives empty output. I think I opted to not use swap during install with the live USB.

(On the desktop, I installed with 8 GB swap, and ‘swapon’ reflects that, but on a fresh boot, the swap is not needed and not used according to ‘free -m’)

Check by what. Also what is (if anything) using cpu?

That was a mistake.

Generally you need swap - how much depends on usecase - but you cannot be without - especially on older systems.

1 Like

aha, swapon using a swapfile is the way to go - no need for partitioning and the swapfile is dynamic (i.e. if you don’t use it then it won’t take up space).

Also it might be worth knocking up a conky script to shop top 5 cpu and top 5 Ram gobblers. Mine shows HDD temps, HD useage (needs editing) but the CPU and Memory sections would work.

Proc conky top 5's

conky.config = {
– Conky settings
background = true,
update_interval = 1,
double_buffer = true,
no_buffers = true,
imlib_cache_size = 10,
format_human_readable = yes,
temperature_unit = celsius,

– Window specifications #
alignment = ‘top_right’,
gap_x = 5,
gap_y = 250,
minimum_width = 0, minimum_height = 0,
maximum_width = 150,
own_window = true,
own_window_type = ‘dock’,
own_window_transparent = false,
own_window_argb_visual = true,
own_window_argb_value = 180,
own_window_hints = ‘below,undecorated,sticky,skip_taskbar,skip_pager’,
uppercase = false,
use_spacer = ‘none’,
use_xft = true,

– Graphics settings #
draw_shades = false,
default_shade_color = ‘#484848’,
draw_outline = false,
default_outline_color = ‘#AAAAAA’,
draw_borders = false,
draw_graph_borders = true,
default_graph_width = 40, default_graph_height = 80,
show_graph_scale = false,
show_graph_range = false,

– Text settings #
use_xft = true,
xftalpha = 0,
font = ‘noto sans :size=8’,
text_buffer_size = 256,
override_utf8_locale = true,

– Useful shortenings #
short_units = true,
pad_percents = 2,
top_name_width = 30,
color = ‘scheme’,

– Color scheme #
default_color = ‘#999999’,
color1 = ‘#FFFFFF’,
color2 = ‘#25C29C’, --manjaro teal
color3 = ‘#84c2b3’, – pale teal
color4 = ‘#5f8c81’, – darker teal
color5 = ‘#DCDCDC’, – pale grey
color6 = ‘#888888’, – darker grey
color7 = ‘#e0d9bf’, – buff
color8 = ‘#659771’, – librarygreen
color9 = ‘#A9CFF4’, --skyblue
total_run_times = 4000,

– iphone wlp0s20u12
total_run_times = 2700,

conky.text = [[${if_running audacious}${font mitr:size=8}${alignc }${exec audtool current-song-tuple-data title}
${font mitr:size=8}${alignc }by ${exec audtool current-song-tuple-data artist}

$hr ${endif}


${diskiograph /dev/sda 12,25 -t -l}-${diskiograph /dev/sdb 12,25 -t -l}-${diskiograph /dev/sdc 12,25 -t -l}-${diskiograph /dev/sdd 12,25 -t -l}-${diskiograph /dev/sde 12,30 -t -l}
${goto 30} ${hddtemp /dev/sdb}ºC ${goto 62}${hddtemp /dev/sdc}ºC ${goto 93}${hddtemp /dev/sdd}ºC ${goto 125}${hddtemp /dev/sde}ºC
${color}Evo ${goto 25} ${color gray40} ${goto 40} ${fs_free /}${if_match ${fs_used_perc}>=75}${color lightsalmon}${endif}${if_match ${fs_used_perc}>=85}${color red}${endif}${goto 90 }${fs_bar 6,55 /}${font }
${if_existing /dev/sdd}${color }T3 ${goto 25} ${goto 40} ${fs_free /mnt/T3} ${color grey40} ${goto 105}${if_match ${fs_used_perc /mnt/T3}>=85}${color salmon}${endif}${if_match ${fs_used_perc}>=95}${color red}${endif} ${goto 90}${fs_bar 6,55 /mnt/T3}${font }${color }
${if_existing /dev/sdc}${color }T4 ${goto 25} ${goto 40} ${fs_free /mnt/T4} ${color grey40} ${goto 105}${if_match ${fs_used_perc /mnt/T4}>=85}${color salmon}${endif}${if_match ${fs_used_perc}>=95}${color red}${endif} ${goto 90 }${fs_bar 6,55 /mnt/T4}${font }${color }
${if_existing /dev/sdd}${color }W2${goto 25} ${goto 40} ${fs_free /mnt/W2} ${color grey40} ${goto 105}${endif}${if_match ${fs_used_perc /mnt/W2}>=85}${color red}${endif} ${goto 90}${fs_bar 6,55 /mnt/W2}${endif}${font }${color }
${color}Win10 ${goto 25} ${color gray40} ${goto 40} ${fs_free /mnt/Win10/}${if_match ${fs_used_perc}>=75}${color lightsalmon}${endif}${if_match ${fs_used_perc}>=85}${color red}${endif}${goto 90 }${fs_bar 6,55 /run/media/ben/Win10}${font }${color }
${if_existing /dev/sdc2}${color }NTFS ${goto 25} ${goto 40} ${fs_free /mnt/NTFS} ${color grey40} ${goto 105}${if_match ${fs_used_perc /mnt/NTFS}>=85}${color salmon}${endif}${if_match ${fs_used_perc}>=95}${color red}${endif} ${goto 90 }${fs_bar 6,55 /mnt/NTFS}${font }${color }
${font :bold:size=8}${color #ff732d}CPU $color ${freq_g} Ghz ${goto 90}${color #ff732d} CPU Hogs
${color #f79f34}${top name 1} ${goto 90}${top cpu 1}
${color #F7A945}${top name 2} ${goto 90}${top cpu 2}
${color #bc8c50}${top name 3} ${goto 90}${top cpu 3}
${color #765}${top name 4} ${goto 90}${top cpu 4}
${color8}${font :bold:size=8}Memory ${goto 90} RAM Users
${color #a6c897}${top_mem name 1} ${goto 90} ${top_mem mem_res 1}
${color #95b488}${top_mem name 2} ${goto 90} ${top_mem mem_res 2}
${color #85a079}${top_mem name 3} ${goto 90} ${top_mem mem_res 3}
${color #748c6a}${top_mem name 4} ${goto 90} ${top_mem mem_res 4}
$color$hr${font :size=9}${color }${font arial rounded MT :bold:size=9}
${nodename_short} Updates: ${alignc}${execi 3600 checkupdates | wc -l}
Snapshot: $alignr ${execi 250 ls -r -l /mnt/T3/timeshift/snapshots | sed -n ‘2p’| cut -c 29-40}
$alignc ${utime %H%M} GMT${font }${font comfortaa :bold:size=9}
$alignc ${desktop_name}

That’s what “free -m” and the “xfce4-taskmanager” tell me.
According to the task manager, CPU usage is between 1% and 10% after startup. If I start a single firefox instance, it briefly goes up to 100%, and then down again (although RAM is then at 100% full).

ok, thank you. I will try with swap then.

That doesn’t help. I’m asking which process(es) are taking all the memory. (You can sort them in htop to get rough estimate)

Yepp that is true. Such systems are only usable with DWM, i3 (and sort of) for me. Firefox, Chrome and any modern browser just takes a lot of RAM. Nothing to do with Manjaro in general.

Also a Swap is highly needed…


Here is a screenshot from taskmanager, with processes sorted by RAM (descending). This is what it looks like after a fresh boot. I find it surprising that processes such as nm-applet, taskmanager or pamac-tray use more than 200MB RAM. What are they even doing with all that space?

You can now investigate further. I’d start top to bottom. Blueman and nm applets 300MB? Sounds a bit excessive to me. Maybe someone with xfce can compare with his own stats.

Not at all. Just note that such systems were made for 32bit systems with the capability to run 64bit in the future also. 64bit processes take almost double memory.

Computer ageism!

Xfce is perfectly able to run smoothly on 2012 hardware, even though I think an upgrade to ssd is what makes it usable as a daily driver.

The 2009 2.66GB Ram Athlon II I’m writing this on is driving an external tv hdmi display while its wifi provides an access point for its ethernet connection in a small studio. The unit is mainly used for browsing, watching tutorial streams or listening to music/net radio. It’s on for 18h a day, 7 days a week, last system install was 2018. No crashes, no stuttering, sleeps and wakes as it should. When rebooting after upgrades it uses about 500-600MB, the browser adds about 1GB with 3-5 tabs open. If temps start rising to 90C (every 2-3month) I apply a vacuum cleaner to the fan outlet and I’m back to 65-70C.

Kernel: 5.15.48-1-MANJARO arch: x86_64 bits: 64 Desktop: Xfce v: 4.16.0
    Distro: Manjaro Linux
  Type: Laptop System: Packard Bell product: EasyNote TJ71 v: 0100
    BIOS: Phoenix v: 1.05 date: 12/07/2009
  Info: dual core model: AMD Athlon II M300 bits: 64 
  Device-1: AMD RS880M [Mobility Radeon HD 4225/4250] driver: radeon
    v: kernel
  Device-1: AMD SBx00 Azalia driver: snd_hda_intel
  Device-2: AMD RS880 HDMI Audio [Radeon HD 4200 Series]
    driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.15.48-1-MANJARO running: yes
  Sound Server-2: PipeWire v: 0.3.52 running: yes
  Device-1: Broadcom NetLink BCM5784M Gigabit Ethernet PCIe driver: tg3
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-2: Qualcomm Atheros AR928X Wireless Network Adapter driver: ath9k
  IF: wlan0 state: up mac: <filter>
  Local Storage: total: 134.17 GiB used: 37.64 GiB (28.1%)
  ID-1: /dev/sda vendor: IBM model: ESA3SMD2MSPB128GB size: 119.24 GiB
  ID-1: swap-1 type: partition size: 3.42 GiB used: 332.7 MiB (9.5%)
  System Temperatures: cpu: 64.1 C mobo: N/A
  Memory: 2.66 GiB used: 1.69 GiB (63.3%)
  • Check the health of your drive and maybe consider swapping it for an ssd. Not only will it feel more like a contemporary device, it will also bring temps down (they use about 10W less than spinners) and so avoid throttling the cpu.
  • Check startup processes and running processes, nmapplet and pamac tray should use around 13MB each. Is pamac looking for updates at each startup? Reschedule. What is your network-manager doing with 400MB? Clean out saved connections? Are there any search indexers or syncing processes running, possibly indexing network drives or samba folders?
  • Check and disable eye candy in Appearance and Window Manager Tweaks Advanced (transparencies off!). Your xfce panel uses 208MB, mine 27MB… Be careful what you add to panel, electron apps are practically a chromium browser. And there is life without whisker menu…

And as was mentioned in this thread; a lean conky (refresh rate 5 secs) showing temps, cpu and ram usage is a great way of keeping an eye on health and distribution of the scarce resources.