Very low FPS playing SCUM in Linux

Hey, there!
I’ve tried SCUM in Linux using Proton, but the performance is so poor; 10 FPS avg.
I just have a GTX 1050, but in Windows 10 I can play it on 60 FPS avg. low settings, of course due to my GPU. Do you know a way to tweak the settings or adding something else so I can have a better gaming experience in Manjaro?
Thanks in advance!

It should work in theory.

Provide your system info from command inxi -Fazy

1 Like
inxi -Fazy                                                                                                                                             ✔ 
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_ADDRESS = "en_US.UTF-8",
        LC_IDENTIFICATION = "en_US.UTF-8",
        LC_MEASUREMENT = "en_US.UTF-8",
        LC_MONETARY = "en_US.UTF-8",
        LC_NAME = "en_US.UTF-8",
        LC_NUMERIC = "en_US.UTF-8",
        LC_PAPER = "en_US.UTF-8",
        LC_TELEPHONE = "en_US.UTF-8",
        LC_TIME = "Default.UTF-8",
        LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
  Kernel: 5.15.65-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=281171bb-d0eb-4d96-a167-96e946c1a134 rw quiet
    resume=UUID=5c11cfed-8b9e-45dd-ad65-88c991da016b udev.log_priority=3
  Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASRock model: B450M Pro4-F serial: <superuser required>
    UEFI-[Legacy]: American Megatrends v: P2.20 date: 07/27/2020
  Info: model: AMD Ryzen 3 1300X bits: 64 type: MCP arch: Zen level: v3
    built: 2017-19 process: GF 14nm family: 0x17 (23) model-id: 1 stepping: 1
    microcode: 0x8001138
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 384 KiB
    desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 8 MiB
    desc: 2x4 MiB
  Speed (MHz): avg: 2416 high: 3591 min/max: 1550/3500 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2981 2: 1547
    3: 3591 4: 1545 bogomips: 27959
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT disabled
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GP107 [GeForce GTX 1050] vendor: Gigabyte driver: nvidia
    v: 515.65.01 alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current
    (as of 2022-08) arch: Pascal code: GP10x process: TSMC 16nm built: 2016-21
    pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s
    bus-ID: 07:00.0 chip-ID: 10de:1c81 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: nvidia gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1360x768 s-dpi: 21 s-size: 1645x929mm (64.76x36.57")
    s-diag: 1889mm (74.38")
  Monitor-1: HDMI-0 res: 1360x768 hz: 60 dpi: 22
    size: 1600x900mm (62.99x35.43") diag: 1836mm (72.27") modes: N/A
  OpenGL: renderer: NVIDIA GeForce GTX 1050/PCIe/SSE2 v: 4.6.0 NVIDIA
    515.65.01 direct render: Yes
  Device-1: NVIDIA GP107GL High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 07:00.1 chip-ID: 10de:0fb9 class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 09:00.3
    chip-ID: 1022:1457 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.65-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.57 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASRock driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: f000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 1.61 TiB used: 48.03 GiB (2.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: WDS500G2B0C-00PXH0 size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 233010WD temp: 38.9 C scheme: MBR
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD10EZEX-08WN4A0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
    rev: 1A02 scheme: MBR
  ID-3: /dev/sdb maj-min: 8:16 vendor: A-Data model: SU800NS38
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 7ANR scheme: MBR
  ID-4: /dev/sdg maj-min: 8:96 type: USB vendor: Kingston
    model: DataTraveler 3.0 size: 14.66 GiB block-size: physical: 512 B
    logical: 512 B type: N/A serial: <filter> rev: PMAP scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-1: / raw-size: 80 GiB size: 78.19 GiB (97.74%) used: 19.36 GiB (24.8%)
    fs: ext4 dev: /dev/sdb1 maj-min: 8:17
  ID-2: /home raw-size: 154.47 GiB size: 150.98 GiB (97.74%) used: 28.67 GiB
    (19.0%) fs: ext4 dev: /dev/sdb3 maj-min: 8:19
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 4 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sdb2 maj-min: 8:18
  System Temperatures: cpu: 45.2 C mobo: N/A gpu: nvidia temp: 50 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
  Processes: 238 Uptime: 6h 37m wakeups: 9 Memory: 15.55 GiB used: 3.33 GiB
  (21.4%) Init: systemd v: 251 default: graphical tool: systemctl Compilers:
  gcc: 12.2.0 clang: 14.0.6 Packages: 1326 pm: pacman pkgs: 1311 libs: 341
  tools: pamac pm: flatpak pkgs: 15 Shell: Zsh v: 5.9 default: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.21

EDIT: I’ve been testing SCUM with Proton 5.13-6 and PROTON_NO_ESYNC=1, but the game experience was HORRIBLE… 5 FPS avg. :stuck_out_tongue_closed_eyes:

Did you try with latest Proton 7?

I would assume with Nvidia drivers installed, such a low resolution (1360x768), and setting the game to low settings, would allow you to have more than 5FPS. From comments on ProtonDB the game doesn’t perform well but it should work better than what you say.

I changed to Proton 7, but the performance is bad too… 7 FPS.

You seem to have the drivers installed properly, so I don’t know what would cause it to run at 10% the performance you get on Windows. I would expect a loss but not that huge.

Try the basics, delete the prefix folder ~/.local/share/Steam/steamapps/compatdata/513710 (careful it may contain savegames, and the cloud save feature in Steam is not always working good with Proton, so you may want to just rename it to something else for now).

Make sure you run the game with latest Proton version in Steam Settings or in the game Properties if you have modified it there, verify the game files from Steam Library, then try again it will recreate a clean Proton prefix folder and probably with default game settings, start from here reconfigure game video settings to your resolution 1360x768, set to lowest graphics, apply restart the game and see if it is better.

//EDIT: maybe there is nothing to do and it is expected as you are under minimum requirement, and running it through Proton. But that is surprising because of how big the gap in performance is.

This is what I have in my home folder, and Steam is not there. :thinking:

Show hidden files with CTRL + H or from the menu in Dolphin file explorer View → Show Hidden Files.

To get there I had to activate hidden files, so it is enabled already; Steam must be in some other place, though. :face_with_raised_eyebrow:

How did you install Steam? I suspect you do not have Steam from Manjaro repo, but Steam from Flatpak or other external source.

Yeah, I have it from Flatpak. Should I change that?

I’m not familiar with this Flatpak version, it should use other folders for installed games, Proton prefixes, and so on.

You can still install and use the normal Steam version from Manjaro, you can maybe reconfigure Steam to point to your library where the game is already installed. Maybe Flatpak version doesn’t work as good for some reason, I don’t know.

//EDIT: more info to remove Flatpak - ArchWiki and Flatpak - Manjaro it seems like Flatpaks are somewhere in ~/.var/

1 Like

OK. I’ll install Steam from the Official Repos; it’s not a problem uninstall the other one because I just have SCUM there for testing purposes.

EDIT: The flatpak route for Steam is ~/.var/app/

OK. I did all you mentioned, and the performance now is better, but still low… 20 FPS avg. I think from now I can keep testing by changing Proton versions and game launch options.

I think this is probably what you should expect if we read comments on Proton DB, people with 1050 TI report having 20 FPS on low settings (I assume with 1080p resolution)

Yeah, probably. I’m using 1360x768, though.

I think it now works as expected, and indeed, with a lower resolution you should gain some performance. At least I don’t see what to tell you to improve your experience.

I’m checking this:

EDIT: After installing and testing other versions of Proton, I stayed on version 7 since it had the best results on performance… then, because now it’s giving me the same low performance as the rest of Proton’s versions. Why? I don’t have a clue, but I suspect that has nothing to do with Proton.

Should I tweak something here?

I remember not long ago using the video-nvidia-470xx for gaming, and maybe installing it could help.

You can try, right click the latest driver video-nvidia and select Remove, then right click video-nvidia-470xx and select Install. Reboot, and see if it works better.

Also something that can improve some games, is to enable the Steam Shader Pre-Caching in the Settings.

Maybe also using Game Mode as instructed in the Proton DB Performance FAQ could help a little.

1 Like