Veracrypt - Invalid characters encountered

I encountered this error when i tried to mount an encrypted device in terminal.

The gui version of Veracrypt gave an error message with the same text when i tried to launch the program, but now it wont even do anything when i try to run it.

i have been using veracrypt on both windows and ubuntu for years, never had any problems with it on those. But i’m new to manjaro so its totally possible that i messed something up at installation.

Can anyone help, please?

How did you install it? veracrypt is available in the community repo.

That was my first try,
than i tried both gui and terminal version from the veracrypt site, they all gave the same error.

Maybe you run into errors because you have gui and terminal version installed at the same time?

Im using the GUI Version with no errors, with Manjaro/KDE since 5 month. Maybe a Gnome problem?

Get sure, its still working under windows and remove the CLI and GUI Version… restart linux and install the GUI Version from repo.

Edit: How did you install it? Maybe try the easy way with the Package Manager GUI.

They weren’t.

Could be, i have no idea.


Done and done. Same error.

I did try that too.

But thanks for trying!

I really not this experienced with Linux,
i hope there is someone other that can help you with your issue…

Maybe you can also get help in Veracrypt Forum or from support.

Which feature from Veracrypt are you using? Full Encrypted Partition or a container file?
Maybe give us more details and pics when and where exactly this error appears.

Did you change settings from Veracrypt, in this case you possible need to manually delete config files
home, after uninstall.

As the last step when nothing helps, you still could try out Manjaro KDE.

And i did try to upload screenshots of the error, but the forum didn’t let me, saying: “Sorry, you can’t embed media items in a post.” I’m guessing it’s because i’m a newbie here.

Since the gui version gave the error without starting at all, i dont think it has anything to do with what i want to to use it for.

No, i can’t even launch it at all.

I will. Thank you for the advice!

1 Like

Did you try to delete the VeraCrypt folder in .config after uninstall?

/home/YOUR USERNAME/.config/VeraCrypt/

I just gave you a like and emotion icon, that should boost your status and you will have access to upload images soon.

1 Like

no need

why upload images to here?
when there are plenty of image hosters out there?
Why waste storage here?

links can be posted like this always:

(use the formatting buttons)

lose the http part
use some spaces in it - which makes it legible, understandable, but not clickable

It’s the same for pictures.
Upload them to some image hoster - and post the link to the picture there here - in the same manner.
You should always use image hosters - not upload pictures here.

Why use images at all?
Text is always preferred in favor of images - text can be parsed, images cannot …

It’s a bit of work.
very little, though
Spammers will not bother - but people who want help … will

No, but i tried it now, sadly did not work.

Thank you, but it seems that wasn’t enough.

Ok, here they are:

Repository version when i try to launch it:

Terminal version, from Veracrypt’s site: