VeraCrypt - create new container - broken pipe - Write:384

I have fresh Manjaro xfce 22.0.5 install (from just 2h ago), installed VeraCrypt from the GUI Software store, and created a new file container. Not hidden, ext4, Linux only use.
After formatting I got an error (can’t really remember) … end of data … not enough data … or something like that.
Tried formatting again, then got a pop-up with an error message
Broken Pipe - VeraCrypt::File::Write:384

On my other system (Manjaron - cinnamon - installed about a year ago with 5.15 kernel , just upgraded to 6.1), I am pretty installed it from the GUI Software Installer and never had any problems …

1 Like
$ sudo inxi --admin --verbosity=7 --filter --no-host --width

  Kernel: 6.1.21-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=26d28c5f-d963-425f-9806-a810b3668471 rw quiet splash
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 dm: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
  Type: Unknown Mobo: ZOTAC model: ZBOX-CI323NANO v: XX serial: <filter>
    UEFI-[Legacy]: American Megatrends v: B301P024 date: 05/07/2018
  Message: No system battery data found. Is one present?
  RAM: total: 15.54 GiB used: 2.03 GiB (13.1%)
  Array-1: capacity: 16 GiB note: est. slots: 2 EC: None
    max-module-size: 8 GiB note: est.
  Device-1: A1_DIMM0 type: DDR3 detail: N/A size: 8 GiB speed: 1600 MT/s
    volts: curr: 1.35 min: 1.35 max: 1.5 width (bits): data: 64 total: 64
    manufacturer: Kingston part-no: KHX1600C9S3L/8G serial: <filter>
  Device-2: A1_DIMM1 type: DDR3 detail: N/A size: 8 GiB speed: 1600 MT/s
    volts: curr: 1.35 min: 1.35 max: 1.5 width (bits): data: 64 total: 64
    manufacturer: Kingston part-no: KHX1600C9S3L/8G serial: <filter>
  Info: model: Intel Celeron N3150 socket: BGA1155 bits: 64 type: MCP
    arch: Airmont level: v2 built: 2015-17 process: Intel 14nm family: 6
    model-id: 0x4C (76) stepping: 3 microcode: 0x368
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 224 KiB
    desc: d-4x24 KiB; i-4x32 KiB L2: 2 MiB desc: 2x1024 KiB
  Speed (MHz): avg: 660 high: 1200 min/max: 480/2080 base/boost: 1600/2400
    scaling: driver: intel_cpufreq governor: schedutil volts: 1.2 V
    ext-clock: 80 MHz cores: 1: 480 2: 1200 3: 480 4: 480 bogomips: 12805
  Flags: 3dnowprefetch acpi aes aperfmperf apic arat arch_perfmon bts
    clflush cmov constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts epb
    ept erms est flexpriority fpu fxsr ht ibpb ibrs ida lahf_lm lm mca mce
    md_clear mmx monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe
    pclmulqdq pdcm pebs pge pni popcnt pse pse36 pti rdrand rdtscp rep_good
    sep smep ss sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow
    tsc tsc_adjust tsc_deadline_timer tsc_known_freq tsc_reliable vme vmx vnmi
    vpid xtopology xtpr
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass status: Not affected
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx
    Integrated Graphics vendor: ZOTAC driver: i915 v: kernel arch: Gen-8
    process: Intel 14nm built: 2014-15 ports: active: HDMI-A-3 empty: DP-1,
    DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:22b1 class-ID: 0300
  Device-2: Logitech BRIO Ultra HD Webcam type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-4:2 chip-ID: 046d:085e
    class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 compositor: xfwm v: 4.18.0 driver: X:
    loaded: modesetting alternate: fbdev,vesa dri: crocus gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: HDMI-A-3 mapped: HDMI-3 model: Dell P2217H serial: <filter>
    built: 2017 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
    size: 476x267mm (18.74x10.51") diag: 546mm (21.5") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series
    High Definition Audio vendor: ZOTAC driver: snd_hda_intel v: kernel
    bus-ID: 1-4:2 bus-ID: 00:1b.0 chip-ID: 046d:085e chip-ID: 8086:2284
    class-ID: 0102 serial: <filter> class-ID: 0403
  Device-2: Logitech BRIO Ultra HD Webcam type: USB
    driver: snd-usb-audio,uvcvideo
  API: ALSA v: k6.1.21-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.67 status: off tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active (root, process)
    tools: pacat,pactl,pavucontrol
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000
    bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: ens1 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000
    bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  Device-3: Intel Wireless 3160 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 8086:08b3 class-ID: 0280
  IF: wlp4s0 state: down mac: <filter>
  IF-ID-1: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-5.2:5 chip-ID: 8087:07dc class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 465.76 GiB used: 7.68 GiB (1.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 840 Series
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 9B0Q scheme: MBR
  Message: No optical or floppy data found.
  ID-1: / raw-size: 218.86 GiB size: 214.37 GiB (97.95%) used: 7.68 GiB (3.6%)
    fs: ext4 block-size: 4096 B dev: /dev/sda4 maj-min: 8:4 label: N/A
    uuid: 26d28c5f-d963-425f-9806-a810b3668471
  Alert: No swap data was found.
  ID-1: /dev/sda1 maj-min: 8:1 size: 15.24 GiB fs: ext4 label: N/A
    uuid: ec6f3699-be20-49de-a117-4c53a2e44ea9
  ID-2: /dev/sda2 maj-min: 8:2 size: 218.86 GiB fs: ext4 label: N/A
    uuid: e2c29aa9-d0a7-4356-9abf-a307c2cfc628
  ID-3: /dev/sda3 maj-min: 8:3 size: 12.8 GiB fs: ext4 label: N/A
    uuid: 116c8097-bbb0-4bd9-abd2-cddb13d91968
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 7 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-4:2 info: Logitech BRIO Ultra HD Webcam type: Video,Audio
    driver: snd-usb-audio,uvcvideo interfaces: 5 rev: 2.1 speed: 480 Mb/s
    power: 500mA chip-ID: 046d:085e class-ID: 0102 serial: <filter>
  Hub-2: 1-5:3 info: Terminus Hub ports: 4 rev: 2.0 speed: 480 Mb/s
    power: 100mA chip-ID: 1a40:0101 class-ID: 0900
  Device-1: 1-5.1:4 info: Realtek 3-in-1 (SD/SDHC/SDXC) Card Reader
    type: Mass Storage driver: ums-realtek interfaces: 1 rev: 2.0 speed: 480 Mb/s
    power: 500mA chip-ID: 0bda:0153 class-ID: 0806 serial: <filter>
  Device-2: 1-5.2:5 info: Intel Bluetooth wireless interface type: Bluetooth
    driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 8087:07dc class-ID: e001
  Device-3: 1-5.3:6 info: SINO WEALTH USB KEYBOARD type: Keyboard,HID
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s
    power: 100mA chip-ID: 258a:0001 class-ID: 0300
  Device-4: 1-5.4:7 info: Dell Universal Receiver type: Keyboard,Mouse,HID
    driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 413c:2514 class-ID: 0300
  Hub-3: 2-0:1 info: Super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 56.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 204 Uptime: 39m wakeups: 0 Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 942 libs: 295 tools: pamac Shell: Bash (sudo) v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.26

try this:

1 Like

Straight after newest stable update from today, my Veracrypt shows error messages when i mount a drive, Not Enough Data and after repeated password, Broken Pipe error message.

I restarted Veracrypt and lucky its working for now… but there is something wrong with Veracrypt in the official repos!

systemd-coredump[17265]: [🡕] Process 17230 (veracrypt) of user 1000 dumped core.
                                                      Stack trace of thread 17230:
                                                      #0  0x00007f6ede4ac83c n/a ( + 0x8e83c)
                                                      #1  0x00007f6ede45c668 raise ( + 0x3e668)
                                                      #2  0x00007f6ede4444b8 abort ( + 0x264b8)
                                                      #3  0x00007f6ede6dd3b2 _ZSt21__glibcxx_assert_failPKciS0_S0_ ( + 0xdd3b2)
                                                      #4  0x00005609b2c64762 n/a (veracrypt + 0x1c7762)
                                                      #5  0x00005609b2b85a94 n/a (veracrypt + 0xe8a94)
                                                      #6  0x00007f6ede445cd0 n/a ( + 0x27cd0)
                                                      #7  0x00007f6ede445d8a __libc_start_main ( + 0x27d8a)
                                                      #8  0x00005609b2b8c775 n/a (veracrypt + 0xef775)
                                                      ELF object binary architecture: AMD x86-64
░░ Subject: Process 17230 (veracrypt) dumped core
░░ Defined-By: systemd
░░ Support:
░░ Documentation: man:core(5)
░░ Process 17230 (veracrypt) crashed and dumped core.
░░ This usually indicates a programming error in the crashing program and
░░ should be reported to its vendor as a bug.

@Kobold I had something similar, the disk unmounted itself all the time after a few seconds.
Solved it by going to >Settings>Mount Options>Uncheck Truecrypt mode and Mount volumes as read-only.
Somehow these settings got changed for me.
Please try.

Hmmm, i don’t have this issue at all. Why do you think its similar to mine, do you see this same errors?

I never use Truecrypt and i never had Truecrypt mode activated.
My mount volume is also not read only, i still have full access…

But I’am little bid worried, that my mount point becomes corrupted after time.

It might not be the same issue as mine. My settings file got corrupted last time and even I used correct settings, every time I started the program the settings were back. So what I had to do was to go to settings and save the config file after adjusting the settings back.

1 Like

I could unmount and mount it yesterday without an error and today there was also no error after Password.

It looks to me, there was just a temporary issue… maybe a corrupted settings file after the new stable update. :man_shrugging: