Vdhcoapp Stopped Working

I use Manjaro cinnamon edition fully up to date. I use Firefox (118.0.1) as my browser, and also “Video Download Helper” ( For VDH to work it also needs a companion app (VDHcoapp).
Earlier this year, following advice on this forum, I installed the AUR version ‘VDHcoapp-bin 1.6.3-1’ everything was working fine.
Recently when I was trying to use VDH, the companion app was reported missing by VDH? however when I checked pamac, an updated version was installed? I checked the history and the 1.6.3-1 was updated on the 29/Sep/23 to 2.0.1-1 and that was updated again on 01/Oct/23 to 2.0.1-3 As I use the app infrequently, I’m not sure when it actually stopped working. Is there an issue with the app? and is a fix coming? or do I have to download and install the app directly from VDH?
The only thing I tried so far is: Uninstall the app, and after a re-start, re-install the app = no change.

Alternative install method below. I have tested and it is working in FF Nightly:

Download the .bz2 file from here: Releases · aclap-dev/vdhcoapp · GitHub
Then do a system wide install. In terminal:

# sudo tar xf vdhcoapp-2.0.2-linux-x86_64.tar.bz2 -C /usr/local
# sudo /usr/local/vdhcoapp-2.0.2/vdhcoapp install --system
Writing /usr/lib/mozilla/native-messaging-hosts//net.downloadhelper.coapp.json
Writing /etc/opt/chrome/native-messaging-hosts//net.downloadhelper.coapp.json
Writing /etc/chromium/native-messaging-hosts//net.downloadhelper.coapp.json
VdhCoApp : VdhCoApp is ready to be used


Linux other: 
download the .tar.bz2 file, unpack and move to a desired location, and run 
./vdhcoapp install.

You can still install/update VdhCoApp via the AUR, but you need to run the following command manually afterwards:

sudo /opt/vdhcoapp/vdhcoapp install

sudo /opt/vdhcoapp/vdhcoapp install
[sudo] password for scotty:
Writing /usr/lib/mozilla/native-messaging-hosts//net.downloadhelper.coapp.json
Writing /etc/opt/chrome/native-messaging-hosts//net.downloadhelper.coapp.json
Writing /etc/chromium/native-messaging-hosts//net.downloadhelper.coapp.json
Writing /etc/opt/edge/native-messaging-hosts//net.downloadhelper.coapp.json
VdhCoApp : VdhCoApp is ready to be used

1 Like

I tried your suggestion, but still not working. Just to be sure I first delete the vdhcoapp-bin trough pamac first, cleaned the system with ‘Bleachbit’ re-started for good measure. Then installed the AUR version of vdhcoapp-bin and then run your command. I did not get the Writing lines

jp@jpmanjarohome ~]$ sudo /opt/vdhcoapp/vdhcoapp install
[sudo] password for jp:
VdhCoApp : VdhCoApp is ready to be used
[jp@jpmanjarohome ~]$

I then checked what files got installed

I downloaded the file but I haven’t tried ‘Jrichard326’ fix yet. in which location should I place the downloaded file? /usr/local?

Make sure you have downloaded the correct file from the vdhcoapp releases page for your type of CPU: currently vdhcoapp-2.0.2-linux-x86_64.tar.bz2 for Intel; vdhcoapp-2.0.2-linux-aarch64.tar.bz2 for ARM.

To install vdhcoapp as a user (not system-wide) place the extracted file (which should be named “vdhcoapp” into any folder in your home directory & from within that folder run ./vdhcoapp install (don’t use sudo to install it as a user).

To install vdhcoapp system-wide, save the extracted file to /opt/vdhcoapp/. Then run sudo /opt/vdhcoapp/vdhcoapp install.

More info/help available from aclap-dev/vdhcoapp: Companion application for Video DownloadHelper browser add-on (make sure you scroll down - as well as providing installation instructions, the page also has a troubleshooting section).

I downloaded the correct file and extracted it into the /opt/vdhcoapp I then run the command but still not working? It appears to be installed but the extension still list it as not installed? I made a search for net.downloadhelper, but I don’t seem to have the .json files?


I followed the troubleshooting section and installation instructions, but nothing works!?

I really don’t know. I’ve never had an issue with installing Video Download Helper manually as a user & system-wide during the decade or more that I have used it.

My guess is Bleachbit has removed more than it should have. I’ve never been brave enough to run it on my PC - I’ve read too many tales of woe over the years from Linux users who thought it was a good idea to “clean” their system & ended up having to do a complete reinstall as a result.

But it could be something else not related to Bleachbit causing the issue - hopefully one of the many other fine minds inhabiting this forum might be able to suggest a solution.

No luck with this method either, I must be missing something? I assumed that the # sign before ‘sudo’ is to comment out that line, so when I enter the command as shown nothing happens, when I enter the command without the # sign and after I enter the password I get the following message

[jp@jpmanjarohome ~]$ sudo tar xf vdhcoapp-2.0.2-linux-x86_64.tar.bz2 -C /usr/local
[sudo] password for jp: 
tar: vdhcoapp-2.0.2-linux-x86_64.tar.bz2: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
[jp@jpmanjarohome ~]$ 

the .bz2 file is in home/download
I moved the file to /usr/local and tried again, but got the same error - not sure what else I can try

Don’t comment out anything. In this case the “#” sign does not signify commenting out in this case.
1-Download the file from the source

2- change to the location where you downloaded the file (in terminal) e.g. /home/your_user_name/Downloads/
3- run in terminal (in the directory you just went to in the above step):
sudo tar xf vdhcoapp-2.0.2-linux-x86_64.tar.bz2 -C /usr/local
The above command extracts the compressed file that you downloaded to /usr/local
4- Still in terminal, still in the directory where you ran command in step 3, run
sudo /usr/local/vdhcoapp-2.0.2/vdhcoapp install --system
This command installs the companion app (system wide)

1 Like

And remember, next time when you get “exists in filesystem” error when installing this package with package manager, ask jrichard326 how to solve it. :stuck_out_tongue:

For others encountering this issue:

Try using vdhcoapp-bin version 2.0.2-1 from the AUR.

There was a problem with version 2.0.1-1 which had a broken symlink to the helper binary. Additionally, it was only running the post-install hook for the root user, but was not installing it so it never actually ran. I recently found & fixed the post-install hook issue and asked the maintainer to pull from my feature branch. The fixed package is released in versions: 2.0.1-3 and 2.0.2-1

For multi-user systems, the other users will have to manually run:

/usr/bin/vdhcoapp install --user
1 Like

This was the fix!
Even though there is only one user on my system, to get vdhcoapp to work I had to run

/usr/bin/vdhcoapp install --user

Thanks all for your help


Glad it worked! This makes sense if the vdhcoapp-bin package was already installed on the system, an upgrade may not have triggered the post-install hook in the same way as on a fresh install.

Just to clarify and to be useful to others that may have the same issue.
Yes initially it was installed, but during the time it did not work and I tried various suggestions, I uninstalled and re-installed the AUR vdhcoapp-bin a few times.
The last time before I applied your suggestion, I wanted to start clean. so I uninstalled the vdhcoapp and I ‘refreshed’ Firefox. I then had to do all the customisation of Firefox settings as it was before. after that I re-installed the vdh extension, then installed the AUR vdhcoapp-bin. I know that Linux does not need to ‘re-start’ like Windows, but just for good measure I re-started after the install. After that the app was still not installed/working!? That’s when I run your command (/usr/bin/vdhcoapp install --user) and after that all was working.

Just out of curiosity, when you installed the package for the final time, was it using sudo pacman or via pamac + PolKit auth?

I just install it with the GUI package manager pamac. browsed for it, than installed it.
I use the Cinnamon edition of manjaro, I think ‘auth’ is automatically included

Ok, thanks for that info! It turns out that installing via pamac was not setting SUDO_USER, as pamac-cli uses pkttyagent for authentication & privilege escalation instead of sudo.

I found & fixed the issue, and asked the maintainer to merge the hook script fix here.

with vdh in FF118.0.1 the “install --user” did not work.
Pamac installed vdhcoapp 2.0.3 from AUR as an update.
coapp says “no such native application net.downloadhelper.coapp

Seems, it’s looking for annother filename?
vdh installing link leeds to github’s net.downloadhelper.coapp 1.6.3.

I found a solution but dangerous because I don’t really understand, what I did.
First de-/reinstalled vdh and coapp 2.0.3.
Then I run sudo /opt/vdhcoapp/vdhcoapp install --user.
Terminal showed, that native-messaging-hosts-directory was created only in /root.
Not in /usr/lib… where net.downloadhelper.coapp.json shoult be found - as I read somewhere?
So I copied native-messaging-hosts-directory in toto from root into my homedirectory to .mozilla
This worked…
Maybe, it’s also possible to create a mozilla directory for native-messaging-hosts in /usr/lib
Thanks for reading.
Yours horstchen

This will install to the user-level location as root user. Therefore, it’s going to place it in root’s home directory (default: /root). It wouldn’t be recommended to run the --user install as root. It should be run as your current user. The package install hook uses sudo, but it runs with the -u flag, to run as the current user:

sudo -u "${SUDO_USER:-$(id -u -n 1000 )}" /opt/vdhcoapp/vdhcoapp install --user

If you’re running it manually as your desktop user, the only necessary command would be:

/opt/vdhcoapp/vdhcoapp install --user

The /usr/lib location would be the system-level install, which for some reason is broken in current upstream. The user-level install is the only one that worked on Manjaro for me.

The installer should take care of creating all necessary directories in your user’s home. However, if for some reason that’s not the case, then it should be considered a bug in upstream VDHcoapp.

If for some reason the native-messaging-hosts folders are missing in your home directory, and the installer fails to create them, you can manually create them with:

mkdir -p ~/.mozilla/native-messaging-hosts/
mkdir -p ~/.var/app/org.mozilla.firefox/.mozilla/native-messaging-hosts/
mkdir -p ~/.config/google-chrome/NativeMessagingHosts/

One last note: One of the recent package versions, 2.0.3-1, was broken again. The package maintainer seems to have forgotten to re-generate the file checksums in the PKGBUILD via makepkg --geninteg. It looks like folks were able to reach out and ask for this to be fixed. It seems the release in 2.0.3-2 is now working again.

EDIT: It looks like the current version 2.0.3-2 also does not have my --user install hook fix applied. I’ll reach out again to the package maintainer to try and get this included.

EDIT++: I’ve asked the maintainer to merge the fixes here. Savvy yay, pamac, & makepkg users can check out my forked PKGBUILD and perform a local build in the meantime. Otherwise, just follow the manual install instructions above, and/or wait for the next AUR package update.

Thanks for explaining. At last I copied native-messaging-hosts-directory to a newly created /usr/lib/mozilla because /home/.mozilla sometimes moves to one of my othe other linux machines.

I tried this processing with my 32bit debian and
and it worked as well. Somewhere in github I read, there is no 32bit version of vdhcoapp 2.x - but there seems to be one working.