Vboxdrv is missing

I installed virtualbox as mentioned in the manjaro wiki.

sudo pacman -Syu virtualbox linux54-virtualbox-host-modules

The kernel version shows
uname -r

I have linux-headers installed
$ pacman -Q | grep header
linux-api-headers 5.10.13-1
linux54-headers 5.4.100-1

I removed the packages, restart and reinstalled all packages but it still shows vboxdrv is missing. Please help

This post might have a solution for this issue. Since you didn’t post the specific error this is a guess.

When you updated your system? This is old kernel, current from this branch is 5.4.100. Do sudo pacman -Syyu and restart your computer.

I tried that, still getting error:

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver is either not loaded or not set up correctly. Please try setting it up again by executing


as root.

If your system has EFI Secure Boot enabled you may also need to sign the kernel modules (vboxdrv, vboxnetflt, vboxnetadp, vboxpci) before you can load them. Please see your Linux system’s documentation for more information.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.

@ Tomek I ran sudo pacman -Syyu as suggested, I recevied there is nothing to do message.

I also tried installing virtualbox-host-dkms
$ sudo pacman -Sy virtualbox-host-dkms

and got the following error:

(1/2) Arming ConditionNeedsUpdate…
(2/2) Install DKMS modules
==> dkms install --no-depmod -m vboxhost -v 6.1.18_OSE -k 5.4.100-1-MANJARO
==> depmod 5.4.100-1-MANJARO
==> Unable to install module vboxhost/6.1.18_OSE for kernel 5.4.18-1-MANJARO: Missing kernel headers.

This is odd behavior. Did you add kernel to blacklist? Check it in Pamac settings.

You can also install other kernel and try with it.

That not worked, because you need 5.4.100 kernel…

I had some issue with kernel version showing different in uname -r and sudo mhwd-kernel -li, this was causing issues during installing correct headers, I corrected the kernel version issue using this solution and removed and installed virtualbox again. It worked.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.