User mistake, admin passwd when installing

I want to start off with, been using manjaro for a few years and really happy with it. For whatever reason my wife laptop developed some kernel issues and I wanted to re-install.

When I setup the user I gave the user a passwd … I skipped right over the admin passwd section … moved on to the next steps leaving it blank.
Now I can not do any administrative task on the machine. Like sudo to run usermod …

The only other way to fix this I know of is to chroot in & fix it.
Or do another install. Am I missing something?

The single account in manjaro settings manager is listed as a admin account since it installed the system … just no admin passwd was created.

If you did not set the root password during installation, then the root account cannot be logged into, and then you must use the user’s own password with sudo, provided that the user is indeed an admin. So sudo should work, but su won’t.

If you want to set a password for the root account, then you can do so from within your working system as follows… :arrow_down:

sudo -i
# Enter your user's password here
# Enter the root password here.  It will ask you to confirm.

If this is not possible for whatever reason, then you must boot up from the installer USB/DVD/CD in live mode, open up a terminal window, and issue the following commands… :arrow_down:

sudo su -
manjaro-chroot -a
# Enter the root password here.  It will ask you to confirm.

After this you can safely reboot and remove the USB or optical medium.


Thank you very much for the help.
I did try sudo -i … still not accepting the passwd. … So I cant use sudo.

It is possible there is another issue. If the laptop is inactive, goes to sleep.
At the sddm login screen it will not accept her user passwd there either.
It is setup for auto login. The only way around this is to select switch user then from the menu choices reboot … then it just auto login on restart.
I still blame this issue on not setting a admin passwd since she is the admin.
I’m kinda wondering why it even goes to sddm if setup for auto login?

We are both doing things this afternoon we agreed in the morning while I drink my coffee she would let me have it to fix or reinstall.
I will reply back then to see what I ended up doing …

So I will try that first, if it does not work I will reinstall and report back tomorrow to hopefully close the thread.

I will add that for whatever reason another pc tower failed to complete a update yesterday … I was not watching it while it updated … the updater said it had failed … I saw there were 83 updates remaining.
I tried to restart the updater, or open a terminal … firefox was opened & kinda worked but had issues. So I just rebooted it. I could do nothing with a unresponsive machine.
It simply failed to boot with so many systems that could not be started.
Since I was outside away from machine I never saw any warnings or messages … just came back to a unresponsive machine.

So since I just created a fresh usb stick to for the wife laptop, I used it on my tower and it works fine. The burn was successful.

It was at that moment when I was installing on my tower & I got to the admin passwd part … I got the DOH! moment, thinking I did not do that yesterday on the wife machine.

Will report back tomorrow.

I’m thinking that you probably didn’t set a password at all. So after auto-login — no need to do the live USB thing — just set a password for her account… :arrow_down:

# Enter the password here.  It will ask you to confirm.

After this, sudo should work.

And as for… :arrow_down:

It’s probably broken now, so see this tutorial… :arrow_down:

However, this is really a separate issue, so if you need more help with that machine, then please start a new thread.

I only posted that info to confirm my newly created usb was known to be good. Which is relevant to this thread.

Truth be told I wanted the wired connection from my tower to do the install on the laptop … was then I realized the repairman had set the desk leg on top of the Ethernet cable … while lifting the corner of the heavy desk trying to remove the cable … the tower tipped over & hit hard on the shelf while it was running. … was still working fine when I stood it back up. … Then I updated it and it failed.
No sir, I will not be asking for help on that machine … although a fresh install seemed to fix it, I need to tear it down & reinstall all hardware.
Will reply tomorrow with my fix on this problem.

I really want to thank Aragorn for volunteering their time to help me with this issue.
While I was really curious about the chroot method … I was also skeptical if it would work.

I have never been accused of being smart, just a old retired carpenter. I remember installing gentoo/kde on a P-4. What a nightmare when uefi & systemd came along. I probably have chroot 50 times in the 15 years I ran it.

Now your telling me I can boot live, gain root then a single command chroot in? … I’m really skeptical … this winter I will play with it and see.

I drank 2 cups of coffee while doing a fresh install this morning on her laptop, took about 30 minutes have it all setup … 3rd install in 3 days.
Wife is happy & I’m in the shop working on things I want to do.

Everything is fine now.

manjaro-chroot is a tool developed by Manjaro. It will scan your drive for installed GNU/Linux systems — if it finds more than one, it will allow you to choose the one you want to chroot into — and it will then mount the necessary filesystems and pseudo-filesystems (such as /proc and /sys) and chroot into the system.

The only caveat is that it doesn’t work with btrfs, because of the subvolumes. It does however work very well with ext4. :wink:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.