USB thumb drive shows with lsusb but not lsblk

I have a USB thumb drive that I am unable to mount. After plugging in the USB, it will not show up in PCManFM. No errors in dmesg, and it shows in lsusb. Not in lsblk nor gparted though. Any ideas?

$ sudo dmesg -w

2157453.080944] usb 1-4.4: new high-speed USB device number 22 using xhci_hcd
[2157453.172388] usb 1-4.4: New USB device found, idVendor=154b, idProduct=6002, bcdDevice=11.00
[2157453.172391] usb 1-4.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[2157453.172392] usb 1-4.4: Product: Hook Attache
[2157453.172393] usb 1-4.4: Manufacturer: PNY
[2157453.172393] usb 1-4.4: SerialNumber: ***

$ lsusb

Bus 001 Device 022: ID 154b:6002 PNY Hook Attache

Using lsblk or gparted, this USB thumb drive do not show up.

If you are use the stick is workiung - it may be incompatible - for unknown reasons - with Linux.

I cannot say why - I have never had a device like it.

It seems it is a hit or miss with the PNY brand

Just a thought - if the device is not listed by lsblk - it has not identified itself as a storage device - the question must be - when it is a storage device - something must be wrong when it does not identify itself correct.

1 Like

I tried with other USB thumbs, I had laying around. Same results with all of them. None of them show up in lsblk.

lsusb results of the drives I now have tried:

Bus 001 Device 022: ID 154b:6002 PNY Hook Attache
Bus 001 Device 024: ID abcd:1234 LogiLink UDisk flash drive
Bus 001 Device 025: ID 0781:5567 SanDisk Corp. Cruzer Blade
Bus 001 Device 026: ID 0781:5581 SanDisk Corp. Ultra
Bus 001 Device 027: ID 0951:1666 Kingston Technology DataTraveler 100 G3/G4/SE9 G2/50
Bus 001 Device 029: ID 0781:5204 SanDisk Corp. Cruzer Crossfire

So, maybe there is something weird with my system? Other USB devices work fine.

Then it is a system issue - mandatory question: Is your system up-to-date?

sudo pacman -Syu

And have you restarted - if your kernel has been updated - it may cause weird issues if you do not restart the system.

A while back I posted a script which uses checkupdates to do a prelimenary check on the pending updates - if any of those would suggest a system restart.

1 Like

Thanks! My system is up-to-date, but maybe I have done a kernel upgrade, without rebooting. That might be the issue. I will check and report back.

And you were absolutely spot on, @linux-aarhus! One reboot later, and all works well.

The fact that Manjaro runs so smoothly makes me forget rebooting. Back in my Windows days, I rebooted quite often. I will, however, make a note to always reboot after kernel upgrades.

Thank you!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.