USB opens in ranger

i’ve been running Manjaro gnome for a while now and there’s one thing that keeps bugging me, if i open my USB from the desktop (using Desktop Icons NG) or from arc menu it opens in ranger… now, i don’t want it opening there, i want it to open in nautilus… Is there any way to change that? i’ve been looking for a bit but i can’t find anything to change it

xdg-mime default nautilus.desktop inode/directory
oh thats the old way; bill_t solved it correctly

Just tried to run that in terminal but it didn’t do anything :confused:

Pl. try:

or i’m doing something wrong or something is wrong with my system as it still defaults to ranger for some reason…

Well, you can try to de-install ranger…
The most brutal way… - no ranger no default to

Btw, the version of gnome-shell-extension-desktop-icons-ng in pamac is 17
but in is 22. But I run Gnome40 (I am on unstable now)
Installed Extensions - GNOME Shell Extensions
You must first de-install the version in pamac (without dependencies!!!)
then reboot and then install from

Let us try terminal: sudo /usr/share/applications/mimeinfo.cache
look for entry: inode/directory=nautilus.desktop;
if different, then correct it.
Do not forget the ;

all the same in a new created /home/test account?

The desktop file of Nautilus in /usr/share/applications/ is called org.gnome.Nautilus.desktop, so in a terminal window try the following command

xdg-mime default org.gnome.Nautilus.desktop inode/directory

and see if that works.

1 Like

This has worked! thanks!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.