Usb not working on windows 7 after switching system from manjaro

my windows was infected and i needed something thats resistant to viruses so a buddy recommended linux and i tried manjaro, u can say its my first time with this system so im an extreme noob i cannot even instal or search programs i need for my own yet, anyways i installed manjaro without deleting infected windows so i can move all the… “important files…” from my system to the linux partition then i installed same windows 7 after formatting partition with previous windows i had some problems with the updates however i installed most of it some are getting weird errors, anyway when i am on windows 7 close system down and then run windows 7 again everything is fine, manjaro closing and opening again still fine, from windows to manjaro is fine too the only problem is when i run windows after i closed manjaro usb not responding at all, front and back, keyboard mouse usbwifi… everything dead so i got no options but to close it with power button on motherboard then i try running it in safe mode wich means usb are working in bios, i installed drivers thru driver booster free program which may be an important information, after few times opening system in safe mode it will start working again (numbers of times various sometimes once sometimes more) then when it works i restart in normal mode and it runs normally
here is my motherboard
gigabyte H81M-DS2V
if someone want info from dxdiag about other things i try to write it out cus i cant post screencap

Hi and welcome to the forum :+1:

I was interested in reading your problem, but your wall of text did me decide to skip it.
Please reformat your text with proper newlines and i will try again…

1 Like

after the person response above i decided to remove the system by cleaning partition so this thread can be closed or deleted or whatever u want to do with it, i thought linux community care more about system not someones poor english

You seem very sensitive.

Asking for proper formatting for ease of reading makes you decide to uninstall an OS? OK good luck in your life then, you’ll hit harder walls.

See I have paragraphs, it makes it more readable.

That is very true, but we (at least me) do care about proper formatting.

If you did not even understand what i wrote there because your english is insufficient then it is maybe better to do what you did and have fun :wave:

@electricatom oh boy :man_facepalming:

Even if you don’t care, but i read your wall of text and honestly i have no idea what you did. Beside that, this is not a support forum for windows problems.

Linux/Manjaro don’t touch the firmware and therefore the cause of the not working USB can’t be due Manjaro.

use a translater like that one (for better understanding):

I’m actually surprised you got any updates to work on Win7 as it’s been out of support for some time now. Likely the USB drivers are no longer available, at least via whatever server(s) your updates came from.

I had a similar problem some years back when trying to get a rellie’s machine working after a Win7 reinstall … WiFi drivers nowhere to be found, including the manufacturer … some of the drivers were there but not the WLAN card or the graphics chipset …