Usb Mouse and Keyboard not working after Shutdown and Restart

OK I have some weird problem since lately.

When I shutdown Manjaro and reboot for some reason usb mouse and keyboard is not detected anymore. Unfortunately at this state I cannot check anything because its a desktop pc so no integrated keyboard…

Now when I boot into a live Manajro from usb stick and then inside the live manjaro hit restart computer which then boots into the installed manjaro mouse / keyboard works normal again.

But as soon as I shutdown and restart it stops working and I have to take again the road via the live manjaro.

Please let me know what I could check to fix it.


-Replugging the usb mouse / keyboard does not fix the issue. Only going via the live manjaro boot fixes it until next system shutdown.

Did you try unplugging your mouse and keyboard, then replugging them in?

I had the same issue 3 days ago until I unplugged and replugged. Weirdly enough, it worked fine in Windows without having to replug.

Hi, sandro!
We did not see you here for a long time! Forgot about us? Had a good vacation somewhere? :slight_smile:
Now time to act.

  1. why you did not mention what happens if to pull out and inject again the USB connectors from keyboard and mouse: does the devices recognized well after that action or not?
    USB is designed to be hot-swapable, why not to try it?

  2. Take a look at the [HowTo] Increase your chances of receiving help

  3. After that, try to find corresponding info, including:
    As it is hardware-involved issue, I would start from seeing the kernel messages:

journactl -k -pX -bY -o short-monotonic --no-host

see man journalctl what X value to set better, try different. The same is for Y: check what it is and find in the journactl --list-boots your index of that (those) unsuccessful boot ups.

  1. Try to switch to another USB port version: 2.0 <-> 3.0+ (may be exact USB version drivers involved).
for example I have different USB drivers on each USB version
lspci -k
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
        Subsystem: Intel Corporation Device 7270
        Kernel driver in use: xhci_hcd
        Kernel modules: xhci_pci
00:14.1 USB controller: Intel Corporation Device 9d30 (rev 21)
        Subsystem: Intel Corporation Device 7270
        Kernel driver in use: dwc3-pci
        Kernel modules: dwc3_pci
  1. Also, did you moved to another kernel recently? Try to move back or/and to another kernels and check if it works.

How did you solve it? Or leaved to constantly re-plug them on each boot up?

Got to the display manager, unplugged my mouse and keyboard, replugged them in, worked from then on.

Yes I tried repluging and also plugged to other usb ports with no luck.

Only boot in the manajro live cd and then press restart fixes it until the next complete shutdown…

and btw I cannot even log in or do anything because i have no mouse and keyboard working.

I tried also different kernels but no success not far. I will check the other things you suggest.

journalctl just gives this:

sudo journalctl -k -pX -bY -o short-monotonic --no-host
[sudo] password for sandro:
Unknown log level X

I would research for solutions in your firmware settings. There are to many possible options to be set / unset for anybody to help you with regard to firmware settings, ideally check for a manual of your mainboard supplier.

What do you mean with firmware settings? The strange thing is the issue was not present before. I did not change any settings in the BIOS of the mainboard or something.

BIOS / UEFI menu - that’s what I meant with firmware.

But I changed nothing in the UEFI Usb settings and USB works with no issues on Windows and when I boot into Manjaro live CD.

I think I’m encountering some kind of similar issue, didn’t find solution yet. Sometimes – just sometimes – when I boot into system some of my USB ports looks like completely disabled (mouse don’t even has enabled lights), but when I plug in another ports it works. Yet that happens only sometimes, usually that port works again after reboot, but that’s still very annoying.

I installed the latest updates from this month and somehow the issue is gone. very strange all of it…