Usb headset pcm2902 code mic not detectable

Hello after latest manjaro update the mic of my usb headset is not detected by pipewrie/pulseaudio.

arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: Device [USB PnP Sound Device], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: SB [HDA ATI SB], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: SB [HDA ATI SB], device 2: ALC892 Alt Analog [ALC892 Alt Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

No input profiles are available:

but the digital profiles of my usb headset seem to show under my analog sound card:

I tried downgrading pipewire pulseaudio alsa kernel linux-firmware but nothing works. Could anyone help me with this?

ok i fixed it according to : PipeWire - ArchWiki

i edited as root /etc/pipewire/media-session.d/alsa-monitor.conf and
api.alsa.use-acp = true → api.alsa.use-acp = false
#api.alsa.use-acp = false → api.alsa.use-acp = true

and then i did

systemctl --user enable pipewire.service pipewire-pulse.service

rebooted and mic works as it should now with pipewire fully enabled

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.